pb tty sur live-Cd ubuntu (7.04-desktop-amd64)

Le
markorki
bonjour,
Je parlais il y a quelques jours de mes tentatives de wifi avec une
live-box, avec un live-CD ubuntu sur le portable de ma fille. Elle a
récupéré son PC quelque temps donc point mort provisoire.
J'ai donc essayé ce live-CD (<ubuntu-7.04-desktop-amd64.iso) avec mon PC
"puissant" (!) actuellement sous 98SE, 3 DD (ide 0:0, 0:1, 1:0), 4
lecteurs optiques SCSI (dont 2 graveurs), donc en boot sur SCSI.

La bonne nouvelle est que le live-CD est détecté tout seul par le BIOS
de la carte SCSI, ensuite j'ai testé les choix "boot and install" et
"boot in safe graphic mode", et les 2 coincent au même moment (parce que
départ sur SCSI?)

le message d'erreur est :
/bin/sh "can't access tty"; job control turned off
la mention "Busy box v1.1.3(debian 1:1.1.3-3ubuntu3)
et en-dessous, le prompt (initramfs)

si je tape "help", j'ai une liste de commandes, où il n'y a pas "find".
dommage parce que j'espérais avoir accès à un DD ou une clé usb ou une
carte flash, tous perifs que je vois, mais auxquels je ne peux pas
accéder : tout est en ram, je vois /dev, /etc, mais je ne trouve pas de
fstab, et je ne peux donc faire aucun "mount", à moins de créer un fstab
quelque-part dans le PATH (où ?), mais je ne connais pas son format par
coeur

dommage, parce que je vois très bien toutes mes mémoires de masse, en
disk/by-id , by-label, by-path ou by-uuid
en particulier je vois mon lecteur de cartes flash en
disk/by-id/usb-Generic_STORAGE_DEVICE_0810-0:n (n =0,1,2, ou 3)

Alors, installation obligatoire, ou y a-t-il un moyen de décoincer à ce
stade et de convaincre le system de continuer vers le mode graphique que
j'avais sans pb sur le portable ?
(en plus, j'ai beau savoir taper sur un clavier français que
l'interprêteur prend pour un américain, c'est assez coton pour certains
caractères :)

question subsidiaire : L'installation permet-elle de choisir son DD ou
va-t-elle tenter uniquement le master d'IDE0 (soit ide 0:0)?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Xavier Dupeyré
Le #1903435
Bonjour,

markorki a écrit le 04/10/2007 :

Je parlais il y a quelques jours de mes tentatives de wifi avec une
live-box, avec un live-CD ubuntu sur le portable de ma fille. Elle a
récupéré son PC quelque temps donc point mort provisoire.
J'ai donc essayé ce live-CD (<ubuntu-7.04-desktop-amd64.iso) avec mon PC
"puissant" (!) actuellement sous 98SE, 3 DD (ide 0:0, 0:1, 1:0), 4
lecteurs optiques SCSI (dont 2 graveurs), donc en boot sur SCSI.


Je ne suis absolument pas spécialiste, mais est-ce que ce ne serait pas
la version 64 bits qui pose problème ?
Peut-être qu'en essayant avec la version Intel x86 ... ?

--
Xavier
--
"Ce que nous vendons à Coca-Cola, c'est du temps de cerveau humain
disponible"
Patrick Le Lay, pdg de TF1

markorki
Le #1903432

Bonjour,

markorki a écrit le 04/10/2007 :


Je parlais il y a quelques jours de mes tentatives de wifi avec une
live-box, avec un live-CD ubuntu sur le portable de ma fille. Elle a
récupéré son PC quelque temps donc point mort provisoire.
J'ai donc essayé ce live-CD (<ubuntu-7.04-desktop-amd64.iso) avec mon PC
"puissant" (!) actuellement sous 98SE, 3 DD (ide 0:0, 0:1, 1:0), 4
lecteurs optiques SCSI (dont 2 graveurs), donc en boot sur SCSI.



Je ne suis absolument pas spécialiste, mais est-ce que ce ne serait pas
la version 64 bits qui pose problème ?
Peut-être qu'en essayant avec la version Intel x86 ... ?

Il s'agit bien dans les 2 cas (PC de bureau et portable Asus) de

machines à base d'AMD-64 bits)... l'un en "Athlon64", l'autre en Turion
simple-coeur, mais le code d'erreur ne me semble pas évoquer un pb de
jeu d'instructions (entre Athlon64 et Turion, ça doit peu différer, et
la gestion des "instructions particulières", si différence il y avait,
je doute que ça plante linux)
alors bien sûr je peux télécharger et graver une autre iso, mais si je
change d'iso à chaque pb... et puis, le portable démarre en graphique et
voit toutes ses ressources (enfin pour le wifi, ça reste à tester), au
moins les partitions, le lecteur de cartes, le graveur, et bien sûr
souris, clavier et "touchpad".


sansflotusspam
Le #1903427
markorki <moicestmarkorkichezorangefr> a commis :


Bonjour,

markorki a écrit le 04/10/2007 :


Je parlais il y a quelques jours de mes tentatives de wifi avec une
live-box, avec un live-CD ubuntu sur le portable de ma fille. Elle a
récupéré son PC quelque temps donc point mort provisoire.
J'ai donc essayé ce live-CD (<ubuntu-7.04-desktop-amd64.iso) avec mon
PC "puissant" (!) actuellement sous 98SE, 3 DD (ide 0:0, 0:1, 1:0), 4
lecteurs optiques SCSI (dont 2 graveurs), donc en boot sur SCSI.



Je ne suis absolument pas spécialiste, mais est-ce que ce ne serait
pas la version 64 bits qui pose problème ?
Peut-être qu'en essayant avec la version Intel x86 ... ?

Il s'agit bien dans les 2 cas (PC de bureau et portable Asus) de

machines à base d'AMD-64 bits)... l'un en "Athlon64", l'autre en
Turion simple-coeur, mais le code d'erreur ne me semble pas évoquer un
pb de jeu d'instructions (entre Athlon64 et Turion, ça doit peu
différer, et la gestion des "instructions particulières", si
différence il y avait, je doute que ça plante linux)
alors bien sûr je peux télécharger et graver une autre iso, mais si je
change d'iso à chaque pb... et puis, le portable démarre en graphique
et voit toutes ses ressources (enfin pour le wifi, ça reste à tester),
au moins les partitions, le lecteur de cartes, le graveur, et bien sûr
souris, clavier et "touchpad".


as-tu tenté de désactiver au boot les machins apic, acpi, etc, ?
ce sont les grands classiques du boot bloqué



markorki
Le #1903426

as-tu tenté de désactiver au boot les machins apic, acpi, etc, ?
ce sont les grands classiques du boot bloqué

dans le BIOS ?

non, excellente idée !
gestion énergie, réveil par USB, et quoi d'autre ?
je crois que j'ai "arrêt sur toute erreur", je garde (je suppose que
c'est périf en rade dont clavier, ou ram ne répondant pas)
à ce propos, passé le test de ram hier (c'est dans le menu du CD) :
long, mais OK

markorki
Le #1903425

as-tu tenté de désactiver au boot les machins apic, acpi, etc, ?
ce sont les grands classiques du boot bloqué

dans le BIOS ?

non, excellente idée !
gestion énergie, réveil par USB, et quoi d'autre ?
(quoique le boot dure 3mn seulement)
je crois que j'ai "arrêt sur toute erreur", je garde (je suppose que
c'est périf en rade dont clavier, ou ram ne répondant pas)
à ce propos, passé le test de ram hier (c'est dans le menu du CD) :
long, mais OK

sansflotusspam
Le #1903421
markorki <moicestmarkorkichezorangefr> a commis :


as-tu tenté de désactiver au boot les machins apic, acpi, etc, ?
ce sont les grands classiques du boot bloqué

dans le BIOS ?

non, excellente idée !


j'oubliais aussi la directive "nolapic" à mettre à l'init ; si l'option
existe au boot du CD (DVD), on peut aussi tenter de démarrer en
failsafe.

gestion énergie, réveil par USB, et quoi d'autre ?


on essaye déjà de booter, mettre en sommeil viendra après ...

(quoique le boot dure 3mn seulement)
je crois que j'ai "arrêt sur toute erreur", je garde (je suppose que
c'est périf en rade dont clavier, ou ram ne répondant pas)
à ce propos, passé le test de ram hier (c'est dans le menu du CD) :
long, mais OK


quand le clavier, la ram, ou un autre truc indispensable, merde,
normalement, le bios fait des bips qui ont un sens (voir manuel de la
carte mère) ; le clavier qui ne va pas, ça fait des bips longs (en
général).

PS - sous Win$, il y a un message d'erreur exemplaire, du pur
Micro$oft :
"votre clavier ne répond pas, appuyez sur la touche F1 pour résoudre le
problème"


markorki
Le #1903420

PS - sous Win$, il y a un message d'erreur exemplaire, du pur
Micro$oft :
"votre clavier ne répond pas, appuyez sur la touche F1 pour résoudre le
problème"

héhé, j'ai connu un système dont je tairai le nom (antérieur à

l'arrivée d'Unix en europe) où le libellé du message "disk-error" était
stocké sur le disque système (et pas en ram), à une époque où souvent
(95% des cas) on avait un seul disque ;-)

c'était un OS qui pratiquait l' "understatement" :quand le libellé était
vide, les "vieux routiers" soupçonnaient la nature de l'erreur...

Nicolas George
Le #1903419
sansflotusspam wrote in message
PS - sous Win$, il y a un message d'erreur exemplaire, du pur
Micro$oft :
"votre clavier ne répond pas, appuyez sur la touche F1 pour résoudre le
problème"


Du pur microsoft... sauf que ce sont les BIOS, qui font ce genre de
messages, et qu'ils n'ont, pour le moment encore, pas grand chose à voir
avec microsoft.

Fabien LE LEZ
Le #1903411
On Thu, 04 Oct 2007 19:00:21 +0200, sansflotusspam

"votre clavier ne répond pas, appuyez sur la touche F1 pour résoudre le
problème"


Sous Windows, il me semble qu'on peut simuler un clavier à la souris.
C'est pas très rapide, mais ça permet de "taper" F1 sans utiliser le
clavier.

Il y a par contre un message BIOS du style "Keyboard error, press F1
to continue". Celui-là est parfaitement légitime : si, au démarrage de
la machine, une touche du clavier est enfoncée, ou si tu as appuyé sur
une touche au mauvais moment, certains BIOS considèrent qu'il y a un
problème de clavier. S'il se trompe, et que tu considères que le
clavier fonctionner bien, tu peux le lui indiquer en tapant F1 -- ce
qui est possible puisque justement ton clavier fonctionne.

markorki
Le #1904611
markorki <moicestmarkorkichezorangefr> a commis :


as-tu tenté de désactiver au boot les machins apic, acpi, etc, ?
ce sont les grands classiques du boot bloqué

dans le BIOS ?

non, excellente idée !



j'ai fait : même topo, normal, il faut moins de 2mn pour arriver au
blocage depuis le lancement du boot

j'oubliais aussi la directive "nolapic" à mettre à l'init ; si l'option
existe au boot du CD (DVD), on peut aussi tenter de démarrer en
failsafe.


gestion énergie, réveil par USB, et quoi d'autre ?


on essaye déjà de booter, mettre en sommeil viendra après ...

ok, ça boote, mais je n'ai qu'un shell, limité, quand on me donne la main


(quoique le boot dure 3mn seulement)
je crois que j'ai "arrêt sur toute erreur", je garde (je suppose que
c'est périf en rade dont clavier, ou ram ne répondant pas)
à ce propos, passé le test de ram hier (c'est dans le menu du CD) :
long, mais OK


quand le clavier, la ram, ou un autre truc indispensable, merde,
normalement, le bios fait des bips qui ont un sens (voir manuel de la
carte mère) ; le clavier qui ne va pas, ça fait des bips longs (en
général).

Je crois qu'il faut exclure l'erreur matérielle, puisque mon 98SE peut

tourner des heures en utilisant toutes ses ressources (sauf la carte
wifi, qui voit mon réseau sans fil "wanadoo" mais ne "communique" pas
avec mon navigateur, une des raisons qui me ferait sauter le pas vers
linux)

j'ai donc essayé ce live-CD sur un PC de bureau AMD 64, avec SCSI, et
les 3 boots
- start or install
- start in safe graphics mode
- check CD for defects
arrivent au même message "can't acces tty"

j'ai même tenté de changer de paramètre par F6, mais là il faudrait que
je trouve la doc sur
:e=true inird=/casper/...

je suis refroidi sur le live-CD ubuntu amd64...
vais voir si un banal Ix86 me mènera qq part ;-(
(à moins que j'aie justement chargé une version réputée ratée :
ubuntu-7.04-desktop-amd64.iso)

l'echec du "check CD for defects" indique-t-il un problème de crc entre
téléchargement et gravage ou juste (puisque c'est le même message dans 3
cas) un pb dans le début d'exécution du boot ?



Publicité
Poster une réponse
Anonyme