Periode de temps fixe et variable et somme valeur des periodes

Le
Baton .rouge
Bonjour

J'ai un logiciel qui me sort des valeurs du style :


10:05:02 20
10:05:30 10
10:06:25 15
10:09:38 25
10:11:52 20
10:12:39 25
10:14:59 14
10:16:02 15
10:17:32 18
10:30:07 23

Je cherche à faire la somme des valeurs par plage de 5mn :

10:05:00 70
10:10:00 59
10:15:00 33
10:20:00 0
10:25:00 0
10:30:00 23


J'ai près de 500.000 lignes comme ça. et des Milliers de fichiers.

Si excel 2003 n'est pas adapté pour ça (65k ligne max), je peux
utiliser access

Merci de vos lumières



--
Les assistés du CAC 40 :
http://www.youtube.com/watch?feature=player_detailpage&v=W5Yx_diRxA8#tH
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #26328576
Bonsoir
Juste une question:
Comment arrives-tu à ce résultat: 10:05:00 70 ?
Veux-tu additionner toutes les valeurs comprises entre 10:00:00,00 et
10:04:59,99?
Ou simplement compter le nombre de valeurs comprises dans cette fourchette?


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Baton .rouge" a écrit dans le message de groupe de discussion :


Bonjour

J'ai un logiciel qui me sort des valeurs du style :


10:05:02 20
10:05:30 10
10:06:25 15
10:09:38 25
10:11:52 20
10:12:39 25
10:14:59 14
10:16:02 15
10:17:32 18
10:30:07 23

Je cherche à faire la somme des valeurs par plage de 5mn :

10:05:00 70
10:10:00 59
10:15:00 33
10:20:00 0
10:25:00 0
10:30:00 23


J'ai près de 500.000 lignes comme ça. et des Milliers de fichiers.

Si excel 2003 n'est pas adapté pour ça (65k ligne max), je peux
utiliser access

Merci de vos lumières



--
Les assistés du CAC 40 :
http://www.youtube.com/watch?feature=player_detailpage&v=W5Yx_diRxA8#tH


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
Baton .rouge
Le #26328606
On Thu, 11 Dec 2014 23:33:25 +0100, "Jacquouille"

Veux-tu additionner toutes les valeurs comprises entre 10:00:00,00 et
10:04:59,99?



oui, c''est bien ça.

--
Les assistés du CAC 40 :
http://www.youtube.com/watch?feature=player_detailpage&v=W5Yx_diRxA8#tH
Jacquouille
Le #26328655
E n A1, le titre de la colonne.
La plage A2:A100 appelée dat

la formule --> =Sommeprod((dat>:00:00,00)*(dat<10:05:00,00))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Baton .rouge" a écrit dans le message de groupe de discussion :


On Thu, 11 Dec 2014 23:33:25 +0100, "Jacquouille"

Veux-tu additionner toutes les valeurs comprises entre 10:00:00,00 et
10:04:59,99?



oui, c''est bien ça.

--
Les assistés du CAC 40 :
http://www.youtube.com/watch?feature=player_detailpage&v=W5Yx_diRxA8#tH


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
http://www.avast.com
DanielCo
Le #26328666
Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) en ligne 1 :
=SOMMEPROD(($A$1:$A$10>="10:"&(LIGNE()-1)*5)*($A$1:$A$10<"10:05"*1)*$B$1:$B$10)
à recopier vers le bas.
Cordialement.
Daniel


Bonjour

J'ai un logiciel qui me sort des valeurs du style :


10:05:02 20
10:05:30 10
10:06:25 15
10:09:38 25
10:11:52 20
10:12:39 25
10:14:59 14
10:16:02 15
10:17:32 18
10:30:07 23

Je cherche à faire la somme des valeurs par plage de 5mn :

10:05:00 70
10:10:00 59
10:15:00 33
10:20:00 0
10:25:00 0
10:30:00 23


J'ai près de 500.000 lignes comme ça. et des Milliers de fichiers.

Si excel 2003 n'est pas adapté pour ça (65k ligne max), je peux
utiliser access

Merci de vos lumières
Baton .rouge
Le #26328668
On Fri, 12 Dec 2014 12:25:13 +0100, DanielCo wrote:

Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) en ligne 1 :
=SOMMEPROD(($A$1:$A$10>="10:"&(LIGNE()-1)*5)*($A$1:$A$10<"10:05"*1)*$B$1:$B$10)
à recopier vers le bas.
Cordialement.
Daniel



Merci à vous 2.


--
Les assistés du CAC 40 :
http://www.youtube.com/watch?feature=player_detailpage&v=W5Yx_diRxA8#tH
DanielCo
Le #26328673
Oups.
=SOMMEPROD(($A$1:$A$10>=("10:"&(LIGNE()-1)*5)*1)*($A$1:$A$10<("10:"&(LIGNE()-1)*5+5)*1)*$B$1:$B$10)
plutôt..
Daniel


Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) en ligne 1 :
=SOMMEPROD(($A$1:$A$10>="10:"&(LIGNE()-1)*5)*($A$1:$A$10<"10:05"*1)*$B$1:$B$10)
à recopier vers le bas.
Cordialement.
Daniel


Bonjour

J'ai un logiciel qui me sort des valeurs du style :


10:05:02 20
10:05:30 10
10:06:25 15
10:09:38 25
10:11:52 20
10:12:39 25
10:14:59 14
10:16:02 15
10:17:32 18
10:30:07 23

Je cherche à faire la somme des valeurs par plage de 5mn :

10:05:00 70
10:10:00 59
10:15:00 33
10:20:00 0
10:25:00 0
10:30:00 23


J'ai près de 500.000 lignes comme ça. et des Milliers de fichiers.

Si excel 2003 n'est pas adapté pour ça (65k ligne max), je peux
utiliser access

Merci de vos lumières
Publicité
Poster une réponse
Anonyme