Perte de /dev/hda1 sous lenny

Le
marc
Bonjour à toutes et à tous,

Bon mon Pb n'est pas simple à expliquer Commençons par le début.

J'ai un noyau 2.18 et un 2.21 sur ma lenny:

root@ServerDebian:/home/marc2# uname -a
Linux ServerDebian 2.6.21-2-686 #1 SMP Wed Jul 11 03:53:02 UTC 2007 i686
GNU/Linux

lorsque je me connecte en 2.18 je vois mon /boot/grub sans soucis.
un ls -las de /dev me donne:
brw-rw- 1 root disk 3, 0 2007-10-06 16:46 hda
brw-rw- 1 root disk 3, 1 2007-10-06 16:47 hda1
brw-rw- 1 root disk 3, 2 2007-10-06 16:46 hda2
brw-rw- 1 root disk 3, 5 2007-10-06 16:46 hda5
brw-rw- 1 root disk 3, 64 2007-10-06 16:46 hdb
brw-rw- 1 root disk 3, 65 2007-10-06 16:46 hdb1
brw-rw- 1 root disk 3, 66 2007-10-06 16:46 hdb2
brw-rw- 1 root disk 3, 69 2007-10-06 16:46 hdb5
brw-rw- 1 root cdrom 22, 0 2007-10-06 16:46 hdc
brw-rw- 1 root cdrom 22, 64 2007-10-06 16:46 hdd

un mount:

/dev/mapper/ServerDebian-root on / type ext3 (rw,errors=remount-ro)
tmpfs on /lib/init/rw type tmpfs (rw,nosuid,mode55)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
procbususb on /proc/bus/usb type usbfs (rw)
udev on /dev type tmpfs (rw,mode55)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,modeb0)

*********> /dev/hda1 on /boot type ext3 (rw)

/dev/mapper/ServerDebian-home on /home type ext3 (rw)
/dev/mapper/ServerDebian-tmp on /tmp type ext3 (rw)
/dev/mapper/ServerDebian-usr on /usr type ext3 (rw)
/dev/mapper/ServerDebian-var on /var type ext3 (rw)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc
(rw,noexec,nosuid,nodev)

Et donc pas de soucis, lorsque je passe sous mon pépin 2.21:
dans le ls -las de /dev je ne vois plus hda1,
certes je récupére tout mes petits (grâce à LVM je supose) quand même,
sauf /boot (Normalement chez moi sur /dev/hda1).

Du coup pas possible de passer à un 2.22 puisque je n'arrive pas à
monter ma partoche!!!

un kdf en root (je sais c'est pas bien mais bon je ne suis pas un as
systeme) me donne:
mount -text3 -odefaults /dev/hda1 /boot
mount: special device /dev/hda1 does not exist

Ben oui j'avais remarqué.

Infos Complémentaires:
http://marc.jarlegand.free.fr/public/dmesg_2.21.txt
http://marc.jarlegand.free.fr/public/fstab_2.21.txt
http://marc.jarlegand.free.fr/public/mtab_2.21.txt
http://marc.jarlegand.free.fr/public/mount_2.21.txt

La je nage grave!!!
Surtout qu'il y a quelques jours mon répertoire perso c'est transformé
tout seul à l'insu de mon plein gré en périphérique bloc !!!

Un p'tit coup de main, ou une poignée d'idée serait bien venue.

Merci
Librement
Marc





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #9758131
marc, samedi 6 octobre 2007, 17:52:20 CEST

Bonjour à toutes et à tous,



’soir,

Bon mon Pb n'est pas simple à expliquer



Ce sont surtout tes explications qui sont, euh, torteuses…

[…]
Et donc pas de soucis, lorsque je passe sous mon pépin 2.21:
dans le ls -las de /dev je ne vois plus hda1, ...



Nous le donner aurait été sympa (parce que ce qui ne fonctionne
pas est plus intéressant que ce qui marche). Enfin bon, c’est pas
grave, on se débrouillera sans.

certes je récupére tout mes petits (grâce à LVM je su pose)
quand même, sauf /boot (Normalement chez moi sur /dev/hda1).



Normal, pas de /boot en LVM.

Du coup pas possible de passer à un 2.22 puisque je n'arrive
pas à monter ma partoche!!!



Bon, je ne vois pas trop ce qui t’empêche de passer en 2._6. _22
à partir du 2.6.18 mais on va quand même régler ton problà ¨me.

[…]
Infos Complémentaires:



Bonne idée.

http://marc.jarlegand.free.fr/public/dmesg_2.21.txt
http://marc.jarlegand.free.fr/public/fstab_2.21.txt
http://marc.jarlegand.free.fr/public/mtab_2.21.txt
http://marc.jarlegand.free.fr/public/mount_2.21.txt

La je nage grave!!! […]



Tout est dans dmesg : les disques ATAPI ne sont plus nommés hdX
mais sont maintenant gérés comme les disques SATA et SCSI et sont
nommés sdX.

Ton lecteur de cartes 5 en 1 prend les périphériques sda à sde.
Tes deux disques dur sont devenus sdf et sdg.

Ton /dev/hda1 est donc devenu /dev/sdf1.

La solution courte est de modifier ton fstab (hda1 → sdf1) mais
ça inverse le problème pour le 2.6.18.

Une meilleure solution, plus durable : utiliser une étiquette
pour cette partition. Pour cela (« monboot » est l’à ©tiquette, tu
peux mettre ce que tu veux ou presque) :

— tune2fs -L monboot /dev/hda1 (ou sda1, suivant le noyau) ;
— modifie fstab en remplaçant /dev/hda1 par « LABEL=m onboot ».

On remarquera aussi deux choses dans ton dmesg :
1. tes cdrom/cdrw sont aussi touchés. Les périphériques son t srX,
sgX, scdX. Le plus simple est d’utiliser /dev/cdrom (lien crà ©Ã©
automatiquement par udev).

2. le second cdrom n’est plus là (?)

--
Sylvain Sauvage
marc
Le #9757811
Sylvain Sauvage a écrit :
marc, samedi 6 octobre 2007, 17:52:20 CEST
Bonjour à toutes et à tous,



’soir,



Bonjour,

Ce sont surtout tes explications qui sont, euh, torteuses…



Désolé de ne pas avoir été clair!
[…]


— tune2fs -L monboot /dev/hda1 (ou sda1, suivant le noyau) ;
— modifie fstab en remplaçant /dev/hda1 par « LABEL=monboot ».



Merci du coup de main

On remarquera aussi deux choses dans ton dmesg :
1. tes cdrom/cdrw sont aussi touchés. Les périphériques sont srX,
sgX, scdX. Le plus simple est d’utiliser /dev/cdrom (lien créé
automatiquement par udev).

2. le second cdrom n’est plus là (?)



Si, mais effectivement j'ai un soucis. Je vais regarder ça!

En tout Merci bcps.
Librement
Marc


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme