Perte du DUAL-CORE

Le
Jean-Pierre Marot
Bonjour,
Il y a quelques mois j'ai changé de carte mère (avec processeur
dual-core d'AMD + nouveau DD) j'ai donc utilisé SYSPREP pour ne pas avoir à
réinstaller WINDOWS ni mes logiciels.. L'opération s'est bien déroulé.
J'avais cloné l'ancien DD sur le nouveau avec ACRONIS. Dernièrement j'ai
utilisé CPUID CPU-Z et là j'ai constaté que le dual-core ne fonctionnait
qu'en simple core. Avez-vous une explication? Je suis sous Windows XP Pro.
Merci Jean-Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jo Kerr
Le #20438551
Jean-Pierre Marot a formulé ce mardi :
Bonjour,
Il y a quelques mois j'ai changé de carte mère (avec processeur dual-core
d'AMD + nouveau DD) j'ai donc utilisé SYSPREP pour ne pas avoir à
réinstaller WINDOWS ni mes logiciels.. L'opération s'est bien déroulé.
J'avais cloné l'ancien DD sur le nouveau avec ACRONIS. Dernièrement j'ai
utilisé CPUID CPU-Z et là j'ai constaté que le dual-core ne fonctionnait
qu'en simple core. Avez-vous une explication? Je suis sous Windows XP Pro.
Merci Jean-Pierre



Vérifier dans le BIOS si le dual core est validé.

--
In gold we trust (c)
Jean-Pierre Marot
Le #20439011
"Jo Kerr"
Jean-Pierre Marot a formulé ce mardi :
Bonjour,
Il y a quelques mois j'ai changé de carte mère (avec processeur
dual-core d'AMD + nouveau DD) j'ai donc utilisé SYSPREP pour ne pas
avoir à réinstaller WINDOWS ni mes logiciels.. L'opération s'est bien
déroulé. J'avais cloné l'ancien DD sur le nouveau avec ACRONIS.
Dernièrement j'ai utilisé CPUID CPU-Z et là j'ai constaté que le
dual-core ne fonctionnait qu'en simple core. Avez-vous une explication?
Je suis sous Windows XP Pro. Merci Jean-Pierre



Vérifier dans le BIOS si le dual core est validé.

--
In gold we trust (c)





Merci pour la réponse, le dual-core est certainement activé car sous le
Gestionnaire de périphériques dans la rubrique Processors on trouve bien 2
lignes identiques, a savoir :

_AMD Athlon(tm) 7750 Dual-Core Processor _

de plus après diverses recherche sur Internet il apparait que le
processeur/carte mère doit gérer l'ACPI ce qui se trouve dans la rubrique
Ordinateur, j'ai bien la ligne :

_ PC à interface de configuration et d'énergie avancée (ACPI) _

Peut-être doit-on déclarer la notion de Dual-Core dans un des nombreux
fichiers .inf de Windows? ou dans le fichier des registres?
Th.A.C
Le #20444401
Jean-Pierre Marot a écrit :





Merci pour la réponse, le dual-core est certainement activé car sous le
Gestionnaire de périphériques dans la rubrique Processors on trouve bien 2
lignes identiques, a savoir :

_AMD Athlon(tm) 7750 Dual-Core Processor _

de plus après diverses recherche sur Internet il apparait que le
processeur/carte mère doit gérer l'ACPI ce qui se trouve dans la rubrique
Ordinateur, j'ai bien la ligne :

_ PC à interface de configuration et d'énergie avancée (ACPI) _

Peut-être doit-on déclarer la notion de Dual-Core dans un des nombreux
fichiers .inf de Windows? ou dans le fichier des registres?



Sous réserve, mais tu peux essayer de changer dans 'Panneau de
configuration/systeme/matériel/gestionnaire de périphérique/ordinateur'
en 'pc multiprocesseur acpi'.
Normalement, clic-droit, mettre à jour le pilote, installer à partir
d'une liste../, ne pas rechercher.../, PC Multiprocesseur ACPI.

Sinon, dans le gestionnaire de taches/onglet performance, regarde si tu
vois 1 ou 2 processeurs
Jean-Pierre Marot
Le #20449601
"Th.A.C"

Sous réserve, mais tu peux essayer de changer dans 'Panneau de
configuration/systeme/matériel/gestionnaire de périphérique/ordinateur' en
'pc multiprocesseur acpi'.
Normalement, clic-droit, mettre à jour le pilote, installer à partir d'une
liste../, ne pas rechercher.../, PC Multiprocesseur ACPI.

Sinon, dans le gestionnaire de taches/onglet performance, regarde si tu
vois 1 ou 2 processeurs



La seule possibilité pour changer le pilote ORDINATEUR est : PC standard +
le mien cité plus haut. Le gestionnaire de taches sous l'onglet PERFORMANCE
ne fait apparaître qu'un seul processeur cad pas de différence avec
l'ancienne CM mono. Merci JP
Th.A.C
Le #20451381
Jean-Pierre Marot a écrit :
"Th.A.C"

Sous réserve, mais tu peux essayer de changer dans 'Panneau de
configuration/systeme/matériel/gestionnaire de périphérique/ordinateur' en
'pc multiprocesseur acpi'.
Normalement, clic-droit, mettre à jour le pilote, installer à partir d'une
liste../, ne pas rechercher.../, PC Multiprocesseur ACPI.

Sinon, dans le gestionnaire de taches/onglet performance, regarde si tu
vois 1 ou 2 processeurs



La seule possibilité pour changer le pilote ORDINATEUR est : PC standard +
le mien cité plus haut. Le gestionnaire de taches sous l'onglet PERFORMANCE
ne fait apparaître qu'un seul processeur cad pas de différence avec
l'ancienne CM mono. Merci JP




As-tu essayé de décocher la case 'afficher les matériels compatibles?'

Sinon, tu peux aussi essayer de changer hal.dll.
Chez moi (un C2D), c'est le fichier halmacpi.dll qui est donc renommé en
hal.dll dans c:windowssystem32.
Je ne sais pas si on peut le faire 'à chaud', mais je l'ai souvent fait
avec un cd de boot comme pe-builder ou même avec la console de récupération.
Sur le cd de windows, tu peux le récupérer (halmacpi.dl_) et le
décompresser avec 'expand.exe'
Th.A.C
Le #20451371
Th.A.C a écrit :
As-tu essayé de décocher la case 'afficher les matériels compatibles?'

Sinon, tu peux aussi essayer de changer hal.dll.
Chez moi (un C2D), c'est le fichier halmacpi.dll qui est donc renommé en
hal.dll dans c:windowssystem32.
Je ne sais pas si on peut le faire 'à chaud', mais je l'ai souvent fait
avec un cd de boot comme pe-builder ou même avec la console de
récupération.
Sur le cd de windows, tu peux le récupérer (halmacpi.dl_) et le
décompresser avec 'expand.exe'




j'ai vérifié, et il y a aussi 2 autres fichiers concernés:
ntknrlpa.exe qui vient de ntkrpamp.ex_
ntoskrnl.exe qui vient de ntkrnlmp.ex_

mais il vaut mieux essayer avec la première méthode (changement de pilote)
Jean-Pierre Marot
Le #20453921
"Th.A.C"
Th.A.C a écrit :
As-tu essayé de décocher la case 'afficher les matériels compatibles?'

Sinon, tu peux aussi essayer de changer hal.dll.
Chez moi (un C2D), c'est le fichier halmacpi.dll qui est donc renommé en
hal.dll dans c:windowssystem32.
Je ne sais pas si on peut le faire 'à chaud', mais je l'ai souvent fait
avec un cd de boot comme pe-builder ou même avec la console de
récupération.
Sur le cd de windows, tu peux le récupérer (halmacpi.dl_) et le
décompresser avec 'expand.exe'




j'ai vérifié, et il y a aussi 2 autres fichiers concernés:
ntknrlpa.exe qui vient de ntkrpamp.ex_
ntoskrnl.exe qui vient de ntkrnlmp.ex_

mais il vaut mieux essayer avec la première méthode (changement de pilote)



Entre temps LDLC (fournisseur de ma CM + Processeur) m'a répondu :

1- Ce type de problème est rencontré lorsqu'une version allégée de Windows
est installée (noyau à base d'ACPI MonoProcesseur). Nous vous recommandons
ici d'installer un système d'exploitation à partir d'un véritable CD ou DVD,
et de faire correctement sa mise à jour.

2- Vous nous indiquez que votre système a été installé depuis plusieurs
années. Si vous avez toujours gardé la même installation de Windows pour
plusieurs machines (et que les anciennes machines étaient équipées de
processeurs simple-cour, cela explique la raison pour laquelle le processeur
n'est pas correctement détecté). Une nouvelle installation, à partir d'une
version originale, est ici indispensable. Deux processeurs doivent être
visibles dans le gestionnaire de périphériques de Windows. Est-ce le cas ?

Sur le CD Windows XP Pro SP3 je trouve les fichiers suivants : HALMACPI.Dl_
(5.1.2600.5512 NTKRNLMP.EX_(5.1.2600.5512) NTOSKRNL.EX_(5.1.2600.5512)
est-ce bien ceux là qui doivent remplacés HAL.DLL(5.1.2600.5512)
NTKRNLPA.EXE(5.1.2600.5857) NTOSKRNL.EXE(5.1.2600.5857)

Je ne trouve pas le fichier NTKRPAMP.DL_ que tu cites dans le CD Windows,
au vu des noms je pense que halmacpi.dll remplace hal.dll que
ntkrnlmp.exe(MP=MultiProcessor ou MonoProcessor?) est à incorporer, ce qui
me chagrine ce sont les versions plus récentes sur mon micro. Pour l'instant
je vais faire un backup du disque système (ACRONIS) + création d'un point
de reprise avant de modifier quoique ce soit prudence, prudence... Merci
Th.A.C
Le #20456631
En fait, dans le gestionnaire de périphérique, j'ai noté les fichiers
associés puis dans l'explorateur j'ai fais propriété dessus ce qui m'a
permis de trouver leur nom d'origine.

c:windowssystem32hal.dll qui s'appelle en réalité HALMACPI.DL_ sur le
cdrom de xp pro sp3 dans I386SP3.CAB
version 5.1.2600.5512

pour les 2 autres fichiers, je n'avais pas vérifié s'ils existaient sur
le cd:

c:windowssystem32ntkrnlpa.exe qui s'appelle en réalité ntkrpamp.exe
et qui se trouve dans C:WINDOWSDriver Cachei386driver.cab
ou sur le cd dans I386sp3.cab
version 5.1.26005857

c:windowssystem32ntoskrnl.exe qui s'appelle en réalité ntkrnlmp.exe
et qui se trouve dans C:WINDOWSDriver Cachei386driver.cab
ou sur le cd dans I386sp3.cab.
version 5.1.2600.5857

tout ca proviens d'un xp pro sp3 à jour.

Le mieux est quand même la première méthode (changement de pilote en
décochant la case 'afficher les matériels compatibles' (si ca marche
bien sur...)
Th.A.C
Le #20456601
Encore moi...

chez moi les 2 derniers fichiers sont datés du 04/08/2009 (une mise à
jour sans aucun doute).
Jean-Pierre Marot
Le #20478911
"Th.A.C"
Encore moi...

chez moi les 2 derniers fichiers sont datés du 04/08/2009 (une mise à jour
sans aucun doute).



Je parts pour 2semaines et vais laisser la micro de côté. Je pense
réinstaller Windows sans rien détruire (au même endroit). Merci pour ton
aide, je te tiendrais au courant quand j'aurais réussi!! Cordialement JP
Publicité
Poster une réponse
Anonyme