pertes des locales

Le
Remi Suinot
Bonjour;
(Je crois que j'ai fait une grosse annerie)
J'ai mon portable en testing, et la dessus, j'ai voulu tester compiz-gnome
(carte ati radeon Radeon Mobility 7500). Et même que ça marche
Suite à des problèmes avec ccsm, j'ai repris l'installation à 0.
J'ai donc réussi à installer ça:
# dpkg -l "*compiz*" | grep ^ii
ii compiz 1:0.6.2-shame-0 =
OpenGL window and compositing manager
ii compiz-bcop 0.6.99+git20071021-shame-0 =
Compiz option code generator
ii compiz-core 1:0.6.2-shame-0 =
OpenGL window and compositing manager
ii compiz-fusion-gnome 0.6.99+git20071115-shame-0 =
Metapackage for the compiz fusion project
ii compiz-fusion-plugins-extra 0.6.99+git20071115-shame-0 =
Collection of Compiz Fusion plugins for Compiz - Extra plugins
ii compiz-fusion-plugins-main 0.6.99+git20071115-shame-0 =
Collection of Compiz Fusion plugins for Compiz - Main
ii compiz-fusion-plugins-unstable 0.6.99+git20071117-shame-0 =
Collection of unofficial Compiz Fusion plugins for Compiz
ii compiz-fusion-plugins-unsupported 0.6.99+git20071115-shame-0 =
Collection of plugins for Compiz - Unsupported
ii compiz-gnome 1:0.6.2-shame-0 =
OpenGL window and compositing manager - GNOME utilities
ii compiz-manager 0.6.99+git20071115-shame-0 =
Compiz Manager for the compiz fusion project
ii compiz-plugins 1:0.6.2-shame-0 =
OpenGL window and compositing manager - plugins
ii compizconfig-backend-gconf 0.6.99+git20071028-shame-0 =
GNOME Backend for the Compiz Configuration System
ii compizconfig-python 0.6.99+git20071106-shame-0 =
Python bindings for the Compiz Configuration System
ii libcompizconfig0 0.6.99+git20071106-shame-0 =
Settings library for plugins - Compiz Fusion Project

Mais là, ca marche plus, je suspect un problème avec les locales, car a=
pt m'a enlevé les
locales: locales, localization-config , les fichier français d'openoffice.
Si je veux réinstallé le paquet locales, voila la réponse:
# apt-get install locales

The following packages have unmet dependencies:
locales: Depends: glibc-2.6-1
E: Broken packages
gtk m'envoi des erreurs de loclaes aussi, bref, la cata!
Et je ne peux pas reconfigurer le langage. J'ai tenté de placer LANG=C =
dans /etc/environment
mais sans résultat.
J'appel donc à l'aide .
Merci de vos suggestions.
Rémi.


--
Merci de m'avoir lu jusqu'ici, longue Vie et Prosperite.
http://www.suinot.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guillaume Coeugnet
Le #9624081
> -----Message d'origine-----
De : Remi Suinot [mailto:]
Envoyé : jeudi 22 novembre 2007 11:38
À :
Objet : pertes des locales

Bonjour;
(Je crois que j'ai fait une grosse ... annerie...) J'ai mon
portable en testing, et la dessus, j'ai voulu tester
compiz-gnome (carte ati radeon Radeon Mobility 7500). Et même
que ça marche...
Suite à des problèmes avec ccsm, j'ai repris l'installation à 0.
J'ai donc réussi à installer ça:
# dpkg -l "*compiz*" | grep ^ii
ii compiz 1:0.6.2-shame-0
OpenGL window and compositing manager
ii compiz-bcop
0.6.99+git20071021-shame-0 Compiz option code generator
ii compiz-core 1:0.6.2-shame-0
OpenGL window and compositing manager
ii compiz-fusion-gnome
0.6.99+git20071115-shame-0 Metapackage for the
compiz fusion project
ii compiz-fusion-plugins-extra
0.6.99+git20071115-shame-0 Collection of Compiz
Fusion plugins for Compiz - Extra plugins
ii compiz-fusion-plugins-main
0.6.99+git20071115-shame-0 Collection of Compiz
Fusion plugins for Compiz - Main
ii compiz-fusion-plugins-unstable
0.6.99+git20071117-shame-0 Collection of unofficial
Compiz Fusion plugins for Compiz
ii compiz-fusion-plugins-unsupported
0.6.99+git20071115-shame-0 Collection of plugins
for Compiz - Unsupported
ii compiz-gnome 1:0.6.2-shame-0
OpenGL window and compositing manager - GNOME
utilities
ii compiz-manager
0.6.99+git20071115-shame-0 Compiz Manager for the
compiz fusion project
ii compiz-plugins 1:0.6.2-shame-0
OpenGL window and compositing manager - plugins
ii compizconfig-backend-gconf
0.6.99+git20071028-shame-0 GNOME Backend for the
Compiz Configuration System
ii compizconfig-python
0.6.99+git20071106-shame-0 Python bindings for the
Compiz Configuration System
ii libcompizconfig0
0.6.99+git20071106-shame-0 Settings library for
plugins - Compiz Fusion Project

Mais là, ca marche plus, je suspect un problème avec les
locales, car apt m'a enlevé les
locales: locales, localization-config , les fichier français
d'openoffice.
Si je veux réinstallé le paquet locales, voila la réponse:
# apt-get install locales
...
The following packages have unmet dependencies:
locales: Depends: glibc-2.6-1
E: Broken packages
gtk m'envoi des erreurs de loclaes aussi, bref, la cata!
Et je ne peux pas reconfigurer le langage. J'ai tenté de
placer LANG=C dans /etc/environment mais sans résultat.
J'appel donc à l'aide ....
Merci de vos suggestions.
Rémi.



Salut,

Ton glibc est dans quelle version et dans quel état ?
Tu as essayé avec aptitude, voir quelles résolutions il te proposait ?

Guillaume.
Remi Suinot
Le #9624071
En ce Thu, 22 Nov 2007 11:46:56 +0100, le sermon de "Guillaume Coeugnet"
..../.....
> # apt-get install locales
> ...
> The following packages have unmet dependencies:
> locales: Depends: glibc-2.6-1
> E: Broken packages
> gtk m'envoi des erreurs de loclaes aussi, bref, la cata!
> Et je ne peux pas reconfigurer le langage. J'ai tenté de
> placer LANG=C dans /etc/environment mais sans résultat.
> J'appel donc à l'aide ....
> Merci de vos suggestions.
> Rémi.

Salut,

Ton glibc est dans quelle version et dans quel état ?
Tu as essayé avec aptitude, voir quelles résolutions il te proposait ?



bonne suggestion:
$ dpkg -l "*glibc*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: upperc aseºd)
||/ Name Version Description
+++-======================= =============-=========== ========================= -======================== ========================= ========================= ==============
un glibc-2.6-1 <none> (no description available)
un glibc-2.7-1 <none> (no description available)
un glibc-doc <none> (no description available)
un libstdc++2.9-glibc2.1-dev <none> (no description available)

Assez étonnant, je trouve. Mais chaque tentative d'installation échoue:
$ sudo apt-get install glibc-2.6-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package glibc-2.6-1 is a virtual package provided by:
You should explicitly select one to install.
E: Package glibc-2.6-1 has no installation candidate

J'y perd mon latin..

Rémi.

--
Merci de m'avoir lu jusqu'ici, longue Vie et Prosperite.
http://www.suinot.org
Stéphane L.
Le #9624061
Le 22/11/07, Remi Suinot

bonne suggestion:
$ dpkg -l "*glibc*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-install ed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppe rcaseºd)
||/ Name Version Description
+++-======================= =============-=========== ========================= -======================== ========================= ========================= ==============
un glibc-2.6-1 <none> (no description available)
un glibc-2.7-1 <none> (no description available)
un glibc-doc <none> (no description available)
un libstdc++2.9-glibc2.1-dev <none> (no description available)

Assez étonnant, je trouve. Mais chaque tentative d'installation échou e:
$ sudo apt-get install glibc-2.6-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package glibc-2.6-1 is a virtual package provided by:
You should explicitly select one to install.
E: Package glibc-2.6-1 has no installation candidate




Fais un aptitude (ou apt-get) update, histoire d'être bien en phase
avec les dépôts.
Vérifies ton source.list.

Cdlt.
Jean-Michel OLTRA
Le #9624051
Bonjour,


Le jeudi 22 novembre 2007, Remi Suinot a écrit...


Assez étonnant, je trouve. Mais chaque tentative d'installation échoue:
$ sudo apt-get install glibc-2.6-1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package glibc-2.6-1 is a virtual package provided by:
You should explicitly select one to install.
E: Package glibc-2.6-1 has no installation candidate



Essaie sur le paquet libc6, avec un -s (--simulate) pour voir.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Remi Suinot
Le #9624041
En ce Thu, 22 Nov 2007 12:22:20 +0100, le sermon de Jean-Michel OLTRA

Bonjour,


Le jeudi 22 novembre 2007, Remi Suinot a écrit...


> Assez étonnant, je trouve. Mais chaque tentative d'installation échoue:
> $ sudo apt-get install glibc-2.6-1
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package glibc-2.6-1 is a virtual package provided by:
> You should explicitly select one to install.
> E: Package glibc-2.6-1 has no installation candidate

Essaie sur le paquet libc6, avec un -s (--simulate) pour voir.



$ sudo apt-get -s install libc6
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
excalibur 12:26:09 admin /home/admin
$ sudo apt-get -s -t unstable install libc6
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

J'ai bien sur, fait un (une?) update avant de tester la réinstallation de libc6.

En écrivant ceci, je me rend compte d'une chose:
j'ai demandé à gdm de placer l'user en anglais, aux seuls fins de test, et là, dans sylpheed
avec les menu en anglais (logique), ben j'ai les accents!!!!€€€€ et même l'euro!!!!
Si je n'avais plsu la locale fr_FR_utf8, cela ne devrait pas être le cas, non?
J'avoue mon imcapacité à comprendre la gestion des locales sous debian....
Rémi.

--
Merci de m'avoir lu jusqu'ici, longue Vie et Prosperite.
http://www.suinot.org


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel OLTRA
Le #9624021
Bonjour,


Le jeudi 22 novembre 2007, Remi Suinot a écrit...


> Essaie sur le paquet libc6, avec un -s (--simulate) pour voir.



$ sudo apt-get -s install libc6
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.



« 1 not upgraded »
Lequel ?
Il n'y a pas une option d'aptitude/apt-get pour voir lequel
(--show-upgraded ??)

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Remi Suinot
Le #9624001
En ce Thu, 22 Nov 2007 13:47:56 +0100, le sermon de Jean-Michel OLTRA

Bonjour,


Le jeudi 22 novembre 2007, Remi Suinot a écrit...


> > Essaie sur le paquet libc6, avec un -s (--simulate) pour voir.

> $ sudo apt-get -s install libc6
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> libc6 is already the newest version.
> 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

« 1 not upgraded »
Lequel ?
Il n'y a pas une option d'aptitude/apt-get pour voir lequel
(--show-upgraded ??)



C'est sensors-applet
Si je tente de forcer l'installation:

The following packages have unmet dependencies:
sensors-applet: Depends: libpanel-applet2-0 (>= 2.19.3) but 2.18.3-2 is to be installed
E: Broken packages

En plus compiz marche plus! Bouhhhh....

--
Merci de m'avoir lu jusqu'ici, longue Vie et Prosperite.
http://www.suinot.org
Publicité
Poster une réponse
Anonyme