petite bizarrerie sur Ultra-5

Le
Emmanuel Florac
Coucou la foule,
j'ai récupéré une rutilante U5, j'ai installé Solaris 10, tout baigne
impeccable mais la bête refuse absolument de booter sans clavier. Si
le clavier est là, tout baigne; pas de clavier, pas de boot.

Avec la console série branchée, le message "Solaris 10 gna gna Oracle"
apparait, puis la petite "ligne tournante" ( /- | ), puis la ligne se
bloque, et plus rien du tout, pas de réseau, que dalle.

Des idées? une option OpenFirmware peut-être?


--
La propriété c'est le vol.
Pierre-Joseph Proudhon.

La propriété c'est le meurtre.
Marcel Camus.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Arnaud Gomes-do-Vale
Le #23979721
Emmanuel Florac
j'ai récupéré une rutilante U5, j'ai installé Solaris 10, tout baigne
impeccable mais... la bête refuse absolument de booter sans clavier. Si
le clavier est là, tout baigne; pas de clavier, pas de boot.

Avec la console série branchée, le message "Solaris 10 gna gna Oracle"
apparait, puis la petite "ligne tournante" ( /- | ), puis la ligne se
bloque, et... plus rien du tout, pas de réseau, que dalle.



Dans mes souvenirs (un peu aidés par une recherche sur le web), booter
sans clavier force OpenFirmware à basculer sur la console série. Par
contre, il n'est pas évident du tout que l'OS soit au courant. Es-tu sûr
qu'elle ne boote pas, ou est-ce juste qu'une fois le noyau booté il
bascule sur la console physique ?

--
Arnaud
http://blogs.glou.org/arnaud/
JKB
Le #23982581
Le Sat, 19 Nov 2011 00:32:28 +0100,
Arnaud Gomes-do-Vale
Emmanuel Florac
j'ai récupéré une rutilante U5, j'ai installé Solaris 10, tout baigne
impeccable mais... la bête refuse absolument de booter sans clavier. Si
le clavier est là, tout baigne; pas de clavier, pas de boot.

Avec la console série branchée, le message "Solaris 10 gna gna Oracle"
apparait, puis la petite "ligne tournante" ( /- | ), puis la ligne se
bloque, et... plus rien du tout, pas de réseau, que dalle.



Dans mes souvenirs (un peu aidés par une recherche sur le web), booter
sans clavier force OpenFirmware à basculer sur la console série. Par
contre, il n'est pas évident du tout que l'OS soit au courant. Es-tu sûr
qu'elle ne boote pas, ou est-ce juste qu'une fois le noyau booté il
bascule sur la console physique ?



Ça, ça m'étonnerais, puisque Solaris se conforme à ce que dit
l'openprom pour configurer sa console. Si le clavier est absent, la
console bascule sur ttysa si elle était configurée sur l'écran et le
matériel en informe Solaris pour que ça se passe bien.

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
Emmanuel Florac
Le #23983551
Le Sat, 19 Nov 2011 00:32:28 +0100, Arnaud Gomes-do-Vale a écrit:


Dans mes souvenirs (un peu aidés par une recherche sur le web), booter
sans clavier force OpenFirmware à basculer sur la console série. Par
contre, il n'est pas évident du tout que l'OS soit au courant. Es-tu sûr
qu'elle ne boote pas, ou est-ce juste qu'une fois le noyau booté il
bascule sur la console physique ?



Elle ne boote pas, le réseau ne monte pas, et rien n'apparaît jamais ni
sur la console série, ni sur la sortie écran. Si je branche le clavier,
je peux faire stop-A puis "go", et elle termine le boot; mais sans
clavier, rien de rien. C'est chiant parce que je veux la laisser en rack
et l'utiliser essentiellement en ssh, donc je voudrais enlever le
clavier. Si je débranche le clavier après coup, elle s'arrête sur l'open
firmware aussi (comme si on avait fait un stop-A)...

--
A thing of beauty is a joy forever.
J. Keats.

Ah! Singe débotté, hisse un jouet fort et vert!
Marcel Bénabou.
Emmanuel Florac
Le #23983541
Le Sat, 19 Nov 2011 16:43:11 +0000, JKB a écrit:

la
console bascule sur ttysa si elle était configurée sur l'écran et le
matériel en informe Solaris pour que ça se passe bien.



Notons que seule cette U5 pose problème, mon U1 boote parfaitement sans
écran, avec tout sur la console série comme attendu. C'est pourquoi je
penche pour un paramétrage à la con dans l'OF ou quelque chose du genre.
Ou alors un bug grossier de Solaris 10, mais ça me paraît bizarre.



--
Sutor ne ultra Crepidam.
JKB
Le #23989481
Le 19 Nov 2011 22:30:22 GMT,
Emmanuel Florac
Le Sat, 19 Nov 2011 16:43:11 +0000, JKB a écrit:

la
console bascule sur ttysa si elle était configurée sur l'écran et le
matériel en informe Solaris pour que ça se passe bien.



Notons que seule cette U5 pose problème, mon U1 boote parfaitement sans
écran, avec tout sur la console série comme attendu. C'est pourquoi je
penche pour un paramétrage à la con dans l'OF ou quelque chose du genre.
Ou alors un bug grossier de Solaris 10, mais ça me paraît bizarre.



Moi, pas plus que ça d'autant que tu parles d'une version Oracle.
J'ai viré Solaris de toutes mes sparcs tant j'ai trouvé de bugs dans
ce système. Enfin, je dis ça je dis rien.

Tu peux essayer de réinitialiser l'openprom pour voir si ça change
quelque chose, mais comme ça, je ne pense pas que ça changerait
quelque chose. N'oublie pas que l'U5 comporte un UltraSparc-IIi
(avec une mmu très spécifique) et boot sous Solaris en 64 bits par
défaut. Ton U1 boote par défaut en _32_ bits à cause d'un bug
sournois de l'UltraSparc-I.

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
Emmanuel Florac
Le #23990151
Le Mon, 21 Nov 2011 18:13:29 +0000, JKB a écrit:

Tu peux essayer de réinitialiser l'openprom pour voir si ça change
quelque chose,



Comment fait-on ça?

N'oublie pas que l'U5 comporte un UltraSparc-IIi (avec
une mmu très spécifique) et boot sous Solaris en 64 bits par défaut.



Oui, c'est justement pour avoir une machine 64 bits que je voulais cette
petite bête...

--
I have not failed. I've just found 10,000 ways that won't work.
Thomas A. Edison
JKB
Le #23990261
Le 21 Nov 2011 21:55:15 GMT,
Emmanuel Florac
Le Mon, 21 Nov 2011 18:13:29 +0000, JKB a écrit:

Tu peux essayer de réinitialiser l'openprom pour voir si ça change
quelque chose,



Comment fait-on ça?



De mémoire, au boot, avec un stop+N. Sinon, un help de l'openprom te
donnera la solution. De mémoire encore, il doit y avoir un
set-defaults. Tu peux aussi jouer un peu ave STOP+D (diagnostics) ou
avec switch-diag? et diag-level.

N'oublie pas que l'U5 comporte un UltraSparc-IIi (avec
une mmu très spécifique) et boot sous Solaris en 64 bits par défaut.



Oui, c'est justement pour avoir une machine 64 bits que je voulais cette
petite bête...



JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
Cyrille Lefevre
Le #23994051
Le 21/11/2011 23:24, JKB a écrit :
Le 21 Nov 2011 21:55:15 GMT,
Emmanuel Florac
Le Mon, 21 Nov 2011 18:13:29 +0000, JKB a écrit:

Tu peux essayer de réinitialiser l'openprom pour voir si ça change
quelque chose,



Comment fait-on ça?



De mémoire, au boot, avec un stop+N. Sinon, un help de l'openprom te
donnera la solution. De mémoire encore, il doit y avoir un
set-defaults. Tu peux aussi jouer un peu ave STOP+D (diagnostics) ou
avec switch-diag? et diag-level.




Bonjour,

je conseillerai tout d'abord de faire un eeprom | lp avant.
si pb, il est tout de même possible de reconfigurer comme
avant le stop+N, sutout s'il y a des devalias tel que :

nvramrcÞvalias vx-rootvg01 /,0/,600000//,0:a
devalias vx-rootvg02 /,0/,600000//,0:a
...
diag-device=vx-rootvg01 vx-rootvg02
boot-device=vx-rootvg01 vx-rootvg02
...
use-nvramrc?=true
...

par ex. dans le cas d'une config / veritas...

en ce qui concerne la console serie vs la console graphique,
ça se passe par là :

ansi-terminal?=true
ttya-rts-dtr-offúlse
ttya-ignore-cd=true
ttya-mode–00,8,n,1,-
output-device=screen
input-device=keyboard

normalement, avec ça, tu peux booter en "headless",
en 9.X tout du moins...

dans le pire des cas, tu peux avoir :

output-device=ttya
input-device=ttya

qu'elle est ta config ?

Cordialement,

Cyrille Lefevre.
--
mailto:Cyrille.Lefevre-news%
supprimer "%nospam% et ".invalid" pour me repondre.
Emmanuel Florac
Le #23994911
Le Wed, 23 Nov 2011 00:19:03 +0100, Cyrille Lefevre a écrit:

ttya-ignore-cd=true




Celui là est à false sur mon U5 et à true sur mon U1... C'est peut-être
ça? Ça sert à quoi?

--
An expert is a man who has made all the mistakes that can be made in a
very narrow field.
Niels Bohr
Philippe Michel
Le #23997491
On 2011-11-23, Emmanuel Florac
Le Wed, 23 Nov 2011 00:19:03 +0100, Cyrille Lefevre a écrit:

ttya-ignore-cd=true



Celui là est à false sur mon U5 et à true sur mon U1... C'est peut-être
ça? Ça sert à quoi?



Ignore Carrier Detect. Si le CD n'est pas ignoré, on surveille une des
broches du port série qui indique si le modem qui est censé y être
connecté a été appelé et a décroché. Si c'est ignoré, on suppose qu'il y a
toujours quelque-chose à l'autre bout du cable.

Pour la console, ça ne semble pas une bonne idée de ne pas l'ignorer,
surtout si on utilise un cable null-modem imcomplet, avec les broches
"inutiles" en l'air.
Publicité
Poster une réponse
Anonyme