[un peu HS] gettext et traduction de site web

Le
Aurelien
Salut, je reviens encore et toujours avec mon problème de gettext et de
traduction que je n'arrive vraiment pas à résoudre.

Pour rappel, j'utilise gettext pour la traduction de deux sites web :
www.sebkhachott.net
et
www.ammd.net
tous les deux hébergés chez un même hébergeur associatif.

Sur la précédente version du serveur de l'hébergeur, les scripts de
traduction fonctionnaient parfaitement, chez free, de même. mais depuis
la migration du serveur, vers une solution basées sur Plesk 8.1 (sous
Linux), impossible de retrouver les traductions.
J'ai cherché un peu dans tous les recoins, mais le support de swsoft
sur Plesk est une catastrophe, et je n'ai rien trouvé de convaincant, si
ce n'est que le safe mode pourrait faire chier. Mais finalement, même en
enlevant le safe mode, ça n'est pas mieux.

Voici, ci-dessous les quelques lignes intéressantes des fichiers du site
www.sebkhachott.net et du serveur :

$> index.php
putenv("LANG=fr_FR");
setlocale(LC_ALL, "fr_FR");

$binddom=bindtextdomain('messages','/var/www/vhosts/sebkhachott.websanslimit.net/httpdocs/lang/locale/');
$textdom=textdomain('messages');

echo '<p><code>WebSansLimit Debug :: bindtextdomain='.$binddom.' -+-
textdomain='.$textdom.' -+- LC_ALL='.getenv("LC_ALL").'</code><p>';

(vous pouvez donc voir sur la première page du site que LC_ALL est
vide)

Côté serveur
safe_mode_allowed_env_vars = PHP_,LANG


Il y a un truc qui me chagrine depuis le départ, c'est qu'il ne semble
pas y avoir de paquet "locale" installé sur le serveur :
(message de l'admin)
"*.mo existe.
locale.gen est OK.
"locale" ne correspond à rien, donc "dpkg-reconfigure locale" ne marche
pas."


Est-ce que quelqu'un a moyen de me donner un coup de main, une
orientation, n'importe quoi qui puisse me faire avancer, car ça va faire
presqu'un an que ça dure.

Merci.

--

ORL


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GiGGz
Le #9733411
Aurelien a écrit :
Salut, je reviens encore et toujours avec mon problème de gettext et de
traduction que je n'arrive vraiment pas à résoudre.

Pour rappel, j'utilise gettext pour la traduction de deux sites web :
www.sebkhachott.net
et
www.ammd.net
tous les deux hébergés chez un même hébergeur associatif.

Sur la précédente version du serveur de l'hébergeur, les scripts de
traduction fonctionnaient parfaitement, chez free, de même. mais depuis
la migration du serveur, vers une solution basées sur Plesk 8.1 (sous
Linux), impossible de retrouver les traductions.
J'ai cherché un peu dans tous les recoins, mais le support de swsoft
sur Plesk est une catastrophe, et je n'ai rien trouvé de convaincant, si
ce n'est que le safe mode pourrait faire chier. Mais finalement, même en
enlevant le safe mode, ça n'est pas mieux.

Voici, ci-dessous les quelques lignes intéressantes des fichiers du site
www.sebkhachott.net et du serveur :

$> index.php
putenv("LANG=fr_FR");
setlocale(LC_ALL, "fr_FR");

$binddom=bindtextdomain('messages','/var/www/vhosts/sebkhachott.websanslimit.net/httpdocs/lang/locale/');
$textdom=textdomain('messages');

echo '<p><code>WebSansLimit Debug :: bindtextdomain='.$binddom.' -+-
textdomain='.$textdom.' -+- LC_ALL='.getenv("LC_ALL").'</code><p>';

(vous pouvez donc voir sur la première page du site que LC_ALL est
vide...)

Côté serveur
safe_mode_allowed_env_vars = PHP_,LANG


Il y a un truc qui me chagrine depuis le départ, c'est qu'il ne semble
pas y avoir de paquet "locale" installé sur le serveur :
(message de l'admin)
"*.mo existe.
locale.gen est OK.
"locale" ne correspond à rien, donc "dpkg-reconfigure locale" ne marche
pas."




je suppose que c'est une erreur de frappe mais le paquet c'est pas
plutot "locales". donc "dpkg-reconfigure locales".

bonne chance


Est-ce que quelqu'un a moyen de me donner un coup de main, une
orientation, n'importe quoi qui puisse me faire avancer, car ça va faire
presqu'un an que ça dure.

Merci.





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme