[Un peu HS] skype google-earth et multi-arch

Le
Mourad Jaber
Bonjour,

J'ai une tas de spaghetti avec les libs QT depuis que j'ai tenté d'installer google-earth.

Avant skype (je sais c'est LE mal !) fonctionnait,

Aprés, ni skype, ni google earth ne fonctionnent pour des raisons différentes

Quand je fait un $ ldd /usr/bin/skype | grep google
libQtWebKit.so.4 => /opt/google/earth/free/libQtWebKit.so.4 (0xf5edb000)
libQtGui.so.4 => /opt/google/earth/free/libQtGui.so.4 (0xf5359000)
libQtNetwork.so.4 => /opt/google/earth/free/libQtNetwork.so.4 (0xf5259000)
libQtCore.so.4 => /opt/google/earth/free/libQtCore.so.4 (0xf4f2d000)

Et j'ai réussit à relancer l'application en forçant le chemin des bibliothèques partagées :
$ LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/ /usr/bin/skype

En cherchant un peu, j'ai trouvé un fichier /etc/ld.so.conf.d/googleearth.conf que
j'aurais espéré n'être utilisé que pour google earth mais cela ne semble visiblement pas
être le cas !!!

Comment revenir dans une configuration plus debian et moins google sans supprimer
google-earth ?

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/50EB0703.3020901@nativobject.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bzzz
Le #25119302
On Mon, 07 Jan 2013 18:33:55 +0100
Mourad Jaber

En cherchant un peu, j'ai trouvé un
fichier /etc/ld.so.conf.d/googleearth.conf que j'aurais espéré n'être utilisé
que pour google earth mais cela ne semble visiblement pas être le ca s !!!



Ben nan, c'est justement là qu'on dit à ldconfig où il
doit aller pêcho toutes les libs system.

Comment revenir dans une configuration plus debian et moins google sans
supprimer google-earth ?



En virant le fichier relatif à GE de /etc/ld.so.conf.d/
et en lançant GE de la même façon que tu décris pour sk ype.
(plus un coup de ldconfig pour remettre les choses d'équerre)

Pour simplifier, t'as intérêt à faire un script bash que tu
appelles, par ex. GE.sh et que tu colles dans /usr/local/bin


--
François: Trop forte ma petite soeur
François: J'ai réussis à lui faire croire que le casque de m on scoot était
un oeuf de moto
François: Depuis, elle dors avec

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Mourad Jaber
Le #25119312
Le 07/01/2013 19:11, Bzzz a écrit :
On Mon, 07 Jan 2013 18:33:55 +0100
Mourad Jaber
En cherchant un peu, j'ai trouvé un
fichier /etc/ld.so.conf.d/googleearth.conf que j'aurais espéré n'être utilisé
que pour google earth mais cela ne semble visiblement pas être le cas !!!


Ben nan, c'est justement là qu'on dit à ldconfig où il
doit aller pêcho toutes les libs system.

Comment revenir dans une configuration plus debian et moins google sans
supprimer google-earth ?


En virant le fichier relatif à GE de /etc/ld.so.conf.d/
et en lançant GE de la même façon que tu décris pour skype.
(plus un coup de ldconfig pour remettre les choses d'équerre)

Pour simplifier, t'as intérêt à faire un script bash que tu
appelles, par ex. GE.sh et que tu colles dans /usr/local/bin



Effectivement, ça fonctionne :)

Google earth n'y voit que du feu, avec le bibliothèques fournies par le système il semble
fonctionner...

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Erwan David
Le #25119322
Le 07/01/2013 19:11, Bzzz a écrit :
On Mon, 07 Jan 2013 18:33:55 +0100
Mourad Jaber
En cherchant un peu, j'ai trouvé un
fichier /etc/ld.so.conf.d/googleearth.conf que j'aurais espéré n'être utilisé
que pour google earth mais cela ne semble visiblement pas être le cas !!!


Ben nan, c'est justement là qu'on dit à ldconfig où il
doit aller pêcho toutes les libs system.

Comment revenir dans une configuration plus debian et moins google sans
supprimer google-earth ?


En virant le fichier relatif à GE de /etc/ld.so.conf.d/
et en lançant GE de la même façon que tu décris pour skype.
(plus un coup de ldconfig pour remettre les choses d'équerre)

Pour simplifier, t'as intérêt à faire un script bash que tu
appelles, par ex. GE.sh et que tu colles dans /usr/local/bin




Et si google-earth a été installé via googleearth-package, ça vaut
peut-être un rapport de bug.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25119432
On Mon, 07 Jan 2013 19:16:12 +0100
Erwan David
Et si google-earth a été installé via googleearth-package, ça vaut
peut-être un rapport de bug.



Vraisemblablement non, j'ai jamais eu ce PB avec le pkg.


--
Q: Why is it that the more accuracy you demand from an interpolation
function, the more expensive it becomes to compute?
A: That's the Law of Spline Demand.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Erwan David
Le #25119512
Le 07/01/2013 19:37, Bzzz a écrit :
On Mon, 07 Jan 2013 19:16:12 +0100
Erwan David
Et si google-earth a été installé via googleearth-package, ça vaut
peut-être un rapport de bug.



Vraisemblablement non, j'ai jamais eu ce PB avec le pkg.




D'où l'intérêt du paquet...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Erwan David
Le #25119502
Le 07/01/2013 19:41, Erwan David a écrit :
Le 07/01/2013 19:37, Bzzz a écrit :
On Mon, 07 Jan 2013 19:16:12 +0100
Erwan David
Et si google-earth a été installé via googleearth-package, ça vaut
peut-être un rapport de bug.


Vraisemblablement non, j'ai jamais eu ce PB avec le pkg.




D'où l'intérêt du paquet...




Par contre en 64 bits on tombe sur un bug de libglade où l'installation
de la version 32 bits provoque la désinstallation de la version 64 bits
et de ce qui en dépend...

Pas cool du tout

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25119632
On Mon, 07 Jan 2013 19:58:36 +0100
Erwan David
Par contre en 64 bits on tombe sur un bug de libglade où l'installat ion
de la version 32 bits provoque la désinstallation de la version 64 b its
et de ce qui en dépend...

Pas cool du tout



Hmmm, il me semble que la version 64bits a eu une kyrielle
de PB depuis pas mal de temps.


--
<Jean> à moi regarde ce que ça donne mon prénom à l'env ers: naej
<alexandre> et moi: erdnaxela
<natacha> pas mal ^^ et moi: ahcatan
<Jean> et toi Luc ça donne quoi ?
<luc> ...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Gaëtan PERRIER
Le #25120212
Le Mon, 07 Jan 2013 18:33:55 +0100
Mourad Jaber
Bonjour,

J'ai une tas de spaghetti avec les libs QT depuis que j'ai tenté d'inst aller
google-earth.

Avant skype (je sais c'est LE mal !) fonctionnait,

Aprés, ni skype, ni google earth ne fonctionnent pour des raisons
différentes...

Quand je fait un $ ldd /usr/bin/skype | grep google
libQtWebKit.so.4 => /opt/google/earth/free/libQtWebKit.so.4
(0xf5edb000) libQtGui.so.4 => /opt/google/earth/free/libQtGui.so.4
(0xf5359000) libQtNetwork.so.4 => /opt/google/earth/free/libQtNetwork.s o.4
(0xf5259000) libQtCore.so.4 => /opt/google/earth/free/libQtCore.so.4
(0xf4f2d000)

Et j'ai réussit à relancer l'application en forçant le chemin des
bibliothèques partagées : $
LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu/ /usr/bin/skype

En cherchant un peu, j'ai trouvé un
fichier /etc/ld.so.conf.d/googleearth.conf que j'aurais espéré n'êt re
utilisé que pour google earth mais cela ne semble visiblement pas êtr e le
cas !!!

Comment revenir dans une configuration plus debian et moins google sans
supprimer google-earth ?

++

Mourad




Pourquoi ne pas simplement utiliser les paquets fournis par google ?

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme