Peut on alléger cette formule ?

Le
Louis XV
Bonsoir à tous
Cette formule qui consiste à récupérer la valeur du dernier jour du mois et
la soustraire du dernier jour du mois précédent fonctionne.
Peut on la réduire?

Merci de vos lumières

Louis

=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;1))*($B$1:$B$507))-SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;0))*($B$1:$B$507))
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Trirème
Le #4248861
Bonjour,

Tu peux essayer ceci :
=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;1))-($A$1:$A$507=FIN.MOIS($A$1;0));($B$1:$B$507))
En quelque sorte c'est une factorisation.

Mais ta formule ne fait elle pas "dernier jour mois suivant - dernier jour mois courant" ?

Cordialement,
Trirème

Bonsoir à tous
Cette formule qui consiste à récupérer la valeur du dernier jour du mois et
la soustraire du dernier jour du mois précédent fonctionne.
Peut on la réduire?

Merci de vos lumières

Louis

=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;1))*($B$1:$B$507))-SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;0))*($B$1:$B$507))




Jean Berti
Le #4248851
Merci beaucoup trirème

Ta formule renvoie fin fév - fin janvier
Pour mars - fev je mets
=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;2))-($A$1:$A$507=FIN.MOIS($A$1;1));($B$1:$B$507))
et ca me renvoie la valeur de mars?
C'est peut etre l'heure tardive?
Merci encore de ton aide

Louis

"Trirème" %
Bonjour,

Tu peux essayer ceci :
=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;1))-($A$1:$A$507=FIN.MOIS($A$1;0));($B$1:$B$507))
En quelque sorte c'est une factorisation.

Mais ta formule ne fait elle pas "dernier jour mois suivant - dernier jour
mois courant" ?

Cordialement,
Trirème

Bonsoir à tous
Cette formule qui consiste à récupérer la valeur du dernier jour du mois
et la soustraire du dernier jour du mois précédent fonctionne.
Peut on la réduire?

Merci de vos lumières

Louis

=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;1))*($B$1:$B$507))-SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;0))*($B$1:$B$507))




Trirème
Le #4248781
Ta formule renvoie fin fév - fin janvier
Pour mars - fev je mets
Oui...

=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;2))-($A$1:$A$507=FIN.MOIS($A$1;1));($B$1:$B$507))
et ca me renvoie la valeur de mars?


...Mais par rapport à '$A$1', la fin du mois précédent est FIN.MOIS($A$1;-1)

Cette formule qui consiste à récupérer la valeur du dernier jour du mois
et la soustraire du dernier jour du mois précédent fonctionne.
Ici tu parles bien du mois précédent.




Cordialement,
Trirème



Jean Berti
Le #4325801
"Trirème" %23UGq$
Ta formule renvoie fin fév - fin janvier
Pour mars - fev je mets
Oui...

=SOMMEPROD(($A$1:$A$507=FIN.MOIS($A$1;2))-($A$1:$A$507=FIN.MOIS($A$1;1));($B$1:$B$507))
et ca me renvoie la valeur de mars?


...Mais par rapport à '$A$1', la fin du mois précédent est
FIN.MOIS($A$1;-1)

Cette formule qui consiste à récupérer la valeur du dernier jour du
mois et la soustraire du dernier jour du mois précédent fonctionne.
Ici tu parles bien du mois précédent.




Cordialement,
Trirème


Merci beaucoup

Jean




Publicité
Poster une réponse
Anonyme