Piloter IE

Le
Thierry 46
Bonjour,

Une aide svp


Je pilote IE en VBS et je souhaiterai tout faire avec Windev
Le Script VBS qui fonctionne

Set ie=CreateObject("Internetexplorer.application")
ie.navigate("http://xxxxxxxxxxxxxxxxxxxxxxxxxxx")
ie.visible=True
Set dct=ie.document
dct.form1.login.value="AAAAAAAAA"
dct.form1.password.value="qhqhgqfqfq"
dct.form1.submit
ie.navigate(http://yyyyyyyyyyyyyyyyyyyyyyyyyyyy)

etc.

Avec Windev ??? sans lanceappli.

avec un champ ActiveX Microsoft Web Browser
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
Cela fonctionne jusque là mais après comment passer le login, password,
submit, etc..

Pour navigate ok mais pour le reste niet!

Pourriez-vous me mettre sur une piste ?
Je ne suis pas spécialiste de l'Activex, de l'automation
Pour moi c'est intéressant car si j'automatise la récupération des
données je vais pouvoir afficher des indicateurs, alertes, etc.
Pour la partie programmation je sais faire.

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry 46
Le #16789081
Bonsoir, je me réponds:

AX_ActiveX1="Shell.Explorer"
pautForm est un objet Automation dynamique
pclHermes_ole est un objet dynamique
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN
pautForm=AX_ActiveX1>>Document>>forms("form1")
pautForm>>login>>value="qqqqqqqq"
pautForm>>password>>value="ddddddddd"
pautForm>>submit
AX_ActiveX1>>navigate(httpxxxxxxxxxxxxxxxxxxxxxxxxxxx.php)
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN

cela fonctionne mais je voudrais terminer:
4 secondes d'écriture du fichier
courriers_non_traites_MIDI_20080911_224456.csv.zip

Il me manque à enregistrer ce zip dans un répertoire bien particulier
Help


Thierry 46 a écrit :
Bonjour,

Une aide svp


Je pilote IE en VBS et je souhaiterai tout faire avec Windev
Le Script VBS qui fonctionne

Set ie=CreateObject("Internetexplorer.application")
ie.navigate("http://xxxxxxxxxxxxxxxxxxxxxxxxxxx")
ie.visible=True
Set dct=ie.document
dct.form1.login.value="AAAAAAAAA"
dct.form1.password.value="qhqhgqfqfq"
dct.form1.submit
ie.navigate(http://yyyyyyyyyyyyyyyyyyyyyyyyyyyy)

etc....

Avec Windev ??? sans lanceappli....

avec un champ ActiveX Microsoft Web Browser
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
Cela fonctionne jusque là mais après comment passer le login, password,
submit, etc........

Pour navigate ok mais pour le reste niet!

Pourriez-vous me mettre sur une piste ?
Je ne suis pas spécialiste de l'Activex, de l'automation...
Pour moi c'est intéressant car si j'automatise la récupération des
données je vais pouvoir afficher des indicateurs, alertes, etc....
Pour la partie programmation je sais faire.

Merci



Thierry 46
Le #16789661
Bonsoir,
en fait cela n'a fonctionné que 2 ou 3 fois....
Thierry 46 a écrit :
Bonsoir, je me réponds:

AX_ActiveX1="Shell.Explorer"
pautForm est un objet Automation dynamique
pclHermes_ole est un objet dynamique
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN
pautForm=AX_ActiveX1>>Document>>forms("form1")
pautForm>>login>>value="qqqqqqqq"
pautForm>>password>>value="ddddddddd"
pautForm>>submit
AX_ActiveX1>>navigate(httpxxxxxxxxxxxxxxxxxxxxxxxxxxx.php)
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN

cela fonctionne mais je voudrais terminer:
4 secondes d'écriture du fichier
courriers_non_traites_MIDI_20080911_224456.csv.zip

Il me manque à enregistrer ce zip dans un répertoire bien particulier
Help


Thierry 46 a écrit :
Bonjour,

Une aide svp


Je pilote IE en VBS et je souhaiterai tout faire avec Windev
Le Script VBS qui fonctionne

Set ie=CreateObject("Internetexplorer.application")
ie.navigate("http://xxxxxxxxxxxxxxxxxxxxxxxxxxx")
ie.visible=True
Set dct=ie.document
dct.form1.login.value="AAAAAAAAA"
dct.form1.password.value="qhqhgqfqfq"
dct.form1.submit
ie.navigate(http://yyyyyyyyyyyyyyyyyyyyyyyyyyyy)

etc....

Avec Windev ??? sans lanceappli....

avec un champ ActiveX Microsoft Web Browser
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
Cela fonctionne jusque là mais après comment passer le login,
password, submit, etc........

Pour navigate ok mais pour le reste niet!

Pourriez-vous me mettre sur une piste ?
Je ne suis pas spécialiste de l'Activex, de l'automation...
Pour moi c'est intéressant car si j'automatise la récupération des
données je vais pouvoir afficher des indicateurs, alertes, etc....
Pour la partie programmation je sais faire.

Merci





JA
Le #16790721
Cela pourrait t'aider:
C:WinDev 12ExemplesExemples didactiquesWD Pilotage de IE

Bonne programmation WinDEV
/JA
htt://www.ja-psi.fr
didiflo Hors ligne
Le #24672391
Le jeudi 11 Septembre 2008 à 22:52 par Thierry 46 :
Bonsoir, je me réponds:

AX_ActiveX1="Shell.Explorer"
pautForm est un objet Automation dynamique
pclHermes_ole est un objet dynamique
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN
pautForm=AX_ActiveX1>>Document>>forms("form1")
pautForm>>login>>value="qqqqqqqq"
pautForm>>password>>value="ddddddddd"
pautForm>>submit
AX_ActiveX1>>navigate(httpxxxxxxxxxxxxxxxxxxxxxxxxxxx.php)
TANTQUE AX_ActiveX1>>busy
Multitâche(50)
FIN

cela fonctionne mais je voudrais terminer:
4 secondes d'écriture du fichier
courriers_non_traites_MIDI_20080911_224456.csv.zip

Il me manque à enregistrer ce zip dans un répertoire bien
particulier
Help


Thierry 46 a écrit :
Bonjour,

Une aide svp


Je pilote IE en VBS et je souhaiterai tout faire avec Windev
Le Script VBS qui fonctionne

Set ie=CreateObject("Internetexplorer.application")
ie.navigate("http://xxxxxxxxxxxxxxxxxxxxxxxxxxx")
ie.visible=True
Set dct=ie.document
dct.form1.login.value="AAAAAAAAA"
dct.form1.password.value="qhqhgqfqfq"
dct.form1.submit
ie.navigate(http://yyyyyyyyyyyyyyyyyyyyyyyyyyyy)

etc....

Avec Windev ??? sans lanceappli....

avec un champ ActiveX Microsoft Web Browser
AX_ActiveX1>>Navigate(http://xxxxxxxxxxxxxxxxxxxxxxxxxxx)
AX_ActiveX1>>Visible=Vrai
Cela fonctionne jusque là mais après comment passer le login,
password,
submit, etc........

Pour navigate ok mais pour le reste niet!

Pourriez-vous me mettre sur une piste ?
Je ne suis pas spécialiste de l'Activex, de l'automation...
Pour moi c'est intéressant car si j'automatise la
récupération des
données je vais pouvoir afficher des indicateurs, alertes, etc....
Pour la partie programmation je sais faire.

Merci






bonjour
moi je voudrais me connecter sur le site pmu
mais je arrive pas
sa rempli bien les champs mais je n'arrive pas a valider
une idée
// Déclaration de l'objet pour piloter Internet Explorer
CliExplore:InitActiveX()
CliExplore:SetURL("http://www.pmu.fr/turf")
CliExplore:TempoChargement()

// Recherche par nom du champ
SI CliExplore:bRechercheChampParNom("login") ALORS
CliExplore:SetValeur(SAI_numero_compte)

FIN

SI CliExplore:bRechercheChampParNom("password") ALORS
CliExplore:SetValeur(SAI_password)
FIN

SI CliExplore:bRechercheChampParNom("codePinPad") ALORS
CliExplore:SetValeur(SAI_password2)
FIN
Publicité
Poster une réponse
Anonyme