pipelight nfs et user_xattr

Le
Christophe PEREZ
Bonjour,

Afin d'avoir enfin accès à certains contenus vidéos légaux sur le net
(canal+ ), nécessitant sylverlight, je suis tombé sur une alternative
qui me semblait prometteuse : pipelight

Etant sous gentoo, j'ai donc tenté de suivre le tuto http://
wiki.gentoo.org/wiki/Netflix/Pipelight

Or, je coince dès le premier test sur l'utilisation de user_xattr, bien
que l'option soit activée dans mon noyau.
J'ai mis un moment à réaliser que cela vient sans nul doute du fait que
mon home est monté en nfs.

J'ai donc mis le ~/.wine-pipelight/drive_c en lien symbolique sur un
répertoire créé sur une partition de mon propre disque, lui même monté
avec user_xattr
$ ll .wine-pipelight/drive_c
lrwxrwxrwx 1 chris users 21 21 déc. 19:56 .wine-pipelight/drive_c -> /
other/wine-pipelight
$ df /other/wine-pipelight
$ mount | grep sdb3
/dev/sdb3 on /other type ext3
(rw,noatime,errors=continue,user_xattr,acl,commit=5,barrier=1,data=ordered)
Malgré tout, mon firefox persiste à m'indiquer une erreur pour
l'activation du plugin pipelight.

Je me dis que c'est peut-être une partie de la config firefox qui devrait
avoir accès au user_xattr, mais je ne suis encore arrivé à aucun résultat.

Je vais bien évidemment continuer à chercher, mais au cas où l'un d'entre
vous serait familier à tout ceci, je préfère déjà poster ici.

Merci de m'avoir lu.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe PEREZ
Le #26330565
La suite de mes recherches m'ayant amené sur http://pipelight.net/cms/
tags/user-xattr.html
Je me rends compte que c'est carrément ~/.wine-pipelight qu'il faut
déplacer et lier, mais qu'à priori, le problème ne proviendrait pas de là
puisque le system check me renvoie des erreurs sur tout le reste :

$ pipelight-plugin --system-check
...
wine: cannot find L"C:\windows\system32\winemenubuilder.exe"
err:wineboot:ProcessRunKeys Error running cmd L"C:\windows\system32
winemenubuilder.exe -a -r" (2)
Checking OpenGL ...
OpenGL Vendor: NVIDIA Corporation
OpenGL Renderer: GeForce GTX 650/PCIe/SSE2
OpenGL Direct Rendering: False (or old/wrong wine version)
OpenGL: FAILURE

Checking fonts ...
Missing Arial
Missing Verdana
Fonts: FAILURE

Checking ACLs / XATTR ...
ACLs: PASSED

Checking libraries...
wine: cannot find L"C:\windows\system32\--check-libs.exe"
Libraries: FAILURE

Ben c'est encore loin d'être réglé tout ça :)
Christophe PEREZ
Le #26330564
J'ai finalement réussi à activer quelque chose puisque je vois bien les
animations de la page de test de sylverlight.
Et comme j'ai lu que Canal+ ne supportait pas la version 5.1 mais la 5.0,
j'ai fait comme indiqué
$ pipelight-plugin --disable silverlight5.1 --enable silverlight5.0

Enfin firefox et la page Canal+ considèrent que sylverlight est présent.
Mais quand je lance la visionnage d'une télévision en livetv, je vois
qu'un flux rentre (bande passante utilisée), j'ai la petite animation
m'indiquant de patienter, et au bout d'une vingtaine de seconde, j'ai un
message d'erreur :
IMPOSSIBLE D'OBTENIR LA LICENCE DE CE PROGRAMME. VÉRIFIEZ QUE VOS PILOTES
DE CARTE GRAPHIQUE SONT À JOUR ET REDÉMARREZ LE LECTEUR (ERREUR 6030)

Je ne sais pas si cela a rapport avec ce que j'ai lu, qui nécessiterait
d'installer en plus les drivers nvidia 32 bits (ce que je ne sais pas
faire sous Gentoo), ou si c'est un problème de droits (DRM ?)...
Bref, j'investigue.
Christophe PEREZ
Le #26330567
A lire tout http://forum.ubuntu-fr.org/viewtopic.php?id88971 je crois
que je perds mon temps.
Merci à Canal+ d'avoir choisi le pire système possible.
Publicité
Poster une réponse
Anonyme