pkg-config --modversion zlib

Le
Bonjour,

L'utilisation de Evince est rendue (très) difficile par
le bug :
Debian Bug report logs - #365575
evince: Renders text selection incorrectly (white-on-white)

La seule version qui n'a pas ce bug est dans Experimental.

Du coup, j'essaye de
+compiler+
Evince.

Pour compiler, et avoir le support PDF,
evince demande
poppler 0.5.4,
ou supérieur.

(la version en testing est 0.4.x)

Compiler poppler.

Il semble qu'il veuille bien compiler sans trop se plaindre
Mais,
je souhaiterais que il puisse lire des
fichiers compressés.

Pour ça il demande
zlib.

$ ./configure

Building poppler with support for:
splash output: yes
cairo output: yes
qt wrapper: no
qt4 wrapper: no
qt4 unittests: no
glib wrapper: yes
use gtk-doc: no
use libjpeg: yes
use zlib: no ##########
command line utils: yes

Or zlib, je l'ai.

$ ls /usr/lib/|grep z

libz.a
libz.so
libz.so.1
libz.so.1.2.3

Déjà, elle s'appelle libz
au lieu de zlib

$ apt-cache policy zlib1g-dev
zlib1g-dev:
Installé : 1:1.2.3-13
Candidat : 1:1.2.3.3.dfsg-3

Aptitude nous apprend qu'il fournit le nom de paquet
libz.

Et :

$ pkg-config --modversion zlib libz zlib1g zlib1g-dev

Package zlib was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib.pc'
to the PKG_CONFIG_PATH environment variable
No package 'zlib' found

Package libz was not found in the pkg-config search path.
Perhaps you should add the directory containing `libz.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libz' found

Package zlib1g was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib1g.pc'
to the PKG_CONFIG_PATH environment variable
No package 'zlib1g' found

Ma question est : Donc, comment faire
pour pouvoir compiler poppler avec support zlib.

Et pourquoi pkg-config ne peut pas trouver zlib.

La confusion entre les noms zlib et libz
ne doit pas arranger les choses non plus.

Si jamais vous avez des réponses
sur ces sujets je serai heureux de les lire.

En attendant, je vais compiler (poppler),
sans le support zlib.

FA.








___________________________________________________________________________
Découvrez une nouvelle façon d'obtenir des réponses à toutes vos questions !
Profitez des connaissances, des opinions et des expériences des internautes sur Yahoo! Questions/Réponses
http://fr.answers.yahoo.com


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #9580831
--- a écrit :

Bonjour,

L'utilisation de Evince est rendue (très) difficile par
le bug :
Debian Bug report logs - #365575
evince: Renders text selection incorrectly (white-on-white)

La seule version qui n'a pas ce bug est dans Experimental.

Du coup, j'essaye de
+compiler+
Evince.

Pour compiler, et avoir le support PDF,
evince demande
poppler 0.5.4,
ou supérieur.

(la version en testing est 0.4.x)

Compiler poppler.

Il semble qu'il veuille bien compiler sans trop se plaindre...
Mais,
je souhaiterais que il puisse lire des
fichiers compressés.

Pour ça il demande
zlib.

$ ./configure
...
Building poppler with support for:
splash output: yes
cairo output: yes
qt wrapper: no
qt4 wrapper: no
qt4 unittests: no
glib wrapper: yes
use gtk-doc: no
use libjpeg: yes
use zlib: no ##########
command line utils: yes




Sur +ce+ point, toutes mes excuses :

./configure --enable-zlib

use libjpeg: yes
use zlib: yes
command line utils: yes

:)



Or zlib, je l'ai.

$ ls /usr/lib/|grep z
...
libz.a
libz.so
libz.so.1
libz.so.1.2.3

Déjà, elle s'appelle libz
au lieu de zlib

$ apt-cache policy zlib1g-dev
zlib1g-dev:
Installé : 1:1.2.3-13
Candidat : 1:1.2.3.3.dfsg-3

Aptitude nous apprend qu'il fournit le nom de paquet
libz.

Et :

$ pkg-config --modversion zlib libz zlib1g zlib1g-dev

Package zlib was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib.pc'
to the PKG_CONFIG_PATH environment variable
No package 'zlib' found

Package libz was not found in the pkg-config search path.
Perhaps you should add the directory containing `libz.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libz' found

Package zlib1g was not found in the pkg-config search path.
Perhaps you should add the directory containing `zlib1g.pc'
to the PKG_CONFIG_PATH environment variable
No package 'zlib1g' found




Pourquoi pkg-config ne trouve pas zlib ?

À quoi sert pkg-congig ?

Comment ./configure trouve-t-il xlib, si ce n'est
oar pkg-config

FA



Ma question est : Donc, comment faire
pour pouvoir compiler poppler avec support zlib.

Et pourquoi pkg-config ne peut pas trouver zlib.

La confusion entre les noms zlib et libz
ne doit pas arranger les choses non plus.

Si jamais vous avez des réponses
sur ces sujets je serai heureux de les lire.

En attendant, je vais compiler (poppler),
sans le support zlib.

FA.











___________________________________________________________________________

Découvrez une nouvelle façon d'obtenir des réponses à toutes vos
questions !
Profitez des connaissances, des opinions et des expériences des
internautes sur Yahoo! Questions/Réponses
http://fr.answers.yahoo.com


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact








____________________________________________________________________________________________
Découvrez le blog Yahoo! Mail : dernières nouveautés, astuces, conseils.. et vos réactions !
http://blog.mail.yahoo.fr


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme