Plus d'affichage des erreurs

Le
bmayer
Bonjour

Je viens de migrer mes applis d'un serveur Apache vers un serveur IIS.
Malgré une vérification (error_display est a On, error_reporting est a
E_STRICT, ) de la config, je n'ai pas d'affichage des erreurs. Par
exemple :
<?php
echo '<html><head></head><body>';
echo 'avant<br />';
echo fonction_pas_declaree();
echo 'apres<br />';
echo '</body></html>';

L'examen du flux que reçoit le navigateur révèle que, apres la
fonction non declaree, il n'y a plus rien.

Quelqu'un a une idee ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #20412471
Bonjour,

Le 24/10/2009 00:11, bmayer a écrit :

Je viens de migrer mes applis d'un serveur Apache vers un serveur IIS.
Malgré une vérification (error_display est a On, error_reporting est a
E_STRICT, ...) de la config, je n'ai pas d'affichage des erreurs.



D'après la doc, E_STRICT ne remplace pas E_ALL mais il le complète. Tu
devrais essayer error_reporting(E_ALL|E_STRICT).

Cordialement,
--
Olivier Miakinen
bmayer
Le #20417691
> > Je viens de migrer mes applis d'un serveur Apache vers un serveur IIS.
> Malgré une vérification (error_display est a On, error_reporting est a
> E_STRICT, ...) de la config, je n'ai pas d'affichage des erreurs.

D'après la doc, E_STRICT ne remplace pas E_ALL mais il le complète. Tu
devrais essayer error_reporting(E_ALL|E_STRICT).



Bingo !

Merci !
Publicité
Poster une réponse
Anonyme