plus de scanner ni imprimante

Le
Daniel Caillibaud
Bonjour,

Aujourd'hui mon scanner & imprimante marche plus.
C'est une hp psc 2210, un truc combiné assez ancien, sous wheezy amd64.

J'ai cru que c'était à cause de la récente mise à jour =
dbus & xorg
[MIS A JOUR] dbus:amd64 1.6.8-1+deb7u5 -> 1.6.8-1+deb7u6
[MIS A JOUR] dbus-x11:amd64 1.6.8-1+deb7u5 -> 1.6.8-1+deb7u6
[MIS A JOUR] libdbus-1-3:amd64 1.6.8-1+deb7u5 -> 1.6.8-1+deb7u6
[MIS A JOUR] libdbus-1-3:i386 1.6.8-1+deb7u5 -> 1.6.8-1+deb7u6
[MIS A JOUR] xserver-common:amd64 2:1.12.4-6+deb7u5 -> 2:1.12.4-6+deb7u6
[MIS A JOUR] xserver-xorg-core:amd64 2:1.12.4-6+deb7u5 -> 2:1.12.4-6+deb7u6

J'ai donc remis les vieilles versions pour voir

aptitude install dbus:amd64=1.6.8-1+deb7u5 dbus-x11:amd64=1.6.8-1+deb7u=
5 libdbus-1-3:amd64=1.6.8-1+deb7u5 libdbus-1-3:i386=1.6.8-1+deb7u5
xserver-common:amd64=2:1.12.4-6+deb7u5 xserver-xorg-core:amd64=2:1.12=
.4-6+deb7u5

puis redémarré le PC pour être sûr de l'init correct de=
dbus et ses copains (dpkg avait dit
ne pas avoir pu le faire car dbus était en route), mais à l'allum=
age du scanner j'ai toujours
dans syslog

Feb 15 21:48:14 quad kernel: [ 171.524016] usb 6-1: new full-speed USB dev=
ice number 4 using uhci_hcd
Feb 15 21:48:14 quad kernel: [ 171.722209] usb 6-1: New USB device found, =
idVendor=03f0, idProduct=2911
Feb 15 21:48:14 quad kernel: [ 171.722213] usb 6-1: New USB device strings=
: Mfr=1, Product=2, SerialNumber=3
Feb 15 21:48:14 quad kernel: [ 171.722215] usb 6-1: Product: PSC 2200 Seri=
es
Feb 15 21:48:14 quad kernel: [ 171.722217] usb 6-1: Manufacturer: Hewlett-=
Packard
Feb 15 21:48:14 quad kernel: [ 171.722219] usb 6-1: SerialNumber: MY36EF32=
3V0G
Feb 15 21:48:14 quad kernel: [ 171.729271] usblp0: USB Bidirectional print=
er dev 4 if 1 alt 0 proto 2 vid 0x03F0 pid 0x2911
Feb 15 21:48:14 quad kernel: [ 171.729469] scsi8 : usb-storage 6-1:1.3
Feb 15 21:48:14 quad mtp-probe: checking bus 6, device 4: "/sys/devices/pci=
0000:00/0000:00:1d.0/usb6/6-1"
Feb 15 21:48:14 quad mtp-probe: bus: 6, device: 4 was not an MTP device
Feb 15 21:48:15 quad kernel: [ 172.732244] scsi 8:0:0:0: Direct-Access =
HP psc 2210 1.00 PQ: 0 ANSI: 2
Feb 15 21:48:15 quad kernel: [ 172.732849] sd 8:0:0:0: Attached scsi gener=
ic sg7 type 0
Feb 15 21:48:15 quad kernel: [ 172.743225] sd 8:0:0:0: [sdg] Attached SCSI=
removable disk
Feb 15 21:48:19 quad colord-sane: io/hpmud/musb.c 2066: Invalid usb_open: P=
ermission denied

Et lorsque je lance un scan avec simple-scan (ou xsane, idem), ça moul=
ine un moment et sort en syslog

Feb 15 21:49:32 quad kernel: [ 250.297510] usblp0: removed
Feb 15 21:49:32 quad kernel: [ 250.298298] Did not find alt setting 1 for =
intf 0, config 1
Feb 15 21:49:32 quad kernel: [ 250.301251] Did not find alt setting 1 for =
intf 0, config 1
Feb 15 21:49:38 quad colord-sane: io/hpmud/musb.c 2066: Invalid usb_open: P=
ermission denied
Feb 15 21:50:21 quad simple-scan: io/hpmud/mlc.c 507: unable to read MlcRev=
erseData header: Succès hp:/usb/PSC_2200_Series?serial=MY36EF323V0G
Feb 15 21:50:23 quad simple-scan: sane_hpaio_cancel: already cancelled!

Si je veux imprimer, j'ai les erreurs

Feb 15 22:01:43 quad hp[6810]: io/hpmud/musb.c 1442: unable to write data h=
p:/usb/PSC_2200_Series?serial=MY36EF323V0G: 45 second io timeout
Feb 15 22:01:43 quad kernel: [ 980.648655] Did not find alt setting 1 for =
intf 0, config 1

Par acquis de conscience, je vérifié le cable usb, et je retente =
un essai avec un
vieux scanner epson (perfection 1260), et là c'est lent mais ça m=
arche.

Je soupçonne donc un pb avec HP, j'ai les paquets
i A hp-ppd - fichiers de définition des imprima=
ntes Postscript HP (PPD)
i A hpijs - transitional dummy package for hpijs pr=
inter driver
i A hplip - Système d'impression et d'imagerie=
Linux HP (HPLIP)
i hplip-data - système d'impression et d'imagerie=
Linux HP (HPLIP) - fichiers de données
i A libhpmud0 - pilote de transport HP multi-points (hp=
mud) - bibliothèques d’exécution
i libsane-hpaio - moteur SANE pour les imprimantes multif=
onctions HP
i A printer-driver-hpcups - imagerie et impression HP pour Linux - =
pilote CUPS (hpcups)
i A printer-driver-hpijs - Système d'impression et d'imagerie=
HP - pilote gs IJS (hpifs)
i printer-driver-postscript-hp - HP Printers PostScript Descriptions

mais je vois pas trop où creuser

Merci à ceux qui auraient des indices.

--
Daniel

Ce qui vient au monde pour ne rien troubler
ne mérite ni égards ni patience.
Victor Hugo

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20150215222113.2ddb977f@quad.lairdutemps.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Caillibaud
Le #26339333
Le 15/02/15 à 22:25, "JF Straeten" JS> Ça sent un problème de permissions...
JS>
JS> As-tu essayé sous le compte root pour voir ?

Oui, oublié de le préciser, c'était le même résultat (lancé xsa ne qui voit le scanner mais
fait un timeout au scan).

--
Daniel

Frère Jacques Clément, C'est l'Enfer qui m'a créé.
Alphonse Allais, Anagrammes

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Daniel Caillibaud
Le #26339337
Le 15/02/15 à 22:25, ""
CF> le roll-back des paquets ne réinstalle pas toujours les fichiers de
CF> config qui allait avec le problème viens peut être de là voir si des
CF> fichiers de config ont été installé avec la nouvelle version et e ssayer
CF> avec apt-get remove --purge par éxemple et ré installer les paquets
CF> par fois il suffit de pas grand chose ....

J'ai comparé mon /etc avec un backup antérieur, la seule différence n otable était
sur /etc/cups/printers.conf avec

< State Stopped
< StateMessage /usr/lib/cups/backend/hp failed
< StateTime 1424034404
< Reason paused
---
State Idle
StateTime 1424037183



Bingo, pourquoi Stopped ?
Et pourquoi personne me dit rien ?

Du coup, je remet l'ancien, redémarre cups, rallume l'imprimante (me rapp elle plus trop dans
quel ordre), et elle sort une feuille (mon test précédent).

Ce que je trouve curieux, c'est le rapport entre ça et le fait que le sca nner remarche...
Quel rapport entre le scanner et cups ?

Je relance mes mises à jour pour voir si ça tient.

--
Daniel

Les USA sont passés du stade primitif à celui de la décadence
sans cette période intermédiaire que l'on nomme, ailleurs, civilisation.
Georges Clémenceau.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
JF Straeten
Le #26339336
Re,

On Sun, Feb 15, 2015 at 11:05:12PM +0100, Daniel Caillibaud wrote:

[...]
Ce que je trouve curieux, c'est le rapport entre ça et le fait que le scanner remarche...
Quel rapport entre le scanner et cups ?



Bien vu, et intéressant...

Si ça se trouve, quand l'imprimante est stoppée, le soft n'accepte pas
que l'on se serve du scanner ?

Je relance mes mises à jour pour voir si ça tient.



Tu peux être vite fixé : tu mets l'imprimante en pause manuellement
(cups disable) et tu essayes de scanner ?

A+


--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Daniel Caillibaud
Le #26339345
Le 15/02/15 à 23:10, "JF Straeten" JS> On Sun, Feb 15, 2015 at 11:05:12PM +0100, Daniel Caillibaud wrote:
JS>
JS> [...]
JS> > Ce que je trouve curieux, c'est le rapport entre ça et le fait que le scanner remarche...
JS> > Quel rapport entre le scanner et cups ?
JS>
JS> Bien vu, et intéressant...
JS>
JS> Si ça se trouve, quand l'imprimante est stoppée, le soft n'accepte pas
JS> que l'on se serve du scanner ?

Ben, le soft c'est xsane non ?
Il n'a a priori rien à voir avec cups.

Mais effectivement, peut-être que cet état stoppé a été répercu té à la machine qui du coup
refusait le scan, bien que sur son mini écran LCD tout semblait normal.

JS> > Je relance mes mises à jour pour voir si ça tient.
JS>
JS> Tu peux être vite fixé : tu mets l'imprimante en pause manuellement
JS> (cups disable) et tu essayes de scanner ?

Après avoir stoppé cups ça scanne normalement, mais j'aurais eu du ma l à comprendre le
contraire (m'enfin avec le matériel j'ai souvent du mal à comprendre).

Merci à vous deux, la piste /etc a permis de régler le pb.

--
Daniel

L'homme raisonnable s'adapte au monde.
L'homme déraisonnable essaye d'adapter le monde à lui-même.
Par conséquent tout progrès dépend de l'homme qui n'est pas raisonnab le.
Bernard Shaw

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
JF Straeten
Le #26339344
Re,

On Sun, Feb 15, 2015 at 11:32:08PM +0100, Daniel Caillibaud wrote:

[...]
JS> Si ça se trouve, quand l'imprimante est stoppée, le soft n'accepte pas
JS> que l'on se serve du scanner ?

Ben, le soft c'est xsane non ?
Il n'a a priori rien à voir avec cups.



Non, je parlais d'un soft de plus bas niveau : le log disait musb.c à
l'endroit de l'erreur, si je me souviens bien (?) On doit être au
niveau du pilote du périphérique...


[...]
Après avoir stoppé cups ça scanne normalement, mais j'aurais eu du
mal à comprendre le contraire (m'enfin avec le matériel j'ai souvent
du mal à comprendre).



Mmmm... ben ça dépend... Apparemment, l'arrêt de cups (par la modif du
fichier de config à l'origine du problème) semble avoir eu une
répercussion sur le pilote lui-même... De là à imaginer que ce type
d'arrêt là le met dans un état où il ne permet plus de rien faire avec
le périph, il n'y a qu'un pas...

Tout ce que le test de mise en pause manuelle démontre, à mon avis,
est que ça ne le fait pas en mettant en pause manuelle. Mais tantôt
(époque du fichier de conf modifié), il s'est bien passé quelque
chose...

Bon, maintenant, si ça marche, on n'est pas non plus forcé de chercher
plus loin.


Merci à vous deux, la piste /etc a permis de régler le pb.



C'est ce qui compte ; les voies du matos sont parfois impénétrables ;)

A+

--

JFS.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Bernard Schoenacker
Le #26339349
Le Sun, 15 Feb 2015 22:58:37 +0100,
Daniel Caillibaud
Le 15/02/15 à 22:25, "JF Straeten" JS> Ça sent un problème de permissions...
JS>
JS> As-tu essayé sous le compte root pour voir ?

Oui, oublié de le préciser, c'était le même résultat (lancé xsane qui
voit le scanner mais fait un timeout au scan).




bonjour,


je conseille de faire un tour du côté de turbo print :

http://www.turboprint.info/


slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Alain Rpnpif
Le #26339507
Bonjour,

Cela ressemble à une désactivation de l'imprimante par CUPS suite à
un petit problème d'imprimante (communication ou autre). La faute à  
CUPS.

C'est pénible et j'ai souvent le problème.

Solution qui peut aider :

Aller dans l'écran de configuration de CUPS qui est à une adresse par
exemple http://127.0.0.1:631/
Modifier les réglages de l'imprimante en redéfinissant ses options
(l'écran exact dépend de l'imprimante) :
Régles : Régle d'erreur : remplacer stop-printer par abort-job ou autre
chose.
Définir ça par défaut.

Cela donne dans /etc/cups/printers.conf
OpPolicy default
ErrorPolicy abort-job

Ce changement empêche CUPS de mettre l'imprimante en pause en cas
d'erreur, c'est-à-dire de couper toute communication vers elle.

Le réglage par défaut d'origine est vraiment pénible.

Cordialement.

--
Alain Rpnpif

Le 15 février 2015, Daniel Caillibaud a écrit :

Le 15/02/15 à 23:10, "JF Straeten" JS> On Sun, Feb 15, 2015 at 11:05:12PM +0100, Daniel Caillibaud wrote:
JS>
JS> [...]
JS> > Ce que je trouve curieux, c'est le rapport entre ça et le fait que le scanner remarche...
JS> > Quel rapport entre le scanner et cups ?
JS>
JS> Bien vu, et intéressant...
JS>
JS> Si ça se trouve, quand l'imprimante est stoppée, le soft n' accepte pas
JS> que l'on se serve du scanner ?

Ben, le soft c'est xsane non ?
Il n'a a priori rien à voir avec cups.

Mais effectivement, peut-être que cet état stoppé a é té répercuté à la machine qui du coup
refusait le scan, bien que sur son mini écran LCD tout semblait norm al.

JS> > Je relance mes mises à jour pour voir si ça tient.
JS>
JS> Tu peux être vite fixé : tu mets l'imprimante en pause manu ellement
JS> (cups disable) et tu essayes de scanner ?

Après avoir stoppé cups ça scanne normalement, mais j'aura is eu du mal à comprendre le
contraire (m'enfin avec le matériel j'ai souvent du mal à compr endre).

Merci à vous deux, la piste /etc a permis de régler le pb.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Daniel Caillibaud
Le #26339691
Le 17/02/15 à 11:58, Alain Rpnpif AR> Solution qui peut aider :

AR> Cela donne dans /etc/cups/printers.conf
AR> OpPolicy default
AR> ErrorPolicy abort-job

Merci bcp

AR> Ce changement empêche CUPS de mettre l'imprimante en pause en cas
AR> d'erreur, c'est-à-dire de couper toute communication vers elle.

C'est exactement ça qu'il me fallait, car comme ça arrive pas souvent j 'aurai p'tet oublié la
prochaine fois.

AR> Le réglage par défaut d'origine est vraiment pénible.

Bien d'accord !

--
Daniel

Ce n'est pas n'importe qui qui peut-être quiconque.
Pierre Dac

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme