port serie rs /usb ubuntu

Le
remy
bonjour

je possède un adaptateur usb rs qui marchait très bien
avec une ubuntu 7.04 mais depuis que je suis passé à la dernière
il ne veut plus rien savoir

seul le dtr rts sont actifs rien sur tx

en gros les manip déjà faites

lsusb

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 002 Device 002: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial =

Port

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
remy@remy-desktop:~$

remy@remy-desktop:~$ sudo modprobe usbserial vendor=0x067b product=0x=
2303
[sudo] password for remy:
remy@remy-desktop:~$

dmesg

6066.727131] usb 2-2: configuration #1 chosen from 1 choice
[ 6066.730917] pl2303 2-2:1.0: pl2303 converter detected
[ 6066.742124] usb 2-2: pl2303 converter now attached to ttyUSB1
remy@remy-desktop:~$

et minicom -s
ttyUSB1 bien paramétré

en gros

http://cjoint.com/data/bCqrRmArAE.htm
une piste ?

merci remy


--
http://remyaumeunier.chez-alice.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Luc.Habert.00__arjf
Le #21073041
Est-ce que le module pl2303 est chargé?
remy
Le #21073251
Luc Habert a écrit :
Est-ce que le module pl2303 est chargé?


lsmod

:~$ lsmod

Module Size Used by
.....
snd_seq_device 6920 5
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 59204 16
snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,s nd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
pl2303 17792 0
usbserial 36264 1 pl2303
soundcore 7264 1 snd
....
output 2780 1 video
r8169 32064 0
mii 5212 1 r8169
intel_agp 27484 2 i915
agpgart 34988 2 drm,intel_agp
:~$

oui oui

--
http://remyaumeunier.chez-alice.fr/
remy
Le #21073331
Luc Habert a écrit :
Est-ce que le module pl2303 est chargé?


chargé et utiliser

:~$ sudo depmod
:~$ cat /lib/modules/2.6.31-17-generic/modules.dep
|grep pl2303

kernel/drivers/usb/serial/pl2303.ko: kernel/drivers/usb/serial/usbserial. ko

:~$


--
http://remyaumeunier.chez-alice.fr/
Pascal Hambourg
Le #21073571
Salut,

remy a écrit :
Luc Habert a écrit :
Est-ce que le module pl2303 est chargé?


chargé et utiliser

:~$ sudo depmod
:~$ cat /lib/modules/2.6.31-17-generic/modules.dep
|grep pl2303

kernel/drivers/usb/serial/pl2303.ko: kernel/drivers/usb/serial/usbserial.ko



Ceci ne veut pas dire que le module pl2303 est utilisé mais simplement
qu'il dépend du module usbserial.
remy
Le #21073561
Luc Habert a écrit :
Est-ce que le module pl2303 est chargé?


chargé et utilisable ou compatible avec le noyaux


:~$ sudo depmod
:~$ cat /lib/modules/2.6.31-17-generic/modules.dep
|grep pl2303

kernel/drivers/usb/serial/pl2303.ko: kernel/drivers/usb/serial/usbserial. ko

:~$ uname -a
Linux remy-desktop 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31
UTC 2009 i686 GNU/Linux
:~$


--
http://remyaumeunier.chez-alice.fr/
remy
Le #21113701
problème réglé

le modem étant un modem auto alimenté
et l'ordinateur étant lui aussi différent
le problème venait de là

donc le driver marche très bien
et fonctionne avec minicom
si je prends un modem avec
alim externe

en gros l'usb du premier ordi
était plus péchu que l'usb du nouvel ordi


remy



--
http://remyaumeunier.chez-alice.fr/
Pascal Hambourg
Le #21114051
remy a écrit :

problème réglé

le modem étant un modem auto alimenté



Auto-alimenté ou alimenté par le bus ?

et l'ordinateur étant lui aussi différent



Différent de quoi ?

le problème venait de là



De quoi au juste ?

donc le driver marche très bien et fonctionne avec minicom
si je prends un modem avec alim externe



Ça c'est auto-alimenté. Le contraire d'alimenté par le bus.

en gros l'usb du premier ordi
était plus péchu que l'usb du nouvel ordi



Quel premier ordinateur ? Sauf inattention de ma part, tu n'en as jamais
parlé dans tes articles précédents.
remy
Le #21116801
Pascal Hambourg a écrit :
remy a écrit :
problème réglé

le modem étant un modem auto alimenté



Auto-alimenté ou alimenté par le bus ?




tiens on troll, maintenant ici
donc si le modem est auto-alimenté
je serais enclin à penser qu'il est alimenté par l'adaptateur usb
puisque dans le cas contraire il serait alimenté par une
pile ,ce que j' apparente à une alimentation externe

donc effectivement le terme auto alimenté est peut être un abus de la ngage
mais dans ce cas comment qualifier le fonctionnement du dit
appareil, puisque il fonctionne sans apport d'énergie autre que son bus
qui est en l'occurence un port série qui lui est indispensable à son
fonctionnement alimentation externe ou pas



et l'ordinateur étant lui aussi différent



Différent de quoi ?


tiens au hasard du précédent tu vois autre chose


le problème venait de là



De quoi au juste ?

donc le driver marche très bien et fonctionne avec minicom
si je prends un modem avec alim externe



Ça c'est auto-alimenté. Le contraire d'alimenté par le bus.

en gros l'usb du premier ordi
était plus péchu que l'usb du nouvel ordi



Quel premier ordinateur ? Sauf inattention de ma part, tu n'en as jamai s
parlé dans tes articles précédents.



remy

--
http://remyaumeunier.chez-alice.fr/
Publicité
Poster une réponse
Anonyme