Position dans une plage

Le
Infogroup
Bonjour ou rebonjour à tous

dans la plage A1:A20, j'ajoute régulièrement des denrées comme ci-dessous :

tomates
oeufs
oignons
carottes
oeufs
cèleri
salade
pommes de terre
oeufs
haricots

j'aimerais connaître toutes les positions dans la plage de la rubrique "oeufs"
Equiv ne donne que la 1ère valeur trouvée

Si possible j'aimerais une solution par formule plustôt que par macro


Merci par avance de votre aide

Cordialement

--
M.Infogroup
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4648461
bonjour,

voilà la formule marticielle (à valider avec ctrl+maj+enter),

1er position

=PETITE.VALEUR(SI(A1:A20="œufs";LIGNE(A1:A20));1)

2em position

=PETITE.VALEUR(SI(A1:A20="œufs";LIGNE(A1:A20));2)

etc...

isabelle

Bonjour ou rebonjour à tous

dans la plage A1:A20, j'ajoute régulièrement des denrées comme ci-dessous :

tomates
oeufs
oignons
carottes
oeufs
cèleri
salade
pommes de terre
oeufs
haricots

j'aimerais connaître toutes les positions dans la plage de la rubrique "oeufs"
Equiv ne donne que la 1ère valeur trouvée

Si possible j'aimerais une solution par formule plustôt que par macro


Merci par avance de votre aide

Cordialement



Infogroup
Le #4648451
Bonjour isabelle et merci beaucoup pour ta réponse

Cordialement
--
M.Infogroup



bonjour,

voilà la formule marticielle (à valider avec ctrl+maj+enter),

1er position

=PETITE.VALEUR(SI(A1:A20="œufs";LIGNE(A1:A20));1)

2em position

=PETITE.VALEUR(SI(A1:A20="œufs";LIGNE(A1:A20));2)

etc...

isabelle

Bonjour ou rebonjour à tous

dans la plage A1:A20, j'ajoute régulièrement des denrées comme ci-dessous :

tomates
oeufs
oignons
carottes
oeufs
cèleri
salade
pommes de terre
oeufs
haricots

j'aimerais connaître toutes les positions dans la plage de la rubrique "oeufs"
Equiv ne donne que la 1ère valeur trouvée

Si possible j'aimerais une solution par formule plustôt que par macro


Merci par avance de votre aide

Cordialement






JB
Le #4648441
Bonjour,

-sélectionner E2:E12
=SI(ESTNUM(PETITE.VALEUR(SI(champ=$C
$2;LIGNE(INDIRECT("1:"&LIGNES(champ))));LIGNE(INDIRECT("1:"&LIGNES(champ))) ));PETITE.VALEUR(SI(champ=
$C
$2;LIGNE(INDIRECT("1:"&LIGNES(champ))));LIGNE(INDIRECT("1:"&LIGNES(champ))) );"")
valider avec maj+ctrl+entrée

http://cjoint.com/?ijrKWACGGj

http://boisgontierjacques.free.fr/2007/pages_site/sommeprod.htm

JB
On 9 août, 16:50, Infogroup wrote:
Bonjour ou rebonjour à tous

dans la plage A1:A20, j'ajoute régulièrement des denrées comme ci-d essous :

tomates
oeufs
oignons
carottes
oeufs
cèleri
salade
pommes de terre
oeufs
haricots

j'aimerais connaître toutes les positions dans la plage de la rubrique "oeufs"
Equiv ne donne que la 1ère valeur trouvée

Si possible j'aimerais une solution par formule plustôt que par macro

Merci par avance de votre aide

Cordialement

--
M.Infogroup


Publicité
Poster une réponse
Anonyme