Pour JB

Le
Pascal
Bonjour JB
J'ai testé les validations cascades. Cela fonctionne, mais j'ai quand même
un soucis.
Par macro, je recopie les données validation sur la ligne du dessous à
chaque saisie. Alors
j'ai bien ma formule de validation =SI(NBCAR(B566)>1;Lettres;
DECALER(Pays;EQUIV(B566&"*";Pays;0)-1;;NB.SI(Pays;B566&"*"))), mais au lieu
de m'afficher les lettres, elle m'affiche les pays.
Tu vois d'où cela peut venir??

Pascal





Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000723-1, 12/03/2007
Analyse le : 13/03/2007 09:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.
http://www.avast.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4327141
Bonsoir,

Je ne suis pas sûr de comprendre la question.
J'ai fait une modif. Si la cellule est vide, on a les lettres:

=SI(NBCAR(A2)=1;DECALER(BDNoms;EQUIV(A2&"*";BDNoms;
0)-1;;NB.SI(BDNoms;A2&"*"));Lettre)

http://cjoint.com/?douXnXo7Gm

JB

On 13 mar, 09:23, "Pascal"
BonjourJB
J'ai testé les validations cascades. Cela fonctionne, mais j'ai quand m ême
un soucis.
Par macro, je recopie les données validation sur la ligne du dessous à
chaque saisie. Alors
j'ai bien ma formule de validation =SI(NBCAR(B566)>1;Lettres;
DECALER(Pays;EQUIV(B566&"*";Pays;0)-1;;NB.SI(Pays;B566&"*"))), mais au li eu
de m'afficher les lettres, elle m'affiche les pays.
Tu vois d'où cela peut venir??

Pascal

---
Antivirus avast! : message Sortant sain.
Base de donnees virale (VPS) : 000723-1, 12/03/2007
Analyse le : 13/03/2007 09:23:06
avast! - copyright (c) 1988-2007 ALWIL Software.http://www.avast.com


Publicité
Poster une réponse
Anonyme