Pour les pros d'Office

Le
PhD
Bonjour à tous,
Je dois rédiger les commentaires de correction d'un test. Il y a 5 parties
consécutives qui chacune peuvent avoir 3 valeurs (P O N). Les 15
commentaires sont déjà rédigés mais cela fait au total 243 (3 puissance 5)
combinaisons de commentaires différents : de PPPPP à NNNNN.

Je peux faire ça à la main en copiant-collant, mais peut-être y-a-t-il une
méthode de fusion(qui m'éviterait 5 ou 6 heures -au moins- de manip) ? Je
travaille avec Excel pour la feuille de test, la correction et l'étalonnage
et ensuite je livre les résultats sur Word.

Merci d'avance pour toutes les idées
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Anacoluthe
Le #1711270
Bonjour !

'PhD' nous a écrit ...
Je dois rédiger les commentaires de correction d'un test. Il y a 5 parties
consécutives qui chacune peuvent avoir 3 valeurs (P O N). Les 15
commentaires sont déjà rédigés mais cela fait au total 243 (3 puissance 5)
combinaisons de commentaires différents : de PPPPP à NNNNN.
Je peux faire ça à la main en copiant-collant, mais peut-être y-a-t-il une
méthode de fusion(qui m'éviterait 5 ou 6 heures -au moins- de manip) ? Je
travaille avec Excel pour la feuille de test, la correction et l'étalonnage
et ensuite je livre les résultats sur Word.


Le plus simple est de tout faire dans Excel : 5 colonnes commentaires calculées
sur les 5 colonnes de valeurs à partir de la matrice de vos 15 commentaire.
Dans Word il suffit ensuite de fusionner directement sur les commentaires...

Anacoluthe
« Hasarder des réponses est une manière d’éclaircir les questions. »
- Alessandro BARICCO

PhD
Le #1711268
"Anacoluthe"
Bonjour !

'PhD' nous a écrit ...
Je dois rédiger les commentaires de correction d'un test. Il y a 5
parties consécutives qui chacune peuvent avoir 3 valeurs (P O N). Les 15
commentaires sont déjà rédigés mais cela fait au total 243 (3 puissance
5) combinaisons de commentaires différents : de PPPPP à NNNNN.
Je peux faire ça à la main en copiant-collant, mais peut-être y-a-t-il
une méthode de fusion(qui m'éviterait 5 ou 6 heures -au moins- de manip)
? Je travaille avec Excel pour la feuille de test, la correction et
l'étalonnage et ensuite je livre les résultats sur Word.


Le plus simple est de tout faire dans Excel : 5 colonnes commentaires
calculées
sur les 5 colonnes de valeurs à partir de la matrice de vos 15
commentaire.
Dans Word il suffit ensuite de fusionner directement sur les
commentaires...

Anacoluthe
« Hasarder des réponses est une manière d’éclaircir les questions. »
- Alessandro BARICCO


Merci bcp pour la réponse, mais... je ne sais pas faire.
C'est-à-dire que je sais afficher des commentaires en fonction d'une valeur
(via la mise en forme conditionnelle) mais je ne sais pas attribuer un
commentaire à une cellule en fonction de la valeur d'un paramètre..






Anacoluthe
Le #1712590
Bonjour !

'PhD' nous a écrit ...
Merci bcp pour la réponse, mais... je ne sais pas faire.


Oui mais là vous posez une question EXCEL !!! (et non WORD) :-p

Supposons dans votre classeur excel :
A B C D E colonnes des valeurs P O ou N
G H I J K colonnes des commentaires correspondants
L1-M15 matrice des 15 commentaires AP AO AN ... FP FO FN
en G2 j'aurais la formule =RECHERCHEV(A2;L1:M3;2)

Pour le publipostage, au lieu d'aller chercher les valeurs en A B C D E
j'irais prendre directement les commentaires calculés en G H I J K

Mais votre question initiale était beaucoup trop imprécise
pour être certain de l'avoir comprise...

Anacoluthe
« Il n'y a pas de substitut à l'excellence. »
- Thomas BOSWELL

PhD
Le #1712573
"Anacoluthe"
Bonjour !

'PhD' nous a écrit ...
Merci bcp pour la réponse, mais... je ne sais pas faire.


Oui mais là vous posez une question EXCEL !!! (et non WORD) :-p

Supposons dans votre classeur excel :
A B C D E colonnes des valeurs P O ou N
G H I J K colonnes des commentaires correspondants
L1-M15 matrice des 15 commentaires AP AO AN ... FP FO FN
en G2 j'aurais la formule =RECHERCHEV(A2;L1:M3;2)

Pour le publipostage, au lieu d'aller chercher les valeurs en A B C D E
j'irais prendre directement les commentaires calculés en G H I J K

Mais votre question initiale était beaucoup trop imprécise
pour être certain de l'avoir comprise...

Bonjour,

Je vais prendre un peu de temps pour réfléchir à votre réponse (et je vous
en remercie) et si je n'y arrive pas je continuerai mes questions dans le
groupe....Excel.
C'est vrai que la question initiale était imprécise ; mais on hésite
toujours entre une formulation un peu vague et une présentation précise
mais.... qui fait 3 pages !
en tous cas merci


Publicité
Poster une réponse
Anonyme