POUR TOUT vs HLitxx

Le
Dams
Bonjour,

je souhaiterai recueillir votre retour sur expérience quant à l'usage
des fonctions de recherche dans des fichiers HF.

Si par exemple je recherche un élément sur un ID (donc Unique) est-ce
plus optimisé d'utiliser une boucle POUR TOUT :

POUR TOUT FICHIER AVEC RUB = MonID

FIN


ou alors HLitRecherchePremier(FICHIER, RUB, MonID)


Y a t-il une grosse différence entre ces 2 utilisations et surtout
dans le temps d'exécution ?

Dams
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Benoit
Le #20691381
POUR TOUT ... AVEC est équivalent à un HFiltre avec bornemin/bornemax
sur la clé. Il y a également des sauvegardes de posistions automatiques.

Pour rechercher une valeur, HLitRecherchePremier est nettement
préférable dans la plupart des cas. A mon avis!

Benoit



Dams a écrit :
Bonjour,

je souhaiterai recueillir votre retour sur expérience quant à l'usage
des fonctions de recherche dans des fichiers HF.

Si par exemple je recherche un élément sur un ID (donc Unique) est-ce
plus optimisé d'utiliser une boucle POUR TOUT :

POUR TOUT FICHIER AVEC RUB = MonID

FIN


ou alors HLitRecherchePremier(FICHIER, RUB, MonID)


Y a t-il une grosse différence entre ces 2 utilisations et surtout
dans le temps d'exécution ?

Dams


Romain PETIT
Le #20692141
Dams a couché sur son écran :
Bonjour,



Bonjour,

je souhaiterai recueillir votre retour sur expérience quant à l'usage
des fonctions de recherche dans des fichiers HF.
Si par exemple je recherche un élément sur un ID (donc Unique) est-ce
plus optimisé d'utiliser une boucle POUR TOUT :
POUR TOUT FICHIER AVEC RUB = MonID
ou alors HLitRecherchePremier(FICHIER, RUB, MonID)
Y a t-il une grosse différence entre ces 2 utilisations et surtout
dans le temps d'exécution ?



Oui, le hlr est probablement plus performant.
en CS, on peut même améliorer en ajoutant hlimiteparcours.

Voir :
http://blogs.pcsoft.fr/post.awp?title=optimisation-hyperfilesql-clientserveur-hlimiteparcours-pour-une-recherche-unique,7,244
http://blogs.pcsoft.fr/post.awp?title=optimisations-hyperfilesql-clientserveur-eviter-les-traitements-type-hlitrecherche-l%92interieur-une-boucle,7,238
http://blogs.pcsoft.fr/post.awp?title=optimisations-hyperfilesql-clientserveur-utilisation-requetes-filtres,7,235

A+

--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
Publicité
Poster une réponse
Anonyme