Pourquoi gnome dépend de swfdec-mozilla ?

Le
Daniel Caillibaud
Bonjour,

Sur lenny (i686), j'ai voulu virer swfdec-mozilla pour utiliser flashplayer-mozilla, mais gnome en dépend !
Bizarre non ? Mettre une dépendance entre un gestionnaire de bureau et un plugin particulier d'un navigateur, c'est pas un peu violent ?

À la limite, le faire dépendre d'un flashplugin-mozilla, qui serait fournit soit par swfdec-mozilla, soit flashplayer-mozilla (et encore, obliger à
adopter un plugin, je trouve ça déjà osé).

Sinon, pour info, avec les 2 paquets installés, je n'arrivais pas à ce que iceweasel utilise le flashplayer (même en l'activant dans outils/modules
complémentaires/plugins). En virant swfdec de force (dpkg -P --force-depends swfdec-mozilla), iceweasel utilise bien flashplugin, et en laissant
aptitute upgrade le remettre, iceweasel utilise toujours flashplugin

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe Alonso
Le #17750531
Le mardi 04 novembre 2008 à 19:34 +0100, Daniel Caillibaud a écrit :
Bonjour,

Sur lenny (i686), j'ai voulu virer swfdec-mozilla pour utiliser flashplayer-mozilla, mais gnome en dépend !
Bizarre non ? Mettre une dépendance entre un gestionnaire de bureau et un plugin particulier d'un navigateur, c'est pas un peu violent ?

À la limite, le faire dépendre d'un flashplugin-mozilla, qui serait fournit soit par swfdec-mozilla, soit flashplayer-mozilla (et encore, obliger à
adopter un plugin, je trouve ça déjà osé).

Sinon, pour info, avec les 2 paquets installés, je n'arrivais pas à ce que iceweasel utilise le flashplayer (même en l'activant dans outils/modules
complémentaires/plugins). En virant swfdec de force (dpkg -P --force-depends swfdec-mozilla), iceweasel utilise bien flashplugin, et en laissant
aptitute upgrade le remettre, iceweasel utilise toujours flashplugin...



C'est effectivement un choix étrange.
Ceci dit, supprimer swfdec-mozilla ne supprime QUE le paquet virtuel
gnome, ce qui n'est pas un drame, si ?

Christophe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Guillaume Caron
Le #17748561
--=-1da0c4vU9iKnnhU90Yh7
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit

Hello,

La gestion du plugin flash se fait dans les alternatives, donc si les
deux sont installés, tu peux forcer celui qui sera utilisé par cette
commande :
# update-alternatives --config flash-mozilla.so

À part ça, je ne savais pas que GNOME dépendait de swfdec-mozilla, ça
doit être tout récent.

Cordialement,
--
Guillaume


Le mardi 04 novembre 2008 à 19:34 +0100, Daniel Caillibaud a écrit :

Bonjour,

Sur lenny (i686), j'ai voulu virer swfdec-mozilla pour utiliser flashplayer-mozilla, mais gnome en dépend !
Bizarre non ? Mettre une dépendance entre un gestionnaire de bureau et un plugin particulier d'un navigateur, c'est pas un peu violent ?

À la limite, le faire dépendre d'un flashplugin-mozilla, qui serait fournit soit par swfdec-mozilla, soit flashplayer-mozilla (et encore, obliger à
adopter un plugin, je trouve ça déjà osé).

Sinon, pour info, avec les 2 paquets installés, je n'arrivais pas à ce que iceweasel utilise le flashplayer (même en l'activant dans outils/modules
complémentaires/plugins). En virant swfdec de force (dpkg -P --force-depends swfdec-mozilla), iceweasel utilise bien flashplugin, et en laissant
aptitute upgrade le remettre, iceweasel utilise toujours flashplugin...

--
Daniel




--=-1da0c4vU9iKnnhU90Yh7
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: 7bit

<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; CHARSET=UTF-8">
</HEAD>
<BODY>
Hello,<BR>
<BR>
La gestion du plugin flash se fait dans les alternatives, donc si les deux sont install&#233;s, tu peux forcer celui qui sera utilis&#233; par cette commande : <BR>
# update-alternatives --config flash-mozilla.so<BR>
<BR>
&#192; part &#231;a, je ne savais pas que GNOME d&#233;pendait de swfdec-mozilla, &#231;a doit &#234;tre tout r&#233;cent.<BR>
<BR>
Cordialement,<BR>
<TABLE CELLSPACING="0" CELLPADDING="0" WIDTH="100%">
<TR>
<TD>
--<BR>
<I>Guillaume</I>
</TD>
</TR>
</TABLE>
<BR>
<BR>
Le mardi 04 novembre 2008 &#224; 19:34 +0100, Daniel Caillibaud a &#233;crit&nbsp;:
<BLOCKQUOTE TYPE=CITE>
<PRE>
Bonjour,

Sur lenny (i686), j'ai voulu virer swfdec-mozilla pour utiliser flashplayer-mozilla, mais gnome en d&#233;pend !
Bizarre non ? Mettre une d&#233;pendance entre un gestionnaire de bureau et un plugin particulier d'un navigateur, c'est pas un peu violent ?

&#192; la limite, le faire d&#233;pendre d'un flashplugin-mozilla, qui serait fournit soit par swfdec-mozilla, soit flashplayer-mozilla (et encore, obliger &#224;
adopter un plugin, je trouve &#231;a d&#233;j&#224; os&#233;).

Sinon, pour info, avec les 2 paquets install&#233;s, je n'arrivais pas &#224; ce que iceweasel utilise le flashplayer (m&#234;me en l'activant dans outils/modules
compl&#233;mentaires/plugins). En virant swfdec de force (dpkg -P --force-depends swfdec-mozilla), iceweasel utilise bien flashplugin, et en laissant
aptitute upgrade le remettre, iceweasel utilise toujours flashplugin...

--
Daniel

</PRE>
</BLOCKQUOTE>
</BODY>
</HTML>

--=-1da0c4vU9iKnnhU90Yh7--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #17748711
Oui, c'est un drame :

Remove the following packages:
gnome
gstreamer0.10-ffmpeg
libavcodec-dev
libavcodec51
libavformat-dev
libavformat52
libavutil-dev
libavutil49
libpostproc-dev
libpostproc51
libswscale0
Leave the following dependencies unresolved:
libswfdec-0.6-90 recommends gstreamer0.10-ffmpeg
totem-gstreamer recommends gstreamer0.10-ffmpeg
Score is -1391
Accept this solution? [Y/n/q/?]
The following NEW packages will be installed:
ffmpeg libavcodeccvs51{a} libavformatcvs51{a} libavutilcvs49{a}
libfaac0{a} libimlib2{a} liblame0{a} libswscalecvs0{a} libx264-54{a}
[...]
totem-plugins{u} transmission-common{u} transmission-gtk{u} unzip{u}
vinagre{u} vino{u} wodim{u} zenity{u} zip{u}
0 packages upgraded, 10 newly installed, 184 to remove and 2 not upgraded.
Need to get 3410kB of archives. After unpacking 515MB will be freed.
Do you want to continue? [Y/n/?]

Sinon, y a un bug concernant cette histoire de dépendance bizarre :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI3948


Christophe Alonso wrote:
Le mardi 04 novembre 2008 à 19:34 +0100, Daniel Caillibaud a écrit :

Bonjour,

Sur lenny (i686), j'ai voulu virer swfdec-mozilla pour utiliser flashplayer-mozilla, mais gnome en dépend !
Bizarre non ? Mettre une dépendance entre un gestionnaire de bureau et un plugin particulier d'un navigateur, c'est pas un peu violent ?

À la limite, le faire dépendre d'un flashplugin-mozilla, qui serait fournit soit par swfdec-mozilla, soit flashplayer-mozilla (et encore, obliger à
adopter un plugin, je trouve ça déjà osé).

Sinon, pour info, avec les 2 paquets installés, je n'arrivais pas à ce que iceweasel utilise le flashplayer (même en l'activant dans outils/modules
complémentaires/plugins). En virant swfdec de force (dpkg -P --force-depends swfdec-mozilla), iceweasel utilise bien flashplugin, et en laissant
aptitute upgrade le remettre, iceweasel utilise toujours flashplugin...




C'est effectivement un choix étrange.
Ceci dit, supprimer swfdec-mozilla ne supprime QUE le paquet virtuel
gnome, ce qui n'est pas un drame, si ?

Christophe






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Alonso
Le #17799781
--=-OFFPFl5EGz9DCFbZgx6Y
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

Le mardi 04 novembre 2008 à 21:10 +0100, David Hautbois a écrit :
Oui, c'est un drame :

Remove the following packages:
gnome
gstreamer0.10-ffmpeg
libavcodec-dev
libavcodec51
libavformat-dev
libavformat52
libavutil-dev
libavutil49
libpostproc-dev
libpostproc51
libswscale0
Leave the following dependencies unresolved:
libswfdec-0.6-90 recommends gstreamer0.10-ffmpeg
totem-gstreamer recommends gstreamer0.10-ffmpeg
Score is -1391
Accept this solution? [Y/n/q/?]
The following NEW packages will be installed:
ffmpeg libavcodeccvs51{a} libavformatcvs51{a} libavutilcvs49{a}
libfaac0{a} libimlib2{a} liblame0{a} libswscalecvs0{a} libx264-54{a}
[...]
totem-plugins{u} transmission-common{u} transmission-gtk{u} unzip{u}
vinagre{u} vino{u} wodim{u} zenity{u} zip{u}
0 packages upgraded, 10 newly installed, 184 to remove and 2 not upgraded .
Need to get 3410kB of archives. After unpacking 515MB will be freed.
Do you want to continue? [Y/n/?]



Curieux, chez moi ça ne désinstalle que le paquet virtuel gnome.. .
Peut-être éviter d'utiliser aptitude sur ce coup.

Christophe

--=-OFFPFl5EGz9DCFbZgx6Y
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEABECAAYFAkkR18QACgkQpZr8AUAUEND4pQCeN3xArdVm99sK2r6b9fRvHZYt
+jcAn3JJ4DlmSBUAvpjW08vvPa3gEths
=+j/o
-----END PGP SIGNATURE-----

--=-OFFPFl5EGz9DCFbZgx6Y--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme