Pourquoi MCIFormatPosition ne marche pas pour hh:mm:ss ?

Le
JC
Bonjour

j'essaie de faire un lecteur SMIL en Windev (c'est juste pour vous
donner le contexte de travail, ce n'est pas le problème de ma
question). Pour faire ce lecteur, j'utilise les fonctions WLangage
MCIOuvre, MCIJoue, etc. Mon problème est que lorsque je fais :

MCIFormatPosition("musique",MciFormatMS)

SI MCIJoue("musique","60000", "70000") ALORS
Trace("ok")
SINON
Trace("pas ok")
Trace(MCIErr())
Trace(MCIMsgErr())
Trace(MCIRécupère())
FIN


ça marche sans problème (WD affiche "ok" et joue bien uniquement 10
secondes de la 6ème minute du fichier MP3, c'est-à-dire t=00:01:00 =
à
t=00:01:10), alors que :

MCIFormatPosition("musique",MciFormatHMS)

SI MCIJoue("musique","00:01:00", "00:01:10") ALORS
Trace("ok")
SINON
Trace("pas ok")
Trace(MCIErr())
Trace(MCIMsgErr())
Trace(MCIRécupère())

FIN

ne marche pas du tout. Le message d'erreur est :
pas ok
282
Le paramètre spécifié est en dehors des limites pour la commande
spécifiée.


Pourquoi ce format ne fonctionne pas ? Pourquoi un tel message
d'erreur ? Est-ce mon code qui est faux ou est-ce encore un bug de WD?

Merci par avance
JC
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #18983571
JC a formulé ce mercredi :

Pourquoi ce format ne fonctionne pas ? Pourquoi un tel message
d'erreur ? Est-ce mon code qui est faux ou est-ce encore un bug de WD?



Je confirme, un bug de WD...
Il ne te reste plus qu'à travailler avec MciFormatMS et convertir
éventuellement les hh:mm:ss en ms (pas trop difficile)

A+

--
Romain PETIT
contact : http://cerbermail.com/?O16kfXOFcq
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
Publicité
Poster une réponse
Anonyme