Préférence de clavier qui se perdent

Le
Daniel Caillibaud
Bonjour,

En lenny amd64, mes préférences d'agencement clavier ne "tiennent=
" pas au reboot.

Avec "PC 105 touches générique", agencement "France autre, latin =
9 seulement", je suis obligé de retourner régulièrement dans
les préférences pour ajouter un agencement (le même) et supp=
rimer celui qui y est si je veux retrouver mon œ sur "alt gr +
o" (sinon ça me fait un ô).

Y'a moyen de fixer ça, même via un petit script lancé par rc=
.local ?

Je ne sais pas trop où gnome met cette info, j'ai essayer de comparer =
avant/après modif les dossiers ~/.gconf, ~/.gconfd,
~/.gnome, ~/.gnome2 et ~/.config sans voir de différence intéress=
ance concernant ça. Je supposais que c'était dans
.gconf/desktop/gnome/peripherals/keyboard/kbd/%gconf.xml, mais ça cont=
ient la même chose avant/après modif (juste le mtime qui
change) <entry name="layouts" mtime="1242395316" type="list" ltype==
"string">
<li type="string">
<stringvalue>fr oss_latin9</stringvalue>
</li>
</entry>

C'est dans les réglages X ? Où ?
Dans mon xorg.conf j'ai :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Merci à ceux qui auraient une piste à donner.


--
Daniel

Nul vent n'est favorable à celui qui ne sait pas où il va.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Claude
Le #19343181
hello,

Avec "PC 105 touches générique", agencement "France autre, latin 9 seulement", je suis obligé de retourner régulièrement dans
les préférences pour ajouter un agencement (le même) et supprimer celui qui y est si je veux retrouver mon œ sur "alt gr +
o" (sinon ça me fait un ô).



En Lenny amd64 itou,
la touche (2) à l'extrême gauche,
au dessus de la tabulation me donne le fameux "O œuf-collé" œ.

Dans mon xorg.conf j'ai :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection



pareil.


Merci à ceux qui auraient une piste à donner.



Essaies l'autre touche, à moins que tu ne veuilles absolument avoir
l'œ en faisant (alt gr + O) ;-)

cordialement
Claude

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #19343171
Daniel Caillibaud, vendredi 15 mai 2009, 16:07:01 CEST

Bonjour,



’jour,

[…]
<entry name="layouts" mtime="1242395316" type="list" ltype="strin g">
<li type="string">
<stringvalue>fr oss_latin9</stringvalue>
</li>
</entry>

C'est dans les réglages X ? Où ?
Dans mon xorg.conf j'ai :

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Merci à ceux qui auraient une piste à donner.



Je n’y connais rien à Gnome mais :
— il y a des chances qu’il utilise ce que lui dit Xorg  ;
– latin9 ≠ oss_latin9 ;
donc essaie de changer ton xorg.conf.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Daniel Caillibaud
Le #19345321
Le 15/05/09 à 19:28, Sylvain Sauvage
Je n’y connais rien à Gnome mais :
— il y a des chances qu’il utilise ce que lui dit Xorg  ;
– latin9 ≠ oss_latin9 ;



J'aurai pu le voir mais je suis passé à coté...

donc essaie de changer ton xorg.conf.



Ça va tout de suite mieux :-)

Merci


Le 15/05/09 à 19:27, Claude
Essaies l'autre touche, à moins que tu ne veuilles absolument avoir
l'œ en faisant (alt gr + O) ;-)



C'est à dire que l'on prend des habitudes...
Sur d'autres PC que j'utilise, c'est "alt gr + o", sur d'autres distribs su r ce même PC aussi...
Et le pb se repose pour æ (alt gr + a), mais ok, il sert moins souvent (Læticia ne va pas rester ex-æequo ad vitam æternam !).

--
Daniel

L'intelligence est la chose la mieux repartie dans le monde,
tout le monde pense en avoir assez, vu que c'est avec la
sienne qu'il en juge.
Coluche

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme