Présentation + pb backupninja

Le
Auguste
Bonjour,

D'abord petite présentation, c'est mon premier mail ici.

Je m'appelle Auguste (gus) et j'utilise Linux depuis plusieurs années,
principalement Slackware au début et maintenant debian (professionel)
Je fait du développement web (php/mysql) et je m'occupe d'un réseau
d'entreprise avec 5 serveurs Debian et 45 postes. J'habite à coté de
Clermont-Ferrand (63 Puy de Dôme)

J'ai un petit problème avec backupninja que j'utilise pour backuper tous
mes serveurs sur
une machine centrale. Sur un nouveau serveur j'ai du installer Lenny (pb
driver réseau) alors que tous les
autres sont sur Etch. Le soucis c'est que backupninja refuse de
fonctionner, il me dit que
la version de rdiff-backup entre mon serveur (lenny) et le serveur de
backup (etch) est différente.
C'est normal j'ai cherché un peu sur google et il semblerait qu'il y
a une option pour désactiver ce test de version
malheureusement pour l'instant je n'ai pas trouvé cette option

Merci pour votre aide au cas ou.


Gus,




_________________________________________________________________________

Ce message a été vérifié par l'antivirus de MDaemon (md6).

Par précaution, n'ouvrez pas de pièces jointes de correspondants inconnus.
_________________________________________________________________________

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Julien Valroff
Le #18559601
Le lundi 02 février 2009 à 15:45 +0100, Auguste a écrit :
Bonjour,

D'abord petite présentation, c'est mon premier mail ici.


[...]

Bienvenue sur la liste !

[...]
Le soucis c'est que backupninja refuse de
fonctionner, il me dit que
la version de rdiff-backup entre mon serveur (lenny) et le serveur de
backup (etch) est différente.
C'est normal... j'ai cherché un peu sur google et il semblerait qu'il y
a une option pour désactiver ce test de version
malheureusement pour l'instant je n'ai pas trouvé cette option...



Je ne connais pas cette option, qui, si elle existait, serait sans doute
illusoire, car les évolutions entre les versions les rendent
incompatibles entre elles.

Je te conseille la création d'un backport.
Tu peux aussi voir si la version de backports.org est compatible avec
celle de Lenny: http://packages.debian.org/etch-backports/rdiff-backup

@+
Julien

--
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org

Rejoignez maintenant près de 4 000 personnes, associations, entreprises
et collectivités qui soutiennent notre action

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Auguste
Le #18559731
Julien Valroff a écrit :
Je ne connais pas cette option, qui, si elle existait, serait sans doute
illusoire, car les évolutions entre les versions les rendent
incompatibles entre elles.

Je te conseille la création d'un backport.
Tu peux aussi voir si la version de backports.org est compatible avec
celle de Lenny: http://packages.debian.org/etch-backports/rdiff-backup

@+
Julien



Merci pour ta réponse, rapide

Je ne connaissais ce site de backports, je vais regarder.
Ce qui peut être 'plus compliqué' si je 'backport' la version sur mon
serveur central c'est qu'il
sera nécessaire de le faire sur tous les autres serveurs (clients) sinon
le problème se posera tant que tout les
parc n'est pas homogène.





_________________________________________________________________________

Ce message a été vérifié par l'antivirus de MDaemon (md6).

Par précaution, n'ouvrez pas de pièces jointes de correspondants inconnus.
_________________________________________________________________________

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Julien Valroff
Le #18559721
Le lundi 02 février 2009 à 16:03 +0100, Auguste a écrit :
Julien Valroff a écrit :
> Je ne connais pas cette option, qui, si elle existait, serait sans doute
> illusoire, car les évolutions entre les versions les rendent
> incompatibles entre elles.
>
> Je te conseille la création d'un backport.
> Tu peux aussi voir si la version de backports.org est compatible avec
> celle de Lenny: http://packages.debian.org/etch-backports/rdiff-backup
>
> @+
> Julien
>
Merci pour ta réponse, rapide

Je ne connaissais ce site de backports, je vais regarder.
Ce qui peut être 'plus compliqué' si je 'backport' la version sur mon
serveur central c'est qu'il
sera nécessaire de le faire sur tous les autres serveurs (clients) sinon
le problème se posera tant que tout les
parc n'est pas homogène.



D'où l'intérêt de mettre en place un dépôt local que peuvent utiliser
tous tes serveurs. Facilement réalisable avec reprepro

@+
JUlien

--
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org

Rejoignez maintenant près de 4 000 personnes, associations, entreprises
et collectivités qui soutiennent notre action

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
François Cerbelle
Le #18559871
Auguste a écrit :
Je ne connaissais ce site de backports, je vais regarder.
Ce qui peut être 'plus compliqué' si je 'backport' la version sur mon
serveur central c'est qu'il
sera nécessaire de le faire sur tous les autres serveurs (clients) sinon
le problème se posera tant que tout les
parc n'est pas homogène.




Salut,

L'autre solution serait d'installer sur ton serveur Lenny le meme paquet
que celui installé sur tes etch. Ainsi, ton serveur est en Lenny pour la
partie systeme et la gestion de ta carte réseau, mais il comporte un
paquet etch.

Pour cela, tu peux ajouter la ligne etch dans ton fichier sources.lists,
puis, tu effectues l'installation :
aptitude install backupninja=version_etch
et ensuite, tu verrouilles cette version pour qu'elle ne soit pas mise a
jour automatiquement avec :
aptitude hold backupninja

Ca devrait resoudre ton probleme sans t'obliger à changer la version
stable_qui_marche_bien de tous tes serveurs pour une version backportée.

Plus tard, tu feras ta migration vers Lenny de tes serveurs un par un en
effectuant la meme manip, et, lorsqu'ils seront tous en lenny, tu fera
un unhold suivi d'un upgrade sur tous tes serveurs pour monter la
version en meme temps partout.

Fanfan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Auguste
Le #18559861
Salut,

L'autre solution serait d'installer sur ton serveur Lenny le meme
paquet que celui installé sur tes etch. Ainsi, ton serveur est en
Lenny pour la partie systeme et la gestion de ta carte réseau, mais il
comporte un paquet etch.

Pour cela, tu peux ajouter la ligne etch dans ton fichier
sources.lists, puis, tu effectues l'installation :
aptitude install backupninja=version_etch
et ensuite, tu verrouilles cette version pour qu'elle ne soit pas mise
a jour automatiquement avec :
aptitude hold backupninja

Ca devrait resoudre ton probleme sans t'obliger à changer la version
stable_qui_marche_bien de tous tes serveurs pour une version backportée.

Plus tard, tu feras ta migration vers Lenny de tes serveurs un par un
en effectuant la meme manip, et, lorsqu'ils seront tous en lenny, tu
fera un unhold suivi d'un upgrade sur tous tes serveurs pour monter la
version en meme temps partout.

Fanfan




Je savais pas qu'il était possible de "mixer" des paquets entre
versions... c'est plutot cool ça !
je vais tester ça sur une machine de test (virtualbox) et si c'est ok,
j'appliquerai à mon serveur Lenny

Merci,


_________________________________________________________________________

Ce message a été vérifié par l'antivirus de MDaemon (md6).

Par précaution, n'ouvrez pas de pièces jointes de correspondants inconnus.
_________________________________________________________________________

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Auguste
Le #18561071
Auguste a écrit :
Salut,

L'autre solution serait d'installer sur ton serveur Lenny le meme
paquet que celui installé sur tes etch. Ainsi, ton serveur est en
Lenny pour la partie systeme et la gestion de ta carte réseau, mais
il comporte un paquet etch.

Pour cela, tu peux ajouter la ligne etch dans ton fichier
sources.lists, puis, tu effectues l'installation :
aptitude install backupninja=version_etch
et ensuite, tu verrouilles cette version pour qu'elle ne soit pas
mise a jour automatiquement avec :
aptitude hold backupninja

Ca devrait resoudre ton probleme sans t'obliger à changer la version
stable_qui_marche_bien de tous tes serveurs pour une version backportée.

Plus tard, tu feras ta migration vers Lenny de tes serveurs un par un
en effectuant la meme manip, et, lorsqu'ils seront tous en lenny, tu
fera un unhold suivi d'un upgrade sur tous tes serveurs pour monter
la version en meme temps partout.

Fanfan





Bon en fait à force de tests et de recherches j'ai fini par trouvé la
bonne option et surtout ou la placer :

ignore_version = yes

Il faut ajouter cela dans les fichiers /etc/backup.d/XX.rdiff
(et non pas dans /etc/backupninja.conf comme je pensais)

Voila tout semble fonctionner, et cela me permet de garder mes Etch et
ma Lenny "propre" :-)

@+

Gus,




_________________________________________________________________________

Ce message a été vérifié par l'antivirus de MDaemon (md6).

Par précaution, n'ouvrez pas de pièces jointes de correspondants inconnus.
_________________________________________________________________________

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme