Prise de poids !

Le
LargoWinch
Bonjour,

j'évoquais hier un fichier Excel bourré de SOMMEPROD avec lequel j'ai
des petits soucis.
Un autre de ces soucis est son poids. J'ai récemment modifié mes
SOMMEPROD pour y ajouter un critère de sélection. Le fichier Excel est
passé d'une taille de 1200Ko à plus de 9500 !
Est-ce que les options de calculs (genre 'Enregistrer les valeurs des
liaisons externes' ou autres) peuvent y être pour quelque chose ?
Avez-vous des astuces pour réduire cette taille ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #18100251
Bonsour® LargoWinch avec ferveur ;o))) vous nous disiez :
j'évoquais hier un fichier Excel bourré de SOMMEPROD avec lequel j'ai
des petits soucis.



l'utilisation de Sommeprod malgré son élégance n'est pas une panacée.
comme toute formule matricielle, son usage est soumis à des contraintes de dimensions et de recalculs non négligeables.
il convient d'étre raisonnable et parcimonieux dans son utilisation.
notament limiter les plages au strict contenu des données...
../..
Les formules matricielles construisent de manière interne des tableaux destinés à stocker les résultats des calculs effectués.
Par exemple, une formule telle que {=SOMME(RACINE(A1:C500))} nécessite la création d'un tableau de 1500 éléments pour stocker les résultats des calculs opérés sur la plage A1:C500 et les renvoyer ensuite à la fonction SOMME.
Ce tableau entraîne une *"allocation supplémentaire de mémoire"* et des *"opérations de copie"* coûteuses pour la vitesse de recalcul.
../..

Un autre de ces soucis est son poids. J'ai récemment modifié mes
SOMMEPROD pour y ajouter un critère de sélection. Le fichier Excel est
passé d'une taille de 1200Ko à plus de 9500 !


Excel gére trés mal l'allocation mémoire, de même que les plages utilisées( vides, vidées ou contenant seulement un format)

Est-ce que les options de calculs (genre 'Enregistrer les valeurs des
liaisons externes' ou autres) peuvent y être pour quelque chose ?
Avez-vous des astuces pour réduire cette taille ?



voir avec profit ce lien :
http://xcell05.free.fr/pages/form/form_mat.htm
et puis pour aller plus loin :
http://xcell05.free.fr/pages/form/form_mat_2.htm
LargoWinch
Le #18100901
LargoWinch a écrit :

Est-ce que les options de calculs (genre 'Enregistrer les valeurs des
liaisons externes' ou autres) peuvent y être pour quelque chose ?
Avez-vous des astuces pour réduire cette taille ?

Merci



Je m'auto-réponds, pour confirmer que decocher cette option me ramene à
une taille raisonnable.
LargoWinch
Le #18100891
Modeste a écrit :
Bonsour® LargoWinch avec ferveur ;o))) vous nous disiez :
j'évoquais hier un fichier Excel bourré de SOMMEPROD avec lequel j'ai
des petits soucis.



l'utilisation de Sommeprod malgré son élégance n'est pas une panacée.
comme toute formule matricielle, son usage est soumis à des contraintes de dimensions et de recalculs non négligeables.
il convient d'étre raisonnable et parcimonieux dans son utilisation.
notament limiter les plages au strict contenu des données...



C'est le cas

../..
Les formules matricielles construisent de manière interne des tableaux destinés à stocker les résultats des calculs effectués.
Par exemple, une formule telle que {=SOMME(RACINE(A1:C500))} nécessite la création d'un tableau de 1500 éléments pour stocker les résultats des calculs opérés sur la plage A1:C500 et les renvoyer ensuite à la fonction SOMME.
Ce tableau entraîne une *"allocation supplémentaire de mémoire"* et des *"opérations de copie"* coûteuses pour la vitesse de recalcul.
../..

Un autre de ces soucis est son poids. J'ai récemment modifié mes
SOMMEPROD pour y ajouter un critère de sélection. Le fichier Excel est
passé d'une taille de 1200Ko à plus de 9500 !


Excel gére trés mal l'allocation mémoire, de même que les plages utilisées( vides, vidées ou contenant seulement un format)

Est-ce que les options de calculs (genre 'Enregistrer les valeurs des
liaisons externes' ou autres) peuvent y être pour quelque chose ?
Avez-vous des astuces pour réduire cette taille ?



voir avec profit ce lien :
http://xcell05.free.fr/pages/form/form_mat.htm
et puis pour aller plus loin :
http://xcell05.free.fr/pages/form/form_mat_2.htm



Zou, dans les favoris :)
Publicité
Poster une réponse
Anonyme