prise de tete avec une matrice

Le
Xavier powaga
Bonjour à tous,
je colle sur une formule de matrice .
Je vous explique (en simplifiant)
j'ai 4 colonnes - 5 Lignes
jour Papa Maman Tata Tonton
Ligne1 lundi Oui Non Non Oui
Ligne2 jeudi Non Non Non Non
Ligne3 jeudi Oui Oui Oui Non
Ligne4 mardi Oui Oui Oui Non
Ligne5 jeudi Non Oui Oui Non

Je souhaiterais qu'une cellule affiche le nombre de jeudi où au moins un des
4 parents dit "Oui". Dans mon exemple la cellule doit donner :2
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Brunos
Le #5150681
j'ai 4 colonnes - 5 Lignes
jour Papa Maman Tata Tonton
Ligne1 lundi Oui Non Non Oui
Ligne2 jeudi Non Non Non Non
Ligne3 jeudi Oui Oui Oui Non
Ligne4 mardi Oui Oui Oui Non
Ligne5 jeudi Non Oui Oui Non

Je souhaiterais qu'une cellule affiche le nombre de jeudi où au moins un des
4 parents dit "Oui". Dans mon exemple la cellule doit donner :2


{=SOMMEPROD((lejour="jeudi")*(SI((papa="Oui")+(maman="Oui")+(tata="Oui")+(tonton="Oui")>1;1;0)))}

--
Brunos

LSteph
Le #5150631
Bonjour Xavier,

en validant normalement:
=SOMMEPROD((A2:A6="jeudi")*(((B2:B6="Oui")+(C2:C6="oui")+(D2:D6="oui")+(E2:E6="oui"))>0))

--
lSteph

Bonjour à tous,
je colle sur une formule de matrice .
Je vous explique (en simplifiant)
j'ai 4 colonnes - 5 Lignes
jour Papa Maman Tata Tonton
Ligne1 lundi Oui Non Non Oui
Ligne2 jeudi Non Non Non Non
Ligne3 jeudi Oui Oui Oui Non
Ligne4 mardi Oui Oui Oui Non
Ligne5 jeudi Non Oui Oui Non

Je souhaiterais qu'une cellule affiche le nombre de jeudi où au moins un des
4 parents dit "Oui". Dans mon exemple la cellule doit donner :2





Brunos
Le #5150621
j'ai 4 colonnes - 5 Lignes
jour Papa Maman Tata Tonton
Ligne1 lundi Oui Non Non Oui
Ligne2 jeudi Non Non Non Non
Ligne3 jeudi Oui Oui Oui Non
Ligne4 mardi Oui Oui Oui Non
Ligne5 jeudi Non Oui Oui Non

Je souhaiterais qu'une cellule affiche le nombre de jeudi où au moins un
des 4 parents dit "Oui". Dans mon exemple la cellule doit donner :2


{=SOMMEPROD((lejour="jeudi")*(SI((papa="Oui")+(maman="Oui")+(tata="Oui")+(tonton="Oui")>1;1;0)))}


Oups ! Correction : il y a un >1 qui traine qu'il faut enlever.
=SOMMEPROD((lejour="jeudi")*(SI((papa="Oui")+(maman="Oui")+(tata="Oui")+(tonton="Oui");1;0)))
valider avec CTRL+Maj.

--
Brunos


Xavier powaga
Le #5150611
merci a vous deux.
Les 2 réponses marchent (moyennant une petit rectification de celle de
Brunos ou il faut remplacer >1 par >0).
Celle de LSteph semble plus simple

Dans ce genre de formule c'est toujours la prise de tête :
- avec la gestion des parenthèses
- avec l'imagination de la matrice


De ce que j'ai compris, la solution de Brunos passe par un calcul matriciel
en utilisant les accolades (shift+Ctrl+Enter) et par un calcul matriciel en
utilisant la formule SOMMEProd. C'est donc un double calcul matriciel.
Celle de LSteph passe seulement par un simple calcul matriciel en utilisant
la formule SOMMEProd

Trop fort les gars




"LSteph"
Bonjour Xavier,

en validant normalement:
=SOMMEPROD((A2:A6="jeudi")*(((B2:B6="Oui")+(C2:C6="oui")+(D2:D6="oui")+(E2:E6="oui"))>0))

--
lSteph

Bonjour à tous,
je colle sur une formule de matrice .
Je vous explique (en simplifiant)
j'ai 4 colonnes - 5 Lignes
jour Papa Maman Tata Tonton
Ligne1 lundi Oui Non Non Oui
Ligne2 jeudi Non Non Non Non
Ligne3 jeudi Oui Oui Oui Non
Ligne4 mardi Oui Oui Oui Non
Ligne5 jeudi Non Oui Oui Non

Je souhaiterais qu'une cellule affiche le nombre de jeudi où au moins un
des 4 parents dit "Oui". Dans mon exemple la cellule doit donner :2





Brunos
Le #5150601
De ce que j'ai compris, la solution de Brunos passe par un calcul matriciel
en utilisant les accolades (shift+Ctrl+Enter) et par un calcul matriciel en
utilisant la formule SOMMEProd. C'est donc un double calcul matriciel.
Celle de LSteph passe seulement par un simple calcul matriciel en utilisant
la formule SOMMEProd


SOMMEPROD est une fonction matricielle par nature, donc pas besoin de
valider de façon particulière.
Mais j'utilise la fonction SI qui n'est pas matricielle naturellement,
donc il faut valider avec shift+Ctrl+Enter pour "forcer" le calcul
matriciel.
Conclusion : la solution de LSteph est meilleure car beaucoup plus
simple ! ;o)

--
Brunos

Jacquouille
Le #5283681
Salut la foule
Voilà 20 ans que l'on se décarcasse à vous le dire.
SOMMEPROD est génial !
Et UN seul doigt suffit pour valider.
Que les matriciellistes me pardonnent, mais ce qui est simple est beau ( et
facile à comprendre...-)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Brunos"
De ce que j'ai compris, la solution de Brunos passe par un calcul
matriciel en utilisant les accolades (shift+Ctrl+Enter) et par un calcul
matriciel en utilisant la formule SOMMEProd. C'est donc un double calcul
matriciel.
Celle de LSteph passe seulement par un simple calcul matriciel en
utilisant la formule SOMMEProd


SOMMEPROD est une fonction matricielle par nature, donc pas besoin de
valider de façon particulière.
Mais j'utilise la fonction SI qui n'est pas matricielle naturellement,
donc il faut valider avec shift+Ctrl+Enter pour "forcer" le calcul
matriciel.
Conclusion : la solution de LSteph est meilleure car beaucoup plus simple
! ;o)

--
Brunos





Brunos
Le #5283601
Salut la foule
Voilà 20 ans que l'on se décarcasse à vous le dire.
SOMMEPROD est génial !
Sommeprod/Ducros même combat.


Et UN seul doigt suffit pour valider.
Que les matriciellistes me pardonnent, mais ce qui est simple est beau ( et
facile à comprendre...-)
Les matriciellistes se mettent le doigt dans l'array ?


--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.
A la tienne !


--
Brunos

LSteph
Le #5283551
:o° heuu!

Les matriciellistes se mettent le doigt dans l'array ?
C'est du beau....!

mais c'est simple et facile à comprendre
J'aurais dit HS mais...
prise de (tete)... doigt avec une matrice


Jacquouille, tu l'auras cherché!
"Le vin est au repas ce que le parfum est à la femme."
et tu doigt z'être bien confus.



Et comme eu dit dit confus si...eusse (...le sien l'engrenage)

<: celui qui se couche avec la gratte au ...
se réveille avec le doigt qui pue!

Amicordialement.

--
lSteph


Salut la foule
Voilà 20 ans que l'on se décarcasse à vous le dire.
SOMMEPROD est génial !
Sommeprod/Ducros même combat.


Et UN seul doigt suffit pour valider.
Que les matriciellistes me pardonnent, mais ce qui est simple est beau
( et facile à comprendre...-)
Les matriciellistes se mettent le doigt dans l'array ?


--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.
A la tienne !





Publicité
Poster une réponse
Anonyme