Probl création d'état

Le
eric.zzzz
Bonjour,
Je veux créer un état avec l'assistant. En selectionnant certaines
requetes (pas pour toutes), la partie gauche (champs disponibles reste
vide). Et comme je ne peux pas selectionner de champs, impossible de
créer mon étatUne explication ? (j'ai Access 2003)
Merci d'avance
Eric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Tisane
Le #6312791
Bonjour Eric,

Je veux créer un état avec l'assistant. En selectionnant
certaines requetes (pas pour toutes), la partie gauche
(champs disponibles reste vide). Et comme
je ne peux pas selectionner de champs, impossible de
créer mon état...Une explication ? (j'ai Access 2003)


Sur quel type de requêtes, as-tu ce problème ?
Ces requêtes fonctionnent-elles indépendamment de l'état ?
Quel assistant état utilises-tu ?

--
Tisane

eric.zzzz
Le #6312731
On 7 août, 11:17, "Tisane"
Sur quel type de requêtes, as-tu ce problème ?
Ces requêtes fonctionnent-elles indépendamment de l'état ?
Quel assistant état utilises-tu ?


J'ai plus de 20 requetes dont 4 analyses croisées, une union, le reste
c'est des sélections sur 1, 2 ou 3 tables.
Je n'ai ce problème que sur 2 requetes selection sur 2 tables. Toutes
mes requetes fonctionnent indépendamment des états vu que je n'ai
encore créé aucun état.
Quel assistant état j'utilise ? Je ne comprends pas vraiment la
question...Je clique sur "Créer un état à l'aide de l'assistant" ou
sur nouveau/assistant Etat...

Tisane
Le #6312661

On 7 août, 11:17, "Tisane"
Sur quel type de requêtes, as-tu ce problème ?
Ces requêtes fonctionnent-elles indépendamment de l'état ?
Quel assistant état utilises-tu ?


[...]
Je n'ai ce problème que sur 2 requetes selection
sur 2 tables. Toutes mes requetes fonctionnent
indépendamment des états vu que je n'ai
encore créé aucun état.
Quel assistant état j'utilise ? Je ne comprends pas
vraiment la question...Je clique sur "Créer un état
à l'aide de l'assistant" ou sur nouveau/assistant Etat...



Access te propose plusieurs assistants : colonnes, tableau, assistants
graphiques et étiquettes.
Mais tu as répondu, tu prends l'assistant état "simple".
Essaie ceci :
- place-toi sur une requête qui pose problème
- menu Insertion | Etat instantané
Est-ce que cela fonctionne ?

Nota : tu as bien dit que les champs ne s'affichent pas pour 2 requêtes
seulement dans l'assistant, sous-entendu, tu vois bien les champs quand tu
sélectionnes une autre requête ??

--
Tisane


eric.zzzz
Le #6312511
On 7 août, 12:31, "Tisane"

On 7 août, 11:17, "Tisane"
Sur quel type de requêtes, as-tu ce problème ?
Ces requêtes fonctionnent-elles indépendamment de l'état ?
Quel assistant état utilises-tu ?


[...]

Je n'ai ce problème que sur 2 requetes selection
sur 2 tables. Toutes mes requetes fonctionnent
indépendamment des états vu que je n'ai
encore créé aucun état.
Quel assistant état j'utilise ? Je ne comprends pas
vraiment la question...Je clique sur "Créer un état
à l'aide de l'assistant" ou sur nouveau/assistant Etat...



Access te propose plusieurs assistants : colonnes, tableau, assistants
graphiques et étiquettes.
Mais tu as répondu, tu prends l'assistant état "simple".
Essaie ceci :
- place-toi sur une requête qui pose problème
- menu Insertion | Etat instantané
Est-ce que cela fonctionne ?

Nota : tu as bien dit que les champs ne s'affichent pas pour 2 requêtes
seulement dans l'assistant, sous-entendu, tu vois bien les champs quand tu
sélectionnes une autre requête ??


Désolé, je pense que le problème vient d'un truc que je n'avais pas
vu. Je n'avais pas vu qu'il y avait des divisions par 0, car la
requete est du type PARAMETERS [Entrez un numéro de diplôme:]; HAVING
FORMATION_DIPLOME=[Entrez un numéro de diplôme:]
Je vais essayer de résoudre cela..
Merci



Publicité
Poster une réponse
Anonyme