Problème accès à mon site web depuis mon réseau

Le
Sébastien B.
Bonjour, j'ai un petit problème sur un réseau configuré autour d'un
serveur osx 10.4.9.
Celui-ci est configuré en Open Directory avec comme nom de nom domaine
"mondomaine.com"
Le problème est que jusqu'à maintenant il n'y avait pas de problème mais
depuis que la société a un site web hébergé ailleurs, je me retrouve
coincé car les machines du réseau qui veulent accéder à
"www.mondomaine.com" n'arrive pas à contacter le site. Quand je réfléchi
, c'est normal car mon serveur DNS leurs indique que c'est sur le réseau
privé donc ils ne sortent pas j'avais eu le même problème avec la
messagerie lorsqu'ils ont eu des mails genre "toto@mondomaine.com" et
quelqu'un de super m'avait dit de rajouter dans les réglages de zone DNS
des ordinateurs POP et SMTP avec comme IP celles du serveur de courrier
qui héberge les mails.
Alors je me demande s'il y a une manip similaire ou plus simple pour que
lorsqu'une machine du réseau s'adresse à "www.mondomaine.com", le DNS la
renvoi vers l'extérieur ?
Si je pouvais j'aimerais changer le domaine en "mondomaine.lan" mais je
crois que c'est impossible sans tout refaire ?

Merci d'avance

Sébastien B.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sébastien B.
Le #469156
Bon bah je me réponds tout seul car j'ai essayé de procéder de la même
façon que pour le POP et le SMTP et cela a fonctionné ...

Par contre si qulqu'un a une meilleure idée je prends avec plaisir !!

Merci


Bonjour, j'ai un petit problème sur un réseau configuré autour d'un
serveur osx 10.4.9.
Celui-ci est configuré en Open Directory avec comme nom de nom domaine
"mondomaine.com"
Le problème est que jusqu'à maintenant il n'y avait pas de problème mais
depuis que la société a un site web hébergé ailleurs, je me retrouve
coincé car les machines du réseau qui veulent accéder à
"www.mondomaine.com" n'arrive pas à contacter le site. Quand je réfléchi
, c'est normal car mon serveur DNS leurs indique que c'est sur le réseau
privé donc ils ne sortent pas ... j'avais eu le même problème avec la
messagerie lorsqu'ils ont eu des mails genre "" et
quelqu'un de super m'avait dit de rajouter dans les réglages de zone DNS
des ordinateurs POP et SMTP avec comme IP celles du serveur de courrier
qui héberge les mails.
Alors je me demande s'il y a une manip similaire ou plus simple pour que
lorsqu'une machine du réseau s'adresse à "www.mondomaine.com", le DNS la
renvoi vers l'extérieur ?
Si je pouvais j'aimerais changer le domaine en "mondomaine.lan" mais je
crois que c'est impossible sans tout refaire ?

Merci d'avance

Sébastien B.


laurent.pertois
Le #469155
"Sébastien B."
Alors je me demande s'il y a une manip similaire ou plus simple pour que
lorsqu'une machine du réseau s'adresse à "www.mondomaine.com", le DNS la
renvoi vers l'extérieur ?


Ben, dans ton service DNS, pour domaine.com tu fais une nouvelle entrée
avec comme nom www et comme adresse l'adresse IP de la machine
hébergeant ton site web à l'extérieur, comme ça quand les clients vont
faire la requête auprès de ton DNS interne ils obtiendront la bonne
adresse.

Si je pouvais j'aimerais changer le domaine en "mondomaine.lan" mais je
crois que c'est impossible sans tout refaire ?


Ben, bon courage pour la migration Open Directory, ça se fait mais faut
vraiment que ce soit motivé et ça prend du temps.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.

laurent.pertois
Le #469154
"Sébastien B."
Par contre si qulqu'un a une meilleure idée je prends avec plaisir !!


Pourquoi vouloir une meilleure idée alors que celle-ci est fonctionnelle
et conçue pour ?

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.

Sébastien B.
Le #469151
"Sébastien B."
Alors je me demande s'il y a une manip similaire ou plus simple pour que
lorsqu'une machine du réseau s'adresse à "www.mondomaine.com", le DNS la
renvoi vers l'extérieur ?


Ben, dans ton service DNS, pour domaine.com tu fais une nouvelle entrée
avec comme nom www et comme adresse l'adresse IP de la machine
hébergeant ton site web à l'extérieur, comme ça quand les clients vont
faire la requête auprès de ton DNS interne ils obtiendront la bonne
adresse.

Si je pouvais j'aimerais changer le domaine en "mondomaine.lan" mais je
crois que c'est impossible sans tout refaire ?


Ben, bon courage pour la migration Open Directory, ça se fait mais faut
vraiment que ce soit motivé et ça prend du temps.

Je ne comprends plus rien, hier soir ça a fonctionné, non seulement sur

le serveur mais aussi sur une machine cliente et aujourd'hui plus rien
... pourtant l'entrée www est toujours bien là dans les réglages de zone
, onglet ordinateurs ... quelqu'un a une idée ?

Merci


Sébastien B.
Le #469150
"Sébastien B."
Alors je me demande s'il y a une manip similaire ou plus simple pour que
lorsqu'une machine du réseau s'adresse à "www.mondomaine.com", le DNS la
renvoi vers l'extérieur ?


Ben, dans ton service DNS, pour domaine.com tu fais une nouvelle entrée
avec comme nom www et comme adresse l'adresse IP de la machine
hébergeant ton site web à l'extérieur, comme ça quand les clients vont
faire la requête auprès de ton DNS interne ils obtiendront la bonne
adresse.

Si je pouvais j'aimerais changer le domaine en "mondomaine.lan" mais je
crois que c'est impossible sans tout refaire ?


Ben, bon courage pour la migration Open Directory, ça se fait mais faut
vraiment que ce soit motivé et ça prend du temps.

Je ne comprends plus rien, hier soir ça a fonctionné, non seulement sur

le serveur mais aussi sur une machine cliente et aujourd'hui plus rien
... pourtant l'entrée www est toujours bien là dans les réglages de zone
, onglet ordinateurs ... quelqu'un a une idée ?

Merci
Par contre il y a autre chose d'étrange ... lorsque je ping l'adresse du

serveur où est hébergé le site www.mondomaine.com depuis un poste de mon
réseau, je n'ai aucune réponse. Par contre si je fais la même démarche
depuis l'extérieur ce la fonctionne ...
Je comprends pas ... HELP



laurent.pertois
Le #469148
"Sébastien B."
Je ne comprends plus rien, hier soir ça a fonctionné, non seulement sur
le serveur mais aussi sur une machine cliente et aujourd'hui plus rien
... pourtant l'entrée www est toujours bien là dans les réglages de zone
, onglet ordinateurs ... quelqu'un a une idée ?

Merci
Par contre il y a autre chose d'étrange ... lorsque je ping l'adresse du

serveur où est hébergé le site www.mondomaine.com depuis un poste de mon
réseau, je n'ai aucune réponse. Par contre si je fais la même démarche
depuis l'extérieur ce la fonctionne ...


Euh, si tu ne pinges pas l'adresse IP (je présume) de ton serveur depuis
ton réseau, il semble normal que tu ne puisses t'y connecter avec son
nom qui est résolu en adresse IP par le DNS.

De ton réseau, que donne la commande suivante lancée dans un terminal :

host www.mondomaine.com

est-ce que tu obtiens bien l'adresse IP du serveur ?

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.


Sébastien B.
Le #468918
"Sébastien B."
Je ne comprends plus rien, hier soir ça a fonctionné, non seulement sur
le serveur mais aussi sur une machine cliente et aujourd'hui plus rien
... pourtant l'entrée www est toujours bien là dans les réglages de zone
, onglet ordinateurs ... quelqu'un a une idée ?

Merci
Par contre il y a autre chose d'étrange ... lorsque je ping l'adresse du

serveur où est hébergé le site www.mondomaine.com depuis un poste de mon
réseau, je n'ai aucune réponse. Par contre si je fais la même démarche
depuis l'extérieur ce la fonctionne ...


Euh, si tu ne pinges pas l'adresse IP (je présume) de ton serveur depuis
ton réseau, il semble normal que tu ne puisses t'y connecter avec son
nom qui est résolu en adresse IP par le DNS.


En fait je ping l'adresse IP genre 66.64.205.7 qui est en fait celle où
le site web est hébergé et je n'obtiens aucune réponse ... c'est ça qui
est bizarre. C'est comme si je faisais un ping sur les adresses IP de
mon serveur de mail (Claranet) qui est à l'extérieur et là ça fonctionne.

De ton réseau, que donne la commande suivante lancée dans un terminal :

host www.mondomaine.com

est-ce que tu obtiens bien l'adresse IP du serveur ?



Oui cette commande me donne bien l'adresse IP de mon serveur en interne
à savoir du type 192.168.x.x

Merci



laurent.pertois
Le #468917
"Sébastien B."
Euh, si tu ne pinges pas l'adresse IP (je présume) de ton serveur depuis
ton réseau, il semble normal que tu ne puisses t'y connecter avec son
nom qui est résolu en adresse IP par le DNS.


En fait je ping l'adresse IP genre 66.64.205.7 qui est en fait celle où
le site web est hébergé et je n'obtiens aucune réponse ...


Y a un problème quelque part, soit la machine qui héberge ne répond pas
aux pings, soit il y a un soucis autre.

c'est ça qui
est bizarre. C'est comme si je faisais un ping sur les adresses IP de
mon serveur de mail (Claranet) qui est à l'extérieur et là ça fonctionne.


Donc tu sors bien.


De ton réseau, que donne la commande suivante lancée dans un terminal :

host www.mondomaine.com

est-ce que tu obtiens bien l'adresse IP du serveur ?



Oui cette commande me donne bien l'adresse IP de mon serveur en interne
à savoir du type 192.168.x.x


Euh, je ne pige pas là, normalement ça devrait te renvoyer un truc genre
(pour reprendre ton exemple ci-dessus) : 66.64.205.7.

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.


Sébastien B.
Le #468916
"Sébastien B."
Euh, si tu ne pinges pas l'adresse IP (je présume) de ton serveur depuis
ton réseau, il semble normal que tu ne puisses t'y connecter avec son
nom qui est résolu en adresse IP par le DNS.
En fait je ping l'adresse IP genre 66.64.205.7 qui est en fait celle où

le site web est hébergé et je n'obtiens aucune réponse ...


Y a un problème quelque part, soit la machine qui héberge ne répond pas
aux pings, soit il y a un soucis autre.

c'est ça qui
est bizarre. C'est comme si je faisais un ping sur les adresses IP de
mon serveur de mail (Claranet) qui est à l'extérieur et là ça fonctionne.


Donc tu sors bien.


De ton réseau, que donne la commande suivante lancée dans un terminal :

host www.mondomaine.com

est-ce que tu obtiens bien l'adresse IP du serveur ?

Oui cette commande me donne bien l'adresse IP de mon serveur en interne

à savoir du type 192.168.x.x


Euh, je ne pige pas là, normalement ça devrait te renvoyer un truc genre
(pour reprendre ton exemple ci-dessus) : 66.64.205.7.



Non pardon, si je fais host mondomaine.com ça me renvoi l'adresse
interne de mon serveur 192.168.1.2

Par contre si je tape www.mondomaine.com, ça me renvoi bien la bonne
adresse de mon site web à savoir (pour l'exemple) 66.64.205.7

C'est donc encore plus étrange, le DNS a l'air de fonctionné ...

Mais le ping sur 66.64.205.7 ou www.mondomaine.com ne donne rien ...
(--- www.mondomaine.com ping statistics ---
10 packets transmitted, 0 packets received, 100% packet loss)

N'y a t'il pas un endroit où cette adresse peut être bloquée ?

Car le plus étrange c'est que cela a fonctionné une soirée ...



Sébastien B.
Le #468915
"Sébastien B."
Euh, si tu ne pinges pas l'adresse IP (je présume) de ton serveur depuis
ton réseau, il semble normal que tu ne puisses t'y connecter avec son
nom qui est résolu en adresse IP par le DNS.
En fait je ping l'adresse IP genre 66.64.205.7 qui est en fait celle où

le site web est hébergé et je n'obtiens aucune réponse ...


Y a un problème quelque part, soit la machine qui héberge ne répond pas
aux pings, soit il y a un soucis autre.

c'est ça qui
est bizarre. C'est comme si je faisais un ping sur les adresses IP de
mon serveur de mail (Claranet) qui est à l'extérieur et là ça fonctionne.


Donc tu sors bien.


De ton réseau, que donne la commande suivante lancée dans un terminal :

host www.mondomaine.com

est-ce que tu obtiens bien l'adresse IP du serveur ?

Oui cette commande me donne bien l'adresse IP de mon serveur en interne

à savoir du type 192.168.x.x


Euh, je ne pige pas là, normalement ça devrait te renvoyer un truc genre
(pour reprendre ton exemple ci-dessus) : 66.64.205.7.

J'ai même essayé sur le routeur, j'ai une fonction de ping d'adresse ...

normalement le routeur est indépendant du DNS ???
Eh bien même problème, le ping n'obtient aucune réponse.



Publicité
Poster une réponse
Anonyme