Problème d'acpi sur un laptop

Le
Goldy
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la prochaine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste noir rien
ne semble se produire (ctrl alt supp reboot le système).

Maintenant que j'ai pris la décision de passer sous debian, je suis bien
décidé à y rester, mais sans acpi c'est véritablement problématique pour
un laptop.

Est-ce que vous auriez des pistes à explorer sachant qu'il est difficile
de savoir ce qui se passe concrètement étant donné que je n'ai aucun
affichage et que le boot ne se fait pas (le système étant chiffré, il
faut saisir un mdp au boot, et même en le faisant à l'aveugle rien ne
semble se produire).

Est-ce que je devrais tenter un upgrade du noyaux ? Une compilation
manuelle ? (j'ai pas fait ça depuis des années).

Merci d'avance si vous avez des pistes à me conseiller.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4BAD75FE.20000@goldenfish.info
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #21446461
Le Sat, 27 Mar 2010 04:05:34 +0100,
Goldy
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la proch aine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste n oir rien
ne semble se produire (ctrl alt supp reboot le système).



ça ressemble à un PB de table DSDT:
http://tldp.org/HOWTO/ACPI-HOWTO/dsdt.html
http://www.unix.privat.t-online.de/acpi.html

--
"Consequences, Schmonsequences, as long as I'm rich."
-- Looney Tunes, Ali Baba Bunny (1957, Chuck Jones)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
giggz
Le #21447231
Goldy a écrit :
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la prochaine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste noir rien
ne semble se produire (ctrl alt supp reboot le système).

Maintenant que j'ai pris la décision de passer sous debian, je suis bien
décidé à y rester, mais sans acpi c'est véritablement problématique pour
un laptop.

Est-ce que vous auriez des pistes à explorer sachant qu'il est difficile
de savoir ce qui se passe concrètement étant donné que je n'ai aucun
affichage et que le boot ne se fait pas (le système étant chiffré, il
faut saisir un mdp au boot, et même en le faisant à l'aveugle rien ne
semble se produire).

Est-ce que je devrais tenter un upgrade du noyaux ? Une compilation
manuelle ? (j'ai pas fait ça depuis des années).

Merci d'avance si vous avez des pistes à me conseiller.




tente de booter avec acpi_osi="Linux" (modifie le menu.lst de grub pour ça)

sinon la piste de la dsdt est complexe mais vraisemblablement la plus
sure de fonctionner.

bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/hokl5g$j0s$
Goldy
Le #21453741
Le 27/03/2010 11:03, giggz a écrit :
Goldy a écrit :
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la prochaine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste noir rien
ne semble se produire (ctrl alt supp reboot le système).

Maintenant que j'ai pris la décision de passer sous debian, je suis bien
décidé à y rester, mais sans acpi c'est véritablement problématique pour
un laptop.

Est-ce que vous auriez des pistes à explorer sachant qu'il est difficile
de savoir ce qui se passe concrètement étant donné que je n'ai aucun
affichage et que le boot ne se fait pas (le système étant chiffré, il
faut saisir un mdp au boot, et même en le faisant à l'aveugle rien ne
semble se produire).

Est-ce que je devrais tenter un upgrade du noyaux ? Une compilation
manuelle ? (j'ai pas fait ça depuis des années).

Merci d'avance si vous avez des pistes à me conseiller.




tente de booter avec acpi_osi="Linux" (modifie le menu.lst de grub pour ça)

sinon la piste de la dsdt est complexe mais vraisemblablement la plus
sure de fonctionner.

bye




Malheureusement, acpi_osi="Linux" ne fonctionne pas.

Donc si je comprends bien, il va falloir que je recompile le noyaux.
Est-ce que je peux me permettre dans ce cas d'utiliser le dernier noyaux
stable de kernel.org et est ce que ça ne va pas poser problème en cas de
maj du noyaux dans la distribution ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Goldy
Le #21454071
Le 27/03/2010 11:03, giggz a écrit :
Goldy a écrit :
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la prochaine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste noir rien
ne semble se produire (ctrl alt supp reboot le système).

Maintenant que j'ai pris la décision de passer sous debian, je suis bien
décidé à y rester, mais sans acpi c'est véritablement problématique pour
un laptop.

Est-ce que vous auriez des pistes à explorer sachant qu'il est difficile
de savoir ce qui se passe concrètement étant donné que je n'ai aucun
affichage et que le boot ne se fait pas (le système étant chiffré, il
faut saisir un mdp au boot, et même en le faisant à l'aveugle rien ne
semble se produire).

Est-ce que je devrais tenter un upgrade du noyaux ? Une compilation
manuelle ? (j'ai pas fait ça depuis des années).

Merci d'avance si vous avez des pistes à me conseiller.




tente de booter avec acpi_osi="Linux" (modifie le menu.lst de grub pour ça)

sinon la piste de la dsdt est complexe mais vraisemblablement la plus
sure de fonctionner.

bye





J'ai de la chance qu'il soit présent des anciennes versions de kernel
dans le dépôt. J'ai installé la version 2.6.30 et je peux booter avec
l'acpi en utilisant celui-ci.

Cela doit être donc un bug dans le kernel 2.6.32, car j'ai eu le même
problème avec ubuntu lucid lynx qui utilise ce même kernel.

Je vais me passer de compilation pour le moment et utiliser ce kernel,
je ne sais pas si je dois faire un rapport de bug ni comment le rédiger,
mais si vous pensez que cela peut être nécessaire, je le ferai.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
giggzounet
Le #21459541
Goldy a écrit :
Le 27/03/2010 11:03, giggz a écrit :
Goldy a écrit :
Bonjour,

J'ai décidé de passer d'une installation d'ubuntu Karmic Koala à une
debian testing sur un laptop (sans marque de type barbone n1212). J'ai
pris cette décision après avoir tenté d'installer la prochaine version
de cette distribution et constatant qu'elle fonctionnait mal avec cette
machine.

Le soucis, c'est qu'avec testing j'ai un peu le même problème, je ne
peux pas booter le laptop si l'acpi est activé. L'écran reste noir rien
ne semble se produire (ctrl alt supp reboot le système).

Maintenant que j'ai pris la décision de passer sous debian, je suis bien
décidé à y rester, mais sans acpi c'est véritablement problématique pour
un laptop.

Est-ce que vous auriez des pistes à explorer sachant qu'il est difficile
de savoir ce qui se passe concrètement étant donné que je n'ai aucun
affichage et que le boot ne se fait pas (le système étant chiffré, il
faut saisir un mdp au boot, et même en le faisant à l'aveugle rien ne
semble se produire).

Est-ce que je devrais tenter un upgrade du noyaux ? Une compilation
manuelle ? (j'ai pas fait ça depuis des années).

Merci d'avance si vous avez des pistes à me conseiller.



tente de booter avec acpi_osi="Linux" (modifie le menu.lst de grub pour ça)

sinon la piste de la dsdt est complexe mais vraisemblablement la plus
sure de fonctionner.

bye





J'ai de la chance qu'il soit présent des anciennes versions de kernel
dans le dépôt. J'ai installé la version 2.6.30 et je peux booter avec
l'acpi en utilisant celui-ci.

Cela doit être donc un bug dans le kernel 2.6.32, car j'ai eu le même
problème avec ubuntu lucid lynx qui utilise ce même kernel.

Je vais me passer de compilation pour le moment et utiliser ce kernel,
je ne sais pas si je dois faire un rapport de bug ni comment le rédiger,
mais si vous pensez que cela peut être nécessaire, je le ferai.




ben déjà avant toute chose tu récupères le noyau le plus récent c'était
à dire le 2.6.33.1. soit tu le compiles à la main (ça fait un peu peur
la première fois...mais bon comme ça t'aprrends plein de trucs!) ou
sinon tu récupères le paquet d'expérimental. s'il y a tjs le problème
avec le 2.6.33 ben tu fais un rapport de bug avec debian sur le noyau.
en détaillant bien ton problème. tu peux aussi testé avec le 2.6.31,
histoire de voir qd survient ton problème.

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/hopjjv$4bi$
Goldy
Le #21467771
Le 29/03/2010 09:07, giggzounet a écrit :

ben déjà avant toute chose tu récupères le noyau le plus récent c'était
à dire le 2.6.33.1. soit tu le compiles à la main (ça fait un peu peur
la première fois...mais bon comme ça t'aprrends plein de trucs!) ou
sinon tu récupères le paquet d'expérimental. s'il y a tjs le problème
avec le 2.6.33 ben tu fais un rapport de bug avec debian sur le noyau.
en détaillant bien ton problème. tu peux aussi testé avec le 2.6.31,
histoire de voir qd survient ton problème.

Bye




J'ai ajouté le dépôt de lucid lynx dans mon installation testing en
réglant le pinning très bas (j'ai fait de même avec les dépots unstable).

J'ai trouvé dedans un paquet linux-image-2.6.31-10-rt que j'ai installé
pour voir, et ce noyaux fonctionne (et j'ai même l'impression qu'il
apporte des performances plus intéressante, principalement au niveau de
l'affichage de compiz qui me semble plus fluide avec ce noyaux).

C'est surprenant de voir que c'est le seul paquet de cette version du
noyaux dans le dépôt, probablement parce qu'il n'y a pas de version rt
du noyaux 2.6.32.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme