problème d'affichage d'une animation flash sous Windev 10

Le
serge91
Bonjour,
Sous Windev 10, j'ai mis un champ ActiveX comportant "shockwaveFlash

le programme me renvoie l'erreur :
L'objet sur lequel on accède au membre movie n'est pas un objet Automation.


Mes lignes de code sont les suivantes :

SI RegistreExiste("HKEY_CLASSES_ROOTShockwaveFlash.ShockwaveFlash") = Faux ALORS
Erreur("pas de plugin")
RENVOYER Faux
FIN

ActiveX1 =fRepEnCours()+ "ShockwaveFlash.ShockwaveFlash"

ActiveX1>>movie = fRepEnCours()+"dragon40.swf" (ligne où se produit l’erreur)

ActiveX1>>play()
ActiveX1..Visible = Vrai

PS : le plugin flash est bien présent sur l'ordinateur

Grand merci à ceux qui pourraient me dépanner

bien cordialement
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JeAn-PhI
Le #18458371
serge91 a écrit :
Bonjour,
Sous Windev 10, j'ai mis un champ ActiveX comportant "shockwaveFlash

le programme me renvoie l'erreur :
L'objet sur lequel on accède au membre movie n'est pas un objet
Automation.


Mes lignes de code sont les suivantes :

SI RegistreExiste("HKEY_CLASSES_ROOTShockwaveFlash.ShockwaveFlash") = Faux
ALORS
Erreur("pas de plugin")
RENVOYER Faux
FIN

ActiveX1 =fRepEnCours()+ "ShockwaveFlash.ShockwaveFlash"



ActiveX1>>movie(fRepEnCours()+"dragon40.swf") => avec ceci ?

ActiveX1>>play()
ActiveX1..Visible = Vrai

PS : le plugin flash est bien présent sur l'ordinateur

Grand merci à ceux qui pourraient me dépanner

bien cordialement



--
Cordialement JeAn-PhI
Publicité
Poster une réponse
Anonyme