problème avec clé wpa wifi

Le
Klaus Becker
Bonjour,

sous Lenny, ma connection wifi ne fonctionne plus alors qu'avant elle march=
ait
très bien.

J'ai une freebox, j'ai généré une clé "WPA (TKIP + AES)" que j'ai i=
ndiquée sur
mon portable dans /etc/wpa_supplicant/wpa_supplicant.conf. Par
/etc/network/interfaces, la connexion se fait en dhcp.

Or iwconfig m'indique que tout va bien, la carte wifi fonctionne, j'ai un p=
oint
d'accès, mais j'y trouve une clé qui n'a rien à voir avec celle indiq=
uée chez
Free et dans /etc/wpa_supplicant/wpa_supplicant.conf.

J'ai le même problème sous Lenny également sur un autre portable, seu=
lement
là, après un /etc/init.d/networking restart, la clé indiquée par iw=
config
change à chaque fois alors que sur le 1er portable, c'est toujours la m=
ême !

J'ai viré network-manager, pour voir si la mauvaise clé vient de là, =
eh non.
Il me semble que network-manager a été remplacé récemment par un au=
tre
packetage, mais je ne me souviens plus du nom et je ne le trouve pas.

Est-ce que qn peut éclairer ma lanterne ? D'où vient cette clé ??

ciao

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Klaus Becker
Le #19651621
On samedi 27 juin 2009 21:21:14 Klaus Becker wrote:
Bonjour,

sous Lenny, ma connection wifi ne fonctionne plus alors qu'avant elle
marchait très bien.

J'ai une freebox, j'ai généré une clé "WPA (TKIP + AES)" que j'ai indiquée
sur mon portable dans /etc/wpa_supplicant/wpa_supplicant.conf. Par
/etc/network/interfaces, la connexion se fait en dhcp.

Or iwconfig m'indique que tout va bien, la carte wifi fonctionne, j'ai un
point d'accès, mais j'y trouve une clé qui n'a rien à voir avec cel le
indiquée chez Free et dans /etc/wpa_supplicant/wpa_supplicant.conf.

J'ai le même problème sous Lenny également sur un autre portable, s eulement
là, après un /etc/init.d/networking restart, la clé indiquée par iwconfig
change à chaque fois alors que sur le 1er portable, c'est toujours la m ême
!

J'ai viré network-manager, pour voir si la mauvaise clé vient de là , eh
non. Il me semble que network-manager a été remplacé récemment pa r un autre
packetage, mais je ne me souviens plus du nom et je ne le trouve pas.

Est-ce que qn peut éclairer ma lanterne ? D'où vient cette clé ??

ciao

Klaus




J'ai trouvé le paquetage qui peut remplacer network-manager. C'est wicd, mais
il est dans testing et pas dans stable que j'utilise sur les 2 portables, d onc
le problème ne vient pas de lui.

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Yannick Fouquet
Le #19652181
Bonjour,

Mes connaissances sur le sujet sont plutôt empiriques donc je peux me
tromper mais si ça peut t'aider...

Klaus Becker a écrit :
sous Lenny, ma connection wifi ne fonctionne plus alors qu'avant elle marchait
très bien.

J'ai une freebox, j'ai généré une clé "WPA (TKIP + AES)" que j'ai indiquée sur
mon portable dans /etc/wpa_supplicant/wpa_supplicant.conf. Par
/etc/network/interfaces, la connexion se fait en dhcp.



Il semble y avoir 2 manières de faire.
Soit en passant par etc/network/interfaces, soit en passant par
network-manager (et seahorse pour garder automatiquement la clé).
Dans ce dernier cas,/etc/network/interfaces ne doit contenir que ce que
tu ne veux pas voir gérer par network-manager, par exemple :

auto lo
iface lo inet loopback

et eventuellement
allow-hotplug eth0
iface eth0 inet dhcp

pour une connexion cablée sans passer par X


Or iwconfig m'indique que tout va bien, la carte wifi fonctionne, j'ai un point
d'accès, mais j'y trouve une clé qui n'a rien à voir avec celle indiquée chez
Free et dans /etc/wpa_supplicant/wpa_supplicant.conf.



De mon côté, je n'ai pas /etc/wpa_supplicant/wpa_supplicant.conf mais
/etc/dbus-1/system.d/wpa_supplicant.conf et il ne contient aucune
configuration wifi.
iwconfig me donne une clé encryptée qui ne correspond pas à ma clé wpa
cryptée par :
# wpa_passphrase essid


J'ai le même problème sous Lenny également sur un autre portable, seulement
là, après un /etc/init.d/networking restart, la clé indiquée par iwconfig
change à chaque fois alors que sur le 1er portable, c'est toujours la même !



Je me demande si tu n'as pas un conflit entre les 2 solutions avec une
mauvaise clé conservée dans le trousseau pour network-manager-gnome par
exemple, et une autre dans wpa_supplicant.conf. J'ai eu à batailler
quelques fois pour faire accepter ma connexion en essayant, reessayant
et ressayant encore, en supprimant la clé dans le trousseau et en
essayant encore. Pour ma part, ça a fini par marcher...


J'ai viré network-manager, pour voir si la mauvaise clé vient de là, eh non.



Tu peux essayer au contraire de mettre en commentaire ta conf freebox
dans wpa_supplicant.conf pour la laisser gérer à network-manager.


Il me semble que network-manager a été remplacé récemment par un autre
packetage, mais je ne me souviens plus du nom et je ne le trouve pas.



Sauf erreur, tu doit parler de gnome-network-admin mais c'est en testing
que, passé en 2.22.1-5 gnome-network-admin a retiré
network-manager-gnome. On en a parlé un peu sur le fil "[testing] plus
de réseau" lancé par Gaëtan Perrier le 20/06/2009.



Est-ce que qn peut éclairer ma lanterne ? D'où vient cette clé ??



Pour ma part, j'utilise network-manager-gnome mais tu dois pouvoir faire
de même avec wicd. J'ai le /etc/network/interfaces minimal tel que
ci-dessus, gnome-network-admin est configuré pour l'itinérant, et c'est
network-manager-gnome qui gère. Je cliques sur le réseau voulu, je
rentre la clé la 1ère fois (avec seahorse, tu la conserve dans ton
trousseau) et c'est parti.

D'autres utilisent /etc/network/interfaces (en plus ça marche sans X),
mais ils seront plus à même de te conseiller là dessus (ex: sur le fil
"[testing] plus de réseau", réponse de giggz le 21/06/2009 :
"dans /etc/network/interfaces :

allow-hotplug eth1

###############################
## Roaming avec wpasupplicant :
###############################
## modifier le fichier ~/.wpa-roam.conf comme il faut
iface eth1 inet manual
wpa-roam /home/user/.wpa-roam.conf

## wpa-roam sort id_str comme identifiant de connexion. chaque
## connexion peut donc avoir une configuration propre. si aucune
## id_str n'est défini alors on utilise default qui fait du dhcp
iface default inet dhcp


Il y a un exemple de wpa-roam.conf dans les packages. ensuite tu remplis
au fur et à mesure le fichier. ça marche parfaitement chez moi;
"
Cela permet de configurer pour la freebox mais également pour ailleurs
si tu déplaces ta bécane...

Hope this helps.
Bon courage.
Yannick.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Klaus Becker
Le #19653821
On dimanche 28 juin 2009 00:12:35 Yannick Fouquet wrote:
Bonjour,

Mes connaissances sur le sujet sont plutôt empiriques donc je peux me
tromper mais si ça peut t'aider...

Klaus Becker a écrit :
> sous Lenny, ma connection wifi ne fonctionne plus alors qu'avant elle
> marchait très bien.
>
> J'ai une freebox, j'ai généré une clé "WPA (TKIP + AES)" que j' ai
> indiquée sur mon portable dans /etc/wpa_supplicant/wpa_supplicant.con f.
> Par
> /etc/network/interfaces, la connexion se fait en dhcp.

Il semble y avoir 2 manières de faire.
Soit en passant par etc/network/interfaces, soit en passant par
network-manager (et seahorse pour garder automatiquement la clé).
Dans ce dernier cas,/etc/network/interfaces ne doit contenir que ce que
tu ne veux pas voir gérer par network-manager, par exemple :

auto lo
iface lo inet loopback

et eventuellement
allow-hotplug eth0
iface eth0 inet dhcp

pour une connexion cablée sans passer par X

> Or iwconfig m'indique que tout va bien, la carte wifi fonctionne, j'ai un
> point d'accès, mais j'y trouve une clé qui n'a rien à voir avec c elle
> indiquée chez Free et dans /etc/wpa_supplicant/wpa_supplicant.conf.

De mon côté, je n'ai pas /etc/wpa_supplicant/wpa_supplicant.conf mais
/etc/dbus-1/system.d/wpa_supplicant.conf et il ne contient aucune
configuration wifi.
iwconfig me donne une clé encryptée qui ne correspond pas à ma cl é wpa
cryptée par :
# wpa_passphrase essid

> J'ai le même problème sous Lenny également sur un autre portable,
> seulement là, après un /etc/init.d/networking restart, la clé ind iquée
> par iwconfig change à chaque fois alors que sur le 1er portable, c'est
> toujours la même !

Je me demande si tu n'as pas un conflit entre les 2 solutions avec une
mauvaise clé conservée dans le trousseau pour network-manager-gnome p ar
exemple, et une autre dans wpa_supplicant.conf. J'ai eu à batailler
quelques fois pour faire accepter ma connexion en essayant, reessayant
et ressayant encore, en supprimant la clé dans le trousseau et en
essayant encore. Pour ma part, ça a fini par marcher...

> J'ai viré network-manager, pour voir si la mauvaise clé vient de l à, eh
> non.

Tu peux essayer au contraire de mettre en commentaire ta conf freebox
dans wpa_supplicant.conf pour la laisser gérer à network-manager.

> Il me semble que network-manager a été remplacé récemment par u n autre
> packetage, mais je ne me souviens plus du nom et je ne le trouve pas.

Sauf erreur, tu doit parler de gnome-network-admin mais c'est en testing
que, passé en 2.22.1-5 gnome-network-admin a retiré
network-manager-gnome. On en a parlé un peu sur le fil "[testing] plus
de réseau" lancé par Gaëtan Perrier le 20/06/2009.

> Est-ce que qn peut éclairer ma lanterne ? D'où vient cette clé ??

Pour ma part, j'utilise network-manager-gnome mais tu dois pouvoir faire
de même avec wicd. J'ai le /etc/network/interfaces minimal tel que
ci-dessus, gnome-network-admin est configuré pour l'itinérant, et c'e st
network-manager-gnome qui gère. Je cliques sur le réseau voulu, je
rentre la clé la 1ère fois (avec seahorse, tu la conserve dans ton
trousseau) et c'est parti.

D'autres utilisent /etc/network/interfaces (en plus ça marche sans X),
mais ils seront plus à même de te conseiller là dessus (ex: sur le fil
"[testing] plus de réseau", réponse de giggz le 21/06/2009 :
"dans /etc/network/interfaces :

allow-hotplug eth1

###############################
## Roaming avec wpasupplicant :
###############################
## modifier le fichier ~/.wpa-roam.conf comme il faut
iface eth1 inet manual
wpa-roam /home/user/.wpa-roam.conf

## wpa-roam sort id_str comme identifiant de connexion. chaque
## connexion peut donc avoir une configuration propre. si aucune
## id_str n'est défini alors on utilise default qui fait du dhcp
iface default inet dhcp


Il y a un exemple de wpa-roam.conf dans les packages. ensuite tu remplis
au fur et à mesure le fichier. ça marche parfaitement chez moi;
"
Cela permet de configurer pour la freebox mais également pour ailleurs
si tu déplaces ta bécane...

Hope this helps.
Bon courage.
Yannick.




merci Yannick,

je n'ai pas encore eu le temps d'étudier tout cela, mais j'ai une info de + :

Je n'avais pas encore vérifié sur le portable de ma tendre épouse (Ub untu) où
le wifi fonctionne encore avec la même config que sur mon portable.

Or je constate que la clé de cryptage (encryption key) indiquée par iwc onf
n'est pas la même que celle de /etc/wpa_supplicant/wpa_supplicant.conf. D onc
ce sont peut-être 2 clés différentes et mon problème ne vient pas d e là.

(Sur mon portable, j'avais mis en place une config wifi qui fonctionne à la
maison et au bureau (où je n'ai pas encore pu vérifier depuis le probl ème est
apparu chez moi), j'aimerais bien refaire fonctionner ça au lieu de cherc her
d'autres manières de configurer le wifi, si possible.)

bye

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Tonio
Le #19655251
> J'ai trouvé le paquetage qui peut remplacer network-manager. C'est wicd, mais
il est dans testing et pas dans stable que j'utilise sur les 2 portables, donc
le problème ne vient pas de lui.

Klaus




Il y a un backport de wicd pour lenny :
http://packages.debian.org/search?keywords=wicd&searchon=names&suite=all&section=all

Personnellement, je n'ai jamais réussi à me dépatouiller avec
NetworkManager (pas calé en wifi du tout), et wicd, par sa simplicité,
me rend bien service sous lenny et squeeze.

Cordialement,

Antoine.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Vincent Lefevre
Le #19711741
On 2009-06-28 16:11:17 +0200, Tonio wrote:
Personnellement, je n'ai jamais réussi à me dépatouiller avec
NetworkManager



Idem. Il semble qu'il faut une truc du style GNOME ou KDE pour
l'utiliser. Avec fvwm, je n'ai pas réussi.

(pas calé en wifi du tout), et wicd, par sa simplicité, me rend bien
service sous lenny et squeeze.



J'utilise aussi wicd.

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Pierre Meurisse
Le #19711981
Bonjour,

On Tue, Jul 07, 2009 at 04:11:58AM +0200, Vincent Lefevre wrote:

On 2009-06-28 16:11:17 +0200, Tonio wrote:
> Personnellement, je n'ai jamais réussi à me dépatouiller avec
> NetworkManager

Idem. Il semble qu'il faut une truc du style GNOME ou KDE pour
l'utiliser. Avec fvwm, je n'ai pas réussi.



avec XFCE, ça fonctionne aussi.

Avec Enlightenment (e16), j'utilise le paquet trayer pour lancer
NetworkManager.

A+

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Vincent Lefevre
Le #19714131
On 2009-07-07 07:52:37 +0200, Pierre Meurisse wrote:
Avec Enlightenment (e16), j'utilise le paquet trayer pour lancer
NetworkManager.



Merci, je ne connaissais pas ce paquet. Ça peut toujours être utile...

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Fran
Le #19716551
Vincent Lefevre a exprimé avec précision :

Personnellement, je n'ai jamais réussi à me dépatouiller avec
NetworkManager





Idem. Il semble qu'il faut une truc du style GNOME ou KDE pour
l'utiliser. Avec fvwm, je n'ai pas réussi.



Il pédalait dans la semoule quand je l'utilisais en wpa sous ubuntu
(pas de problème en wep), et je l'avais remplacé par wicd.
Sous Debian, je n'ai jamais réussi à le faire marcher.

(pas calé en wifi du tout), et wicd, par sa simplicité, me rend
bien
service sous lenny et squeeze.





J'utilise aussi wicd.



Pareil.

--
François
Pour vivre heureux, il faut coucher sur la paille que l’on voit dans
l’œil de son voisin, et se chauffer avec la poutre qu’on a dans le sien
- Alphonse ALLAIS



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #19718111
François, mardi 7 juillet 2009, 17:39:13 CEST

Vincent Lefevre a exprimé avec précision :

>> Personnellement, je n'ai jamais réussi à me dépatouil ler avec
>> NetworkManager

> Idem. Il semble qu'il faut une truc du style GNOME ou KDE pour
> l'utiliser. Avec fvwm, je n'ai pas réussi.

Il pédalait dans la semoule quand je l'utilisais en wpa sous ubuntu
(pas de problème en wep), et je l'avais remplacé par wicd.
Sous Debian, je n'ai jamais réussi à le faire marcher.



Juste pour dire : ça fait 3 ans qu’il (NM) me sert fid èlement,
d’abord sous Fvwm (applet knetworkmanager dans un stalonetray)
puis KDE (3 puis 4), en WEP puis WPA2, sur 4 PC différents.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Fran
Le #19718101
Sylvain Sauvage a utilisé son clavier pour écrire :

Juste pour dire : ça fait 3 ans qu’il (NM) me sert fidèlement,
d’abord sous Fvwm (applet knetworkmanager dans un stalonetray)
puis KDE (3 puis 4), en WEP puis WPA2, sur 4 PC différents.



Tu as de la chance.
Il y a peut-être un problème de compatibilité avec certains routeurs,
une Livebox en ce qui me concerne.

--
François
Si le bol de riz qu'on te propose ne te convient pas, laisse le riz
et mange le bol.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme