Probleme avec Flashplayer

Le
Bernard
Bonjour à tous,

J'ai de sérieux problèmes avec FlashPlayer. Sur mon système Debian
Lenny, certains sites web ne fonctionnent pas correctement. Ainsi, les
Archives Départementales, qui proposent depuis quelques années la
consultation d'archives en ligne, ont adopté, selon les départements,
diverses fonctionnalités que leurs concepteurs n'ont testé, le plus
souvent, qu'avec Internet Explorer sous MSWIN. Sur les quelque 60
départements "en ligne", je ne suis familier que des AD du 78, 79 et 85.
Durant une période relativement brève (quelques mois), ces trois sites
départementaux fonctionnaient bien sur ce PC dont je me sers le plus
couramment. Puis certains sites ont cessé de fonctionner correctement,
suite, sans doute, à l'évolution de leur programme et à l'adaptation de
celui ci aux nouvelles versions de FlashPlayer et autres supports.
Ainsi, depuis quelques mois, le site des AD78 ne fonctionnait plus que
sur un seul de mes trois PC (celui-ci était sous Ubuntu Hardy Heron), le
site des AD85 n'était plus opérationnel que sur un autre (sous Debian
Squeeze), et, sur mon Desktop sous Lenny (celui d'où vous provient ce
message), je n'accédais plus qu'aux AD79 !

Ce dernier ordi étant celui que j'utilise le plus fréquemment, j'ai
envisagé l'upgrade de Flashplayer mais, apparemment, ceci n'est pas
possible :

root@new-host:/home/bd# apt-get install -s flashplayer-mozilla
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
flashplayer-mozilla: Dépend: libatk1.0-0 (>= 1.29.3) mais 1.22.0-1
devra être installé
Dépend: libfontconfig1 (>= 2.8.0) mais 2.6.0-3
devra être installé
Dépend: libgtk2.0-0 (>= 2.14.0) mais
2.12.12-1~lenny2 devra être installé
Recommande: flash-player-properties mais ne sera
pas installé
E: Paquets défectueux
root@new-host:/home/bd#

Merci d'avance pour vos lumières

Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4DF7ED6A.10907@teaser.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Roussin
Le #23462861
Bonjour,

Sur mes différents PC j'utilise avec succès le paquet flashplugin-nonfree
http://wiki.debian.org/FlashPlayer

Guy

Le 15/06/2011 01:23, Bernard a écrit :
Bonjour à tous,

J'ai de sérieux problèmes avec FlashPlayer. Sur mon système Debian Lenny, certains sites
web ne fonctionnent pas correctement. Ainsi, les Archives Départementales, qui proposent
depuis quelques années la consultation d'archives en ligne, ont adopté, selon les
départements, diverses fonctionnalités que leurs concepteurs n'ont testé, le plus souvent,
qu'avec Internet Explorer sous MSWIN. Sur les quelque 60 départements "en ligne", je ne
suis familier que des AD du 78, 79 et 85. Durant une période relativement brève (quelques
mois), ces trois sites départementaux fonctionnaient bien sur ce PC dont je me sers le
plus couramment. Puis certains sites ont cessé de fonctionner correctement, suite, sans
doute, à l'évolution de leur programme et à l'adaptation de celui ci aux nouvelles
versions de FlashPlayer et autres supports. Ainsi, depuis quelques mois, le site des AD78
ne fonctionnait plus que sur un seul de mes trois PC (celui-ci était sous Ubuntu Hardy
Heron), le site des AD85 n'était plus opérationnel que sur un autre (sous Debian Squeeze),
et, sur mon Desktop sous Lenny (celui d'où vous provient ce message), je n'accédais plus
qu'aux AD79 !

Ce dernier ordi étant celui que j'utilise le plus fréquemment, j'ai envisagé l'upgrade de
Flashplayer... mais, apparemment, ceci n'est pas possible :

:/home/bd# apt-get install -s flashplayer-mozilla
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
flashplayer-mozilla: Dépend: libatk1.0-0 (>= 1.29.3) mais 1.22.0-1 devra être installé
Dépend: libfontconfig1 (>= 2.8.0) mais 2.6.0-3 devra être installé
Dépend: libgtk2.0-0 (>= 2.14.0) mais 2.12.12-1~lenny2 devra être installé
Recommande: flash-player-properties mais ne sera pas installé
E: Paquets défectueux
:/home/bd#

Merci d'avance pour vos lumières

Bernard




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #23463111
Le 15/06/11, Guy Roussin
Sur mes différents PC j'utilise avec succès le paquet flashplugin-non free
http://wiki.debian.org/FlashPlayer



Pour ma part, j'ai tenté plusieurs fois de faire appel à ce package
provenant des backports lenny, mais non content de ne pas marcher, ça
me fait des bugs dans d'autres applications, notamment pidgin
crash. Donc Bernard, fait attention, parce que ce n'est pas super
drôle de voir d'autres applis bugguer à cause de l'install de
nouveaux paquets dépendants. Comme je ne suis pas assez compétent pour
résoudre, heureusement que j'ai un backup.

Mais si quelqu'un sait comment se dépatouiller de tou tça, ça
m'intéresse.

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTin9KMLgK+
maderios
Le #23463251
On 06/15/2011 09:43 AM, Raphaël POITEVIN wrote:
Le 15/06/11, Guy Roussin
Sur mes différents PC j'utilise avec succès le paquet flashplugin-nonfree
http://wiki.debian.org/FlashPlayer



Pour ma part, j'ai tenté plusieurs fois de faire appel à ce package
provenant des backports lenny, mais non content de ne pas marcher, ça
me fait des bugs dans d'autres applications, notamment pidgin
crash. Donc Bernard, fait attention, parce que ce n'est pas super
drôle de voir d'autres applis bugguer à cause de l'install de
nouveaux paquets dépendants. Comme je ne suis pas assez compétent pour
résoudre, heureusement que j'ai un backup.

Mais si quelqu'un sait comment se dépatouiller de tou tça, ça
m'intéresse.

Raphaël



Dans ton cas, le plus simple est de désinstaller tous les .deb
concernant Flash puis de copier le dernier plugin Flash (téléchargé sur
le site d'Adobe) dans /usr/lib/mozilla/plugins et de le rendre exécutable.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #23463431
Bonjour,
Le 15/06/11, maderios
Dans ton cas, le plus simple est de désinstaller tous les .deb



Tout va bien, jepars d'une install fraîche sans rien concernant flash.

concernant Flash puis de copier le dernier plugin Flash (télécharg é sur
le site d'Adobe) dans /usr/lib/mozilla/plugins et de le rendre
exécutable.



Génial ça marche ! Il faut juste faire attention au .tar.gz qui
déploie plein de fichiers inutiles dans notre cas, copier le
libflashplugin.so vers la destination que tu indiques et ça roule !

Merci, je ne croyais pas que ça aurait été aussi simple.

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Guy Roussin
Le #23464291
concernant Flash puis de copier le dernier plugin Flash (téléchargé sur
le site d'Adobe) dans /usr/lib/mozilla/plugins et de le rendre
exécutable.



Génial ça marche ! Il faut juste faire attention au .tar.gz qui
déploie plein de fichiers inutiles dans notre cas, copier le
libflashplugin.so vers la destination que tu indiques et ça roule !



En fait c'est exactement ce que fait le paquet flashplugin-nonfree
(téléchargement + copie du .so)
Sauf qu'il utilise un mécanisme de liens qui permet à ce que tous les
navigateurs installés sur ta debian puissent en profiter (iceweasel, chromium, ...)
J'ai une 40ène de machines installés. J'ai jamais eu de problème
particulier ...

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël POITEVIN
Le #23464311
Le 15/06/11, Guy Roussin
Génial ça marche ! Il faut juste faire attention au .tar.gz qui
déploie plein de fichiers inutiles dans notre cas, copier le
libflashplugin.so vers la destination que tu indiques et ça roule !



En fait c'est exactement ce que fait le paquet flashplugin-nonfree
(téléchargement + copie du .so)
Sauf qu'il utilise un mécanisme de liens qui permet à ce que tous les
navigateurs installés sur ta debian puissent en profiter (iceweasel,
chromium, ...)
J'ai une 40ène de machines installés. J'ai jamais eu de problème
particulier ...



Avant j'en avais pas ! Depuis que j'ai voulu faire des mise à jour, ça
casse des composants. C'est pire avec le flashplayer-mozilla du dépôt
multimedia; Peut-être qu'avec Squeeze ça marche mieux, mais pour le
moment je préfère rester en Lenny.

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/BANLkTikO4QdRcLOk0veJB+
Bernard
Le #23469551
Guy Roussin wrote:
Bonjour,

Sur mes différents PC j'utilise avec succès le paquet flashplugin-nonfree
http://wiki.debian.org/FlashPlayer

Guy



Merci, je connaissais le paquet flashplugin-nonfree, mais chez moi cela
ne marche pas, tout au moins pas sur mon système Lenny:

:/home/bd# apt-get install -s flashplugin-nonfree
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
flashplugin-nonfree: Dépend: libgtk2.0-0 (>= 2.14) mais
2.12.12-1~lenny2 devra être installé
E: Paquets défectueux
:/home/bd#

*******************

Cà, c'est sur donc mon installation Lenny

******************

Sur mon portable DELL avec UBUNTU 8.04 (Hardy Heron),
flashplugin-nonfree a déjà été installé:

sudo apt-get install -s flashplugin-nonfree ==> Flashplugin-nonfree est
déjà la plus récente version disponible

Sur ce portable, lorsque je vais, avec Firefox, sur le site des AD78 et
que je demande la consultation des actes paroissiaux en ligne, au moment
du lancement de l'applet j'assiste chaque fois à la fermeture brutale de
Firefox. Même résultat avec Epiphany. Sur le site des AD85 (Vendée),
tout est OK, de même que sur le site des AD79 (Deux Sèvres). Le 79 est
également OK sous mon Lenny, mais pas le 85: là j'ai la première page du
registre choisi, mais impossible de tourner les pages, l'appui sur la
touche de changement de page ne donne aucun résultat, par contre le 78
fonctionne OK, contrairement au système UBUNTU avec Flashplugin-nonfree,
comme je viens de le dire.

Et, pour finir, sur mon ASUS sous Squeeze, Flashplugin-nonfree est déjà
installé, mais le site des AD78 ne fonctionne pas ! Contrairement à ce
qui se passe avec Flashplugin-nonfree sous Ubuntu 8.04, Firefox ne se
referme pas, mais rien n'apparaît à l'écran: après le lancement de
l'applet, un écran blanc apparaît avec la mention "terminé", et c'est
tout. Les AD79 et 85, quant à eux, fonctionnent.

En résumé, je dispose de "Flashplugin-nonfree" sur deux de mes trois PC,
l'un sous un système récent (Squeeze) et l'autre sous un système ancien
(Ubuntu Hardy Heron) : le site des AD78 ne fonctionne correctement sous
aucun !

Le site des AD78 ne fonctionne que sur le seul système sur lequel je ne
dispose pas de "Flashplugin-nonfree" (Lenny), mais, là, c'est le 85 qui
déconne !

Aucun de mes trois systèmes ne permet le fonctionnement correct des
trois sites d'AD (78,79,85) et, comme j'ai la nécessité de les consulter
tous, je n'ai pas trop de mes trois ordis pour ce faire !!!



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard
Le #23887411
Raphaël POITEVIN wrote:
Bonjour,
Le 15/06/11, maderios
Dans ton cas, le plus simple est de désinstaller tous les .deb




Tout va bien, jepars d'une install fraîche sans rien concernant flash.


concernant Flash puis de copier le dernier plugin Flash (téléchargé sur
le site d'Adobe) dans /usr/lib/mozilla/plugins et de le rendre
exécutable.




Génial ça marche ! Il faut juste faire attention au .tar.gz qui
déploie plein de fichiers inutiles dans notre cas, copier le
libflashplugin.so vers la destination que tu indiques et ça roule !

Merci, je ne croyais pas que ça aurait été aussi simple.

Raphaël




Bonjour,

Ici aussi çà marche. Sauf que... depuis que j'ai remplacé mon ancien .so
par le

libflashplugin.so

Firefox se plante souvent. Il s'agit de Iceweaser 3.06 sous Debian
Lenny. Avant d'avoir fait ce remplacement, Firefox ne se plantait
quasiment jamais, mais, depuis quelques mois, je ne pouvais plus accéder
à certaines fonctionnalités dépendant de Flash (notamment les images
mises en ligne par les Archives Départementales). J'accède donc
maintenant à ces pages... çà ne plante pas sur celles ci, mais sur
d'autres, disons sur 10 à 20% des pages que j'ouvre. Il en va de même
pour Epiphany 2.22.3, lequel, sans doute, fait usage du même plugin,
bien que je ne l'aie installé que dans le répertoire

/usr/lib/mozilla/plugins

Merci d'avance pour vos commentaires ou suggestions.

Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
J
Le #23888541
Le jeudi 20 octobre 2011 à 17:25 +0200, Bernard a écrit :
Il en va de même
pour Epiphany 2.22.3, lequel, sans doute, fait usage du même plugin,
bien que je ne l'aie installé que dans le répertoire

/usr/lib/mozilla/plugins



Si c'est juste pour Iceweasel, en procédure manuelle je mets
libflashplugin.so dans ~/.mozilla/plugins et je désactive si
nécessaire, dans le menu des modules complémentaire, les autres plugins.

Mais je suis en 64bits partout et n'ai pas eu de problème récent avec le
paquet flashplayer-nonfree (qui positionne l'alternative). Juste
vérifier qu'il n'y ait pas un ancien plugin installé manuellement qui
traîne dans le path des plugins.

Un petit ajout dans le script de lancement de Iceweasel pour supprimer
tout le contenu des dossiers ~/macromedia et ~/.adobe fait du bien à
tout points de vue, étant donné la @☭⎈⁂㌶☣☠☠☠⚡(((●~* qui est stockée
dedans. Une alternative "soft" est d'utiliser l'extension
"betterprivacy".


Très éventuellement, avec certaines cartes graphiques, un clic droit sur
l'animation flash pour désactiver l'accélération intégrée peut faire du
bien.

Et enfin, ça vaut vraiment le coup d'installer iceweasel en version
récente, ça marche mieux, flash ne plante (presque) pas. Il y a un dépôt
backport fait exprès :

http://grawok.wordpress.com/2011/09/28/installer-iceweasel-7-firefox-7-release-en-francais-sur-debian-squeeze/


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bernard Schoenacker
Le #23888621
Le Fri, 21 Oct 2011 00:43:03 +0200,
Jérôme
Le jeudi 20 octobre 2011 à 17:25 +0200, Bernard a écrit :
> Il en va de même
> pour Epiphany 2.22.3, lequel, sans doute, fait usage du même
> plugin, bien que je ne l'aie installé que dans le répertoire
>
> /usr/lib/mozilla/plugins

Si c'est juste pour Iceweasel, en procédure manuelle je mets
libflashplugin.so dans ~/.mozilla/plugins et je désactive si
nécessaire, dans le menu des modules complémentaire, les autres
plugins.

Mais je suis en 64bits partout et n'ai pas eu de problème récen t avec
le paquet flashplayer-nonfree (qui positionne l'alternative). Juste
vérifier qu'il n'y ait pas un ancien plugin installé manuelleme nt qui
traîne dans le path des plugins.

Un petit ajout dans le script de lancement de Iceweasel pour supprimer
tout le contenu des dossiers ~/macromedia et ~/.adobe fait du bien à
tout points de vue, étant donné la @☭⎈⁂ ㌶☣☠☠☠⚡(((●~ * qui est stockée
dedans. Une alternative "soft" est d'utiliser l'extension
"betterprivacy".


Très éventuellement, avec certaines cartes graphiques, un clic droit
sur l'animation flash pour désactiver l'accélération int égrée peut
faire du bien.

Et enfin, ça vaut vraiment le coup d'installer iceweasel en version
récente, ça marche mieux, flash ne plante (presque) pas. Il y a un
dépôt backport fait exprès :

http://grawok.wordpress.com/2011/09/28/installer-iceweasel-7-firefox-7-re lease-en-francais-sur-debian-squeeze/





bonjour,

pourquoi ne pas employer également Bleachbit ?

bleachbit - delete unnecessary files from the system

Description:

BleachBit deletes unnecessary files to free valuable disk
space, maintain privacy, and remove junk.

It removes cache, Internet history, temporary files,cookies, and
broken shortcuts.

It handles cleaning of Adobe Reader, Bash, Beagle, Epiphany, Fire=
fox, Flash, GIMP, Google Earth, Java, KDE, OpenOffice.org, Opera;
RealPlayer, rpmbuild, Second Life Viewer, VIM, XChat, and
more ...

Homepage: http://bleachbit.sourceforge.net

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme