Probleme avec le fonction Recherche()

Le
Bill2
Bonjour à tous,

Je vous expose mon petit problème du vendredi soir.

J'ai donc un classeur avec 2 feuilles, sous excel 2007

Dans la première, des infos avec code postal, et nom de "découpage
administratif" associé.

Dans ma 2e feuille, je retrouve ces codes postaux, et je veux afficher les
nom des découpages.

Donc une petite formule, avec un Recherche()

Sauf que pour les 84 premiers codes postaux, ça ne fonctionne pas : elle
renvoi "#N/A" !
J'ai vérifier les formats des cellules, on a bien du numérique partout.
Je n'arrive pas à comprendre pourquoi une même formule ne fonctionne pas sur
une partie du tableau, et fonctionne ensuite sans aucune raison..

Je vous joint le fichier ici : http://cjoint.com/?kfongwlZXr

Si vous avez le temps de jetter un coup d'oeil, merci d'avance à vous tous !
--
Bill2
Utilisez Process Manager, gestionnaire de processus automatique :
http://bill2web.chez-alice.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4962371
bonjour bill2,

peut tu enregistrer ton fichier sur xl97/2003 et revenir donner le lien ci-joint, car y 'a pas beaucoup de contributeur ayant xl2007.

isabelle


Bonjour à tous,

Je vous expose mon petit problème du vendredi soir.

J'ai donc un classeur avec 2 feuilles, sous excel 2007

Dans la première, des infos avec code postal, et nom de "découpage
administratif" associé.

Dans ma 2e feuille, je retrouve ces codes postaux, et je veux afficher les
nom des découpages.

Donc une petite formule, avec un Recherche()

Sauf que ... pour les 84 premiers codes postaux, ça ne fonctionne pas : elle
renvoi "#N/A" !
J'ai vérifier les formats des cellules, on a bien du numérique partout.
Je n'arrive pas à comprendre pourquoi une même formule ne fonctionne pas sur
une partie du tableau, et fonctionne ensuite sans aucune raison..

Je vous joint le fichier ici : http://cjoint.com/?kfongwlZXr

Si vous avez le temps de jetter un coup d'oeil, merci d'avance à vous tous !


Bill2
Le #4962361
isabelle wrote:
bonjour bill2,

peut tu enregistrer ton fichier sur xl97/2003 et revenir donner le
lien ci-joint, car y 'a pas beaucoup de contributeur ayant xl2007.


Pas de pb, voilà : http://cjoint.com/?kfpaVUERQA
(Je l'ai mis dans un zip, car trop "lourd" sinon pour cjoint ...)

Et c'est vrai que, voyant pas mal de sujet sur 2007, je n'ai pas pensé que
tout le monde ne l'avait pas ... mea culpa !

--
Bill2
Utilisez Process Manager, gestionnaire de processus automatique :
http://bill2web.chez-alice.fr/

isabelle
Le #4962351
re bonjour Bill2,

voilà j'ai testé avec celle ci
=INDEX('1'!C:C;EQUIV($A3;'1'!$A:$A;0))
et ça va mieux.

isabelle


isabelle wrote:

bonjour bill2,

peut tu enregistrer ton fichier sur xl97/2003 et revenir donner le
lien ci-joint, car y 'a pas beaucoup de contributeur ayant xl2007.



Pas de pb, voilà : http://cjoint.com/?kfpaVUERQA
(Je l'ai mis dans un zip, car trop "lourd" sinon pour cjoint ...)

Et c'est vrai que, voyant pas mal de sujet sur 2007, je n'ai pas pensé que
tout le monde ne l'avait pas ... mea culpa !




Bill2
Le #4962341
isabelle wrote:
re bonjour Bill2,

voilà j'ai testé avec celle ci
=INDEX('1'!C:C;EQUIV($A3;'1'!$A:$A;0))
et ça va mieux.



OK, merci, ça fonctionne impec !

Mais ça ne m'explique pas pourquoi le Recherche() ne fonctionne pas sur une
partie de mon tableau ...

Bon Week end !

--
Bill2
Utilisez Process Manager, gestionnaire de processus automatique :
http://bill2web.chez-alice.fr/

MichDenis
Le #4962291
Assigne un nom à ton tableau en feuille 1

suppose comme nom : Toto = $A$2:E2048

Et dans ta formule en feuille Calcul , cellule B3 , tu inscris :
=RECHERCHEV(A3;toto;3;0)
Cellule C3
=RECHERCHEV(A3;toto;4;0)
cellule C4
=RECHERCHEV(A3;toto;5;0)

Il est préférable d'utiliser ce qu'isabelle t'a proposée



"Bill2" %
isabelle wrote:
re bonjour Bill2,

voilà j'ai testé avec celle ci
=INDEX('1'!C:C;EQUIV($A3;'1'!$A:$A;0))
et ça va mieux.



OK, merci, ça fonctionne impec !

Mais ça ne m'explique pas pourquoi le Recherche() ne fonctionne pas sur une
partie de mon tableau ...

Bon Week end !

--
Bill2
Utilisez Process Manager, gestionnaire de processus automatique :
http://bill2web.chez-alice.fr/

verochoj Hors ligne
Le #23876011
Bill2 a écrit le 05/10/2007 à 14h13 :
Bonjour à tous,

Je vous expose mon petit problème du vendredi soir.

J'ai donc un classeur avec 2 feuilles, sous excel 2007

Dans la première, des infos avec code postal, et nom de
"découpage
administratif" associé.

Dans ma 2e feuille, je retrouve ces codes postaux, et je veux afficher les
nom des découpages.

Donc une petite formule, avec un Recherche()

Sauf que ... pour les 84 premiers codes postaux, ça ne fonctionne pas :
elle
renvoi "#N/A" !
J'ai vérifier les formats des cellules, on a bien du numérique
partout.
Je n'arrive pas à comprendre pourquoi une même formule ne
fonctionne pas sur
une partie du tableau, et fonctionne ensuite sans aucune raison..

Je vous joint le fichier ici : http://cjoint.com/?kfongwlZXr

Si vous avez le temps de jetter un coup d'oeil, merci d'avance à vous
tous !
--
Bill2
Utilisez Process Manager, gestionnaire de processus automatique :
http://bill2web.chez-alice.fr/


J'ai moi aussi 2 feuilles excel dans un même classeur.
Dans ma feuille "CP" j'ai en colonne A les codes postaux, en colonne B les villes.
Dans ma feuille "Inscrits" en colonne C les codes postaux, en colonne D les villes qui vont s'afficher automatiquement.
Dans ta cellule où tu veux que ça commence à apparaître tu tapes la formule :
=SI(C2=CP!A1;CP!B1;RECHERCHEV(C2;CP!A:B;2;FAUX))
et tu fais glisser ta formule.
C'est trop cool.
Publicité
Poster une réponse
Anonyme