Problème avec FormulaLocal

Le
Vallebarray
Dans le code suivant les lignes 1à 3 fonctionnent, mais la ligne 4 ouvre une
fenêtre d'erreur 1004 "erreur définie par l'application ou par l'objet"

1 With Sheets("calc")
2 .Range("J2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;13)"

3 .Range("K2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;12)"

4 .Range("L2").FormulaLocal =
"=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
5 End With

Je ne comprend pas ce qui se passe, quelqu'un aurait il une idée ?

Merci d'avance
--
Le galérien
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
J&B
Le #16389671
Bonjour

4 .Range("L2").FormulaLocal "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"""";RECHERCHEV(Type;AA1062:AM1571;3))"


"Vallebarray" message de news:
Dans le code suivant les lignes 1à 3 fonctionnent, mais la ligne 4 ouvre
une
fenêtre d'erreur 1004 "erreur définie par l'application ou par l'objet"

1 With Sheets("calc")
2 .Range("J2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;13)"

3 .Range("K2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;12)"

4 .Range("L2").FormulaLocal > "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
5 End With

Je ne comprend pas ce qui se passe, quelqu'un aurait il une idée ?

Merci d'avance
--
Le galérien


Vallebarray
Le #16390641
Oui, ça marche et c'est étonnant puisque la formule créee par ce code est :
.Range("L2").FormulaLocal > "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
Pourquoi le code est il différent ? (4 doubles cotes au lieu de 2)
En tous cas, merci J&B.
--
Le galérien.


"J&B" a écrit :

Bonjour

4 .Range("L2").FormulaLocal > "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"""";RECHERCHEV(Type;AA1062:AM1571;3))"


"Vallebarray" message de news:
> Dans le code suivant les lignes 1à 3 fonctionnent, mais la ligne 4 ouvre
> une
> fenêtre d'erreur 1004 "erreur définie par l'application ou par l'objet"
>
> 1 With Sheets("calc")
> 2 .Range("J2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;13)"
>
> 3 .Range("K2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;12)"
>
> 4 .Range("L2").FormulaLocal > > "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
> 5 End With
>
> Je ne comprend pas ce qui se passe, quelqu'un aurait il une idée ?
>
> Merci d'avance
> --
> Le galérien





Rouch
Le #16394731
Bonjour,

Il s'agit d'une règle de syntaxe pour que, dans VBA, il puisse
distinguer les " de code VBA [Celui qui est après ton >] et les " des
formules [celui au milieu de ta formule].
La règle est qu'un "" dans une formule locale soit transformé dans la
feuille excel en un simple "

@+


Oui, ça marche et c'est étonnant puisque la formule créee par ce code est :
.Range("L2").FormulaLocal >> "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
Pourquoi le code est il différent ? (4 doubles cotes au lieu de 2)
En tous cas, merci J&B.
--
Le galérien.


"J&B" a écrit :

Bonjour

4 .Range("L2").FormulaLocal >> "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"""";RECHERCHEV(Type;AA1062:AM1571;3))"


"Vallebarray" message de news:
Dans le code suivant les lignes 1à 3 fonctionnent, mais la ligne 4 ouvre
une
fenêtre d'erreur 1004 "erreur définie par l'application ou par l'objet"

1 With Sheets("calc")
2 .Range("J2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;13)"

3 .Range("K2").FormulaLocal = "=RECHERCHEV(Type;AA1062:AM1571;12)"

4 .Range("L2").FormulaLocal >>> "=SI(ESTERREUR(RECHERCHEV(Type;AA1062:AM1571;3));"";RECHERCHEV(Type;AA1062:AM1571;3))"
5 End With

Je ne comprend pas ce qui se passe, quelqu'un aurait il une idée ?

Merci d'avance
--
Le galérien









Publicité
Poster une réponse
Anonyme