Problème avec formule

Le
anne & greg
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur j'ai
plusieurs choses de marquer sur une ligne genre (n° de tel + email +adresse
etc) et dans la derniere colonne j'ai une liste deroulante avec plusieurs
choix (genre X et Y) je voudrais mettre la meme ligne sur la feuille n°2 qui
contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a le X
sur la feuille 2
Merci d'avance de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #5055881
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et suivant,
vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur j'ai
plusieurs choses de marquer sur une ligne genre (n° de tel + email
+adresse etc...) et dans la derniere colonne j'ai une liste deroulante
avec plusieurs choix (genre X et Y) je voudrais mettre la meme ligne sur
la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a le X
sur la feuille 2
Merci d'avance de votre aide



anne & greg
Le #5054871
Désolé mais ce n'est pas la bonne formule souhaité
Je vous joint le fichier en question sur le site cjoint
Merci d'avance a tous ceux qui voudront bien plancher a ma place :o)
Anne
http://cjoint.com/?lnt6mmizRo


"Philippe.R"
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et suivant,
vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur j'ai
plusieurs choses de marquer sur une ligne genre (n° de tel + email
+adresse etc...) et dans la derniere colonne j'ai une liste deroulante
avec plusieurs choix (genre X et Y) je voudrais mettre la meme ligne sur
la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a le X
sur la feuille 2
Merci d'avance de votre aide






Philippe.R
Le #5054831
Bonsoir,
La formule sera donc plutôt celle ci, à coller en A3 du tableau de Feuille2
et à recopier vers la droite et vers le bas :

=SI(OU(Feuille1!$H3<>"X";Feuille1!A3="");"";Feuille1!A3)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4739f487$0$5088$
Désolé mais ce n'est pas la bonne formule souhaité
Je vous joint le fichier en question sur le site cjoint
Merci d'avance a tous ceux qui voudront bien plancher a ma place :o)
Anne
http://cjoint.com/?lnt6mmizRo


"Philippe.R"
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et
suivant, vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur
j'ai plusieurs choses de marquer sur une ligne genre (n° de tel + email
+adresse etc...) et dans la derniere colonne j'ai une liste deroulante
avec plusieurs choix (genre X et Y) je voudrais mettre la meme ligne sur
la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a le
X sur la feuille 2
Merci d'avance de votre aide










perso
Le #5054821
Bsr Anne,

Tu veux du VBA ? tu connais les macros ?

J'ai certainement qqchose pour toi

J'attends ta réponse

Pat Rednef
Philippe.R
Le #5054761
Re,
Petite précision, mieux vaut, lors de la recopie, utiliser le collage
spécial / formule (Alt + e, Alt + g, Alt + u , "Entrée", "Echap"), histoire
de conserver les formats.
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Philippe.R" news:
Bonsoir,
La formule sera donc plutôt celle ci, à coller en A3 du tableau de
Feuille2 et à recopier vers la droite et vers le bas :

=SI(OU(Feuille1!$H3<>"X";Feuille1!A3="");"";Feuille1!A3)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4739f487$0$5088$
Désolé mais ce n'est pas la bonne formule souhaité
Je vous joint le fichier en question sur le site cjoint
Merci d'avance a tous ceux qui voudront bien plancher a ma place :o)
Anne
http://cjoint.com/?lnt6mmizRo


"Philippe.R" news:
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et
suivant, vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur
j'ai plusieurs choses de marquer sur une ligne genre (n° de tel + email
+adresse etc...) et dans la derniere colonne j'ai une liste deroulante
avec plusieurs choix (genre X et Y) je voudrais mettre la meme ligne
sur la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a le
X sur la feuille 2
Merci d'avance de votre aide













anne & greg
Le #5049171
Merci beaucoup philippe pour ta compétence et ton aide
Je suis heureuse, beaucoup moins de recopiage a faire grace à toi ;o)
Mais y a t il des sites sur le net ou tu peux apprendre les formules ??
Salutations
A.RODRIGUEZ


"Philippe.R" ewJj$
Re,
Petite précision, mieux vaut, lors de la recopie, utiliser le collage
spécial / formule (Alt + e, Alt + g, Alt + u , "Entrée", "Echap"),
histoire de conserver les formats.
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Philippe.R" news:
Bonsoir,
La formule sera donc plutôt celle ci, à coller en A3 du tableau de
Feuille2 et à recopier vers la droite et vers le bas :

=SI(OU(Feuille1!$H3<>"X";Feuille1!A3="");"";Feuille1!A3)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4739f487$0$5088$
Désolé mais ce n'est pas la bonne formule souhaité
Je vous joint le fichier en question sur le site cjoint
Merci d'avance a tous ceux qui voudront bien plancher a ma place :o)
Anne
http://cjoint.com/?lnt6mmizRo


"Philippe.R" news:
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et
suivant, vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur
j'ai plusieurs choses de marquer sur une ligne genre (n° de tel +
email +adresse etc...) et dans la derniere colonne j'ai une liste
deroulante avec plusieurs choix (genre X et Y) je voudrais mettre la
meme ligne sur la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a
le X sur la feuille 2
Merci d'avance de votre aide
















perso
Le #5049101
Bonjour Anne,

suite à ta demande en ma BAL (ne pas utiliser, préférence au forum) je
te donne un code testé sur ton fichier:

Copier les 2 modules de codes à l'endroit indiqué, ensuite il suffit
de double cliquer sur une cellule de LA LIGNE A COPIER, elle sera
automatiquement copiée dans la seconde page
A la fin une boite de dialogue donne la confirmation de la réussite de
l'opération

'Attention ne pas oublier de mettre ce code dans la feuille avant
d'utiliser le code CopieLigneS...
Pour cela clique droit sur l'onglet de la première feuille puis «
visualiser le code »


Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel
As Boolean)
CopieLigneSurFeuilleSuivante
End Sub

'Puis mettre dans un module normal:

Sub CopieLigneSurFeuilleSuivante()

If ActiveSheet.Index = Sheets.Count Then Exit Sub
On Error GoTo GestErr

ActiveCell.EntireRow.Copy
Sheets(ActiveSheet.Index + 1).Select
Range("A65536").End(xlUp).Offset(1, 0).Select
ActiveSheet.Paste
Application.CutCopyMode = False
Sheets(ActiveSheet.Index - 1).Select
ActiveCell.Offset(1, 0).Select

MsgBox "La ligne " & ActiveCell.Row - 1 & " a été copiée dans l'onglet
" & Sheets(ActiveSheet.Index + 1).Name, vbInformation
Exit Sub

GestErr: MsgBox Err.Description, vbCritical, "Erreur de procédure"

End Sub

Qu'en penses-tu ?

Bonne utilisation

Pat REDNEF
Philippe.R
Le #5048631
Bonsoir Anne,
Les meilleurs amis pour explorer les fonctions d'Excel et leurs
possibilités, restent le clic sur le signe "=" ou "f(x)" situés à côté de la
barre de formules et la touche F1 pour appeler l'aide.
En outre, la lecture régulière de ce forum, accompagnée de tests des
formules proposées permettent d'en apprendre beaucoup.
Tu as en outre la FAQ du forum : http://dj.joss.free.fr/faq.htm
qui fourni des liens vers différents sites : http://dj.joss.free.fr/lien.htm
et une bibliographie : http://dj.joss.free.fr/faq.htm#lecteur
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:473aeb2b$0$27374$
Merci beaucoup philippe pour ta compétence et ton aide
Je suis heureuse, beaucoup moins de recopiage a faire grace à toi ;o)
Mais y a t il des sites sur le net ou tu peux apprendre les formules ??
Salutations
A.RODRIGUEZ


"Philippe.R" ewJj$
Re,
Petite précision, mieux vaut, lors de la recopie, utiliser le collage
spécial / formule (Alt + e, Alt + g, Alt + u , "Entrée", "Echap"),
histoire de conserver les formats.
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Philippe.R" news:
Bonsoir,
La formule sera donc plutôt celle ci, à coller en A3 du tableau de
Feuille2 et à recopier vers la droite et vers le bas :

=SI(OU(Feuille1!$H3<>"X";Feuille1!A3="");"";Feuille1!A3)
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4739f487$0$5088$
Désolé mais ce n'est pas la bonne formule souhaité
Je vous joint le fichier en question sur le site cjoint
Merci d'avance a tous ceux qui voudront bien plancher a ma place :o)
Anne
http://cjoint.com/?lnt6mmizRo


"Philippe.R" news:
Bonsoir,
Si j'ai bien compris...
En supposant les x et y en colonne G, dans la feuille 2, en a1 et
suivant, vers la droite et vers le bas

=SI(Feuil1!$G1="X";Feuil1!A1;"")

à moins que ce ne soit (si je n'ai pas compris du 1er coup)

=SI($G1="X";Feuil1!A1;"")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"anne & greg" news:4738aa06$0$25948$
Bonsoir à tous,
Voila je suis devant un dilemne en faits je suis devant mon classeur
j'ai plusieurs choses de marquer sur une ligne genre (n° de tel +
email +adresse etc...) et dans la derniere colonne j'ai une liste
deroulante avec plusieurs choix (genre X et Y) je voudrais mettre la
meme ligne sur la feuille n°2 qui contient le X
C'est a dire reporter les lignes entieres de la feuille 1 ou ils y a
le X sur la feuille 2
Merci d'avance de votre aide




















Publicité
Poster une réponse
Anonyme