Problème avec formule pour exclure d'un décompte les samedis et dimanches...

Le
François
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
alexandre-dit le jeune
Le #4590531
Bonjour,
je ne comprends pas très bien votre problème mais pouvez-vous envoyez votre
fichier par C-Joint ?
Cordialement,
Alexandre

"François" news:
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François






JB
Le #4590521
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaq ue
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 p ar
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2 );2)>5­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François


François
Le #4590511
Voici le fichier :

http://cjoint.com/?gptnubzoFk

"alexandre-dit le jeune" news:
Bonjour,
je ne comprends pas très bien votre problème mais pouvez-vous envoyez
votre fichier par C-Joint ?
Cordialement,
Alexandre

"François" news:
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de
prendre en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François









François
Le #4590491
Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la fonction
ne détecte toujours aucun des jours où il y a un X de coché (miniuscule
comme majuscule) ?

cf. le fichier en Cjoint :
http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François


JB
Le #4590471
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);
2)<6))

http://cjoint.com/?gptywGFofV

JB

On 15 juin, 19:19, "François"
Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la fonction
ne détecte toujours aucun des jours où il y a un X de coché (minius cule
comme majuscule) ?

cf. le fichier en Cjoint :http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"


Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par ch aque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure d e ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid d e prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF $2);2)>5­­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



JB
Le #4590461
http://boisgontierjacques.free.fr/fichiers/Dates/PlanningColoriageBarre.xls
http://boisgontierjacques.free.fr/fichiers/Dates/PlanningColoriageSaisieLet tre.xls
http://boisgontierjacques.free.fr/fichiers/jb-planningmensuelmacro.zip

JB

On 15 juin, 19:19, "François"
Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la fonction
ne détecte toujours aucun des jours où il y a un X de coché (minius cule
comme majuscule) ?

cf. le fichier en Cjoint :http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"


Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par ch aque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure d e ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid d e prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF $2);2)>5­­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



François
Le #4590441
Superbe !

Petite question subsidiaire ...

Quand FAUT-il passer en validation matricielle ?

Merci pour ton coup de pouce significatif !...

François

"JB"

=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);
2)<6))

http://cjoint.com/?gptywGFofV

JB

On 15 juin, 19:19, "François"
Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la fonction
ne détecte toujours aucun des jours où il y a un X de coché (miniuscule
comme majuscule) ?

cf. le fichier en Cjoint :http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"


Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de
ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de
prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5­­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



JB
Le #4590421
SommeProd() est une fonction matricielle implicite (validation
simple).
Mais elle ne fonctionne pas toujours; il faut alors valider avec Maj
+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/jb-FonctionsMatricielles.zip

JB http://boisgontierjacques.free.fr/

On 15 juin, 20:22, "François"
Superbe !

Petite question subsidiaire ...

Quand FAUT-il passer en validation matricielle ?

Merci pour ton coup de pouce significatif !...

François

"JB"

=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2 );
2)<6))

http://cjoint.com/?gptywGFofV

JB

On 15 juin, 19:19, "François"


Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la fonct ion
ne détecte toujours aucun des jours où il y a un X de coché (mini uscule
comme majuscule) ?

cf. le fichier en Cjoint :http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, e t en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de
ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/ 07 par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de
prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2: AF$2);2)>5­­­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




François
Le #4590381
OK

Grand merci pour le coup de "clavier" !

François

"JB"
SommeProd() est une fonction matricielle implicite (validation
simple).
Mais elle ne fonctionne pas toujours; il faut alors valider avec Maj
+Ctrl+Entrée

http://boisgontierjacques.free.fr/fichiers/jb-FonctionsMatricielles.zip

JB http://boisgontierjacques.free.fr/

On 15 juin, 20:22, "François"
Superbe !

Petite question subsidiaire ...

Quand FAUT-il passer en validation matricielle ?

Merci pour ton coup de pouce significatif !...

François

"JB"

=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);
2)<6))

http://cjoint.com/?gptywGFofV

JB

On 15 juin, 19:19, "François"


Bonjour JB,

Effectivement l'usage de Dates simplifie bien la formule, mais la
fonction
ne détecte toujours aucun des jours où il y a un X de coché (miniuscule
comme majuscule) ?

cf. le fichier en Cjoint :http://cjoint.com/?gptnubzoFk

François

"JB"
Bonsoir,

=SOMMEPROD((B2:AF2="x")*(JOURSEM(dates;2)<6))

JB

On 15 juin, 18:48, "François"
Bonjour à tous,

J'ai un tableau avec de B1 à AF1, les numéros de jours du mois, et en
ordonné de A3 à A14 le nom de personnes.
(N.B. pour juin qui ne compte que 30 jours, la cellule AF3 est alors
vide...)
Lorsqu'une personne part en vacances, je mets manuellement un"X" sur
la
ligne du salarié, à toutes les dates de non présence...
Enfin, de AG3 à AG14, j'ai le total des jours de congés pris par
chaque
personne.
La formule NBVAL(B3:AF3) me donne ce résultat. Sans problème.

Mais je n'arrive pas à trouver la formule qui me permette d'exclure de
ce
calcul les samedis et les dimanches ?
J'ai essayé :
=NB.SI(B3:AF3;JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5)
(N.B. j'ai en A1 un jour quelquonque du mois considéré, le 06/06/07
par
exemple)
par exemple). Mais cela ne détecte aucun X (résultat = 0). Quid de
prendre
en compte le côté samedi ou dimanche !
J'ai essayé :
=SOMMEPROD((B3:AF3="X")*(JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);B$2:AF$2);2)>5­­­))
Même résultat erroné !
Le fait de rajouter *1 à la fin ne change rien à l'affaire.

Où est mon erreur ?
Dois-je recourrir à une formule matricielle (plus lourde!) ?

Merci à tous

François- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -




Modeste
Le #4590281
Bonsour® JB avec ferveur ;o))) vous nous disiez :

SommeProd() est une fonction matricielle implicite (validation
simple).
Mais elle ne fonctionne pas toujours; il faut alors valider avec Maj
+Ctrl+Entrée


???????????
simple curiosité : exemples ??

--
--
@+
;o)))

Publicité
Poster une réponse
Anonyme