Probleme avec formule Si et index Equiv

Le
Aiwa
Bonjour j'ai un petit probleme a trouver une formule avec / si / Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #5140201
bonjour Aiwa,

il manque un argument "Valeur_Chercher" à la formule suivante :

=SI(H6="";"";INDEX(B3:B33;EQUIV(Valeur_Chercher;A3:A33;0)))

isabelle

Bonjour j'ai un petit probleme a trouver une formule avec / si / Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide


Aiwa
Le #5288291
Rebonjour Isabelle j'ai essayer ta formule en H3 dans mon fichier et ca
marche pas, aussi a tu une idée pour la formule que je doit mettre en F3
selon condition que j'ai inscrit sur le fichier ci-joint

Merci encore


bonjour Aiwa,

il manque un argument "Valeur_Chercher" à la formule suivante :

=SI(H6="";"";INDEX(B3:B33;EQUIV(Valeur_Chercher;A3:A33;0)))

isabelle

Bonjour j'ai un petit probleme a trouver une formule avec / si / Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide





isabelle
Le #5288271
bonjour Aiwa,

F3 : =SI(H3<=5;INDEX(B3:B33;EQUIV(F6;A3:A33;0));INDEX(C3:C33;EQUIV(F6;A3:A33;0)))

H3 : =SI(H6="";"";INDEX(B3:B33;EQUIV(H6;A3:A33;0)))

http://cjoint.com/?bBri2NoVOQ

isabelle

Rebonjour Isabelle j'ai essayer ta formule en H3 dans mon fichier et ca
marche pas, aussi a tu une idée pour la formule que je doit mettre en F3
selon condition que j'ai inscrit sur le fichier ci-joint

Merci encore


bonjour Aiwa,

il manque un argument "Valeur_Chercher" à la formule suivante :

=SI(H6="";"";INDEX(B3:B33;EQUIV(Valeur_Chercher;A3:A33;0)))

isabelle

Bonjour j'ai un petit probleme a trouver une formule avec / si / Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide






isabelle
Le #5288251
ps/

j'ai modifié les données pour tout remettre en numérique,
car il y avait un mélange de chiffre en numérique et en texte.

isabelle

bonjour Aiwa,

F3 :
=SI(H3<=5;INDEX(B3:B33;EQUIV(F6;A3:A33;0));INDEX(C3:C33;EQUIV(F6;A3:A33;0)))


H3 : =SI(H6="";"";INDEX(B3:B33;EQUIV(H6;A3:A33;0)))

http://cjoint.com/?bBri2NoVOQ

isabelle

Rebonjour Isabelle j'ai essayer ta formule en H3 dans mon fichier et
ca marche pas, aussi a tu une idée pour la formule que je doit mettre
en F3 selon condition que j'ai inscrit sur le fichier ci-joint

Merci encore


bonjour Aiwa,

il manque un argument "Valeur_Chercher" à la formule suivante :

=SI(H6="";"";INDEX(B3:B33;EQUIV(Valeur_Chercher;A3:A33;0)))

isabelle

Bonjour j'ai un petit probleme a trouver une formule avec / si /
Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide








Aiwa
Le #5287501
Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir

Merci beaucoup encore


ps/

j'ai modifié les données pour tout remettre en numérique,
car il y avait un mélange de chiffre en numérique et en texte.

isabelle

bonjour Aiwa,

F3 :
=SI(H3<=5;INDEX(B3:B33;EQUIV(F6;A3:A33;0));INDEX(C3:C33;EQUIV(F6;A3:A33;0)))


H3 : =SI(H6="";"";INDEX(B3:B33;EQUIV(H6;A3:A33;0)))

http://cjoint.com/?bBri2NoVOQ

isabelle

Rebonjour Isabelle j'ai essayer ta formule en H3 dans mon fichier et
ca marche pas, aussi a tu une idée pour la formule que je doit mettre
en F3 selon condition que j'ai inscrit sur le fichier ci-joint

Merci encore


bonjour Aiwa,

il manque un argument "Valeur_Chercher" à la formule suivante :

=SI(H6="";"";INDEX(B3:B33;EQUIV(Valeur_Chercher;A3:A33;0)))

isabelle

Bonjour j'ai un petit probleme a trouver une formule avec / si /
Index et Equiv
je ne veut pas utiliser de macro.
adresse de mon fichier http://cjoint.com/?bBavvWAqxi



Merci a l'avance de votre aide











isabelle
Le #5287401
bonjour aiwa,

Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1


oui il faut mettre ces cellules au format personnalisé 00

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir


tu pourrais ajouter cette macro sur la page code de la feuille :

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set plg1 = Application.Intersect(Target(1), Range("F6"))
Set plg2 = Application.Intersect(Target(1), Range("H6"))
If Not plg1 Is Nothing Or Not plg2 Is Nothing Then
If IsError(Application.Match(Target(1), Range("A4:A33"), 0)) Then
Target.Value = 0
MsgBox "Cette valeur n'est pas authorisée"
End If
End If
Err.Clear
End Sub

isabelle

Aiwa
Le #5287371
Rebonjour Encore moi , le programme que je fait cest pour interprété une
lecture de compteur électrique qui fonctionne avec des aiguille et numéroté
de 0 à 9 , en réalité j'ai 4 cadran j'en ai mis 2 sur le fichier que j'ai mis
pcq les 2 autres les formule va etre pareil.
Pour réponse 1 tu me donne
oui il faut mettre ces cellules au format personnalisé 00
le probleme est qu'il y a 2 possibilité on peut choisir le 09 et le 9
le 09 indique que l'éguille est situer en le 0 et le 9 et le 9 indique que
l'éguille du compteur est sur le 9 exactement , car la réponse est pas le
meme
09 = 9 meme si < ou > 5
et le 9 = 9 si < 5 et 8 si > que 5

et pour question 2
SAns macro est-ce possible

Merci encore de ton aide et ta patience.





bonjour aiwa,

Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1


oui il faut mettre ces cellules au format personnalisé 00

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir


tu pourrais ajouter cette macro sur la page code de la feuille :

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set plg1 = Application.Intersect(Target(1), Range("F6"))
Set plg2 = Application.Intersect(Target(1), Range("H6"))
If Not plg1 Is Nothing Or Not plg2 Is Nothing Then
If IsError(Application.Match(Target(1), Range("A4:A33"), 0)) Then
Target.Value = 0
MsgBox "Cette valeur n'est pas authorisée"
End If
End If
Err.Clear
End Sub

isabelle




isabelle
Le #5287341
bonjour Aiwa,

dans ce cas tu n'as pas le choix de remettre tout en format texte (sauf F3 et H3 pour les formules)
et pour la question 2, le seul autre choix que je voie serait une liste de validation.

isabelle

Rebonjour Encore moi , le programme que je fait cest pour interprété une
lecture de compteur électrique qui fonctionne avec des aiguille et numéroté
de 0 à 9 , en réalité j'ai 4 cadran j'en ai mis 2 sur le fichier que j'ai mis
pcq les 2 autres les formule va etre pareil.
Pour réponse 1 tu me donne
oui il faut mettre ces cellules au format personnalisé 00
le probleme est qu'il y a 2 possibilité on peut choisir le 09 et le 9
le 09 indique que l'éguille est situer en le 0 et le 9 et le 9 indique que
l'éguille du compteur est sur le 9 exactement , car la réponse est pas le
meme
09 = 9 meme si < ou > 5
et le 9 = 9 si < 5 et 8 si > que 5

et pour question 2
SAns macro est-ce possible

Merci encore de ton aide et ta patience.





bonjour aiwa,

Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1
oui il faut mettre ces cellules au format personnalisé 00

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir
tu pourrais ajouter cette macro sur la page code de la feuille :


Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set plg1 = Application.Intersect(Target(1), Range("F6"))
Set plg2 = Application.Intersect(Target(1), Range("H6"))
If Not plg1 Is Nothing Or Not plg2 Is Nothing Then
If IsError(Application.Match(Target(1), Range("A4:A33"), 0)) Then
Target.Value = 0
MsgBox "Cette valeur n'est pas authorisée"
End If
End If
Err.Clear
End Sub

isabelle






Aiwa
Le #5287301
Allo
Question 1 Si je met en format texte sauf F3 et H3 quand j'entre des
chiffre en F5 ou H6 ca donne #N/A

Question 2 dans validation ce que je peut voir faut entrer une formule car
cest pas une série de chiffre qui ce suit, le probleme je ne sais pas comment
formuler la formule pour mettre dedans

Merci de ta patience et ton aide qui est vraiement apprécié




bonjour Aiwa,

dans ce cas tu n'as pas le choix de remettre tout en format texte (sauf F3 et H3 pour les formules)
et pour la question 2, le seul autre choix que je voie serait une liste de validation.

isabelle

Rebonjour Encore moi , le programme que je fait cest pour interprété une
lecture de compteur électrique qui fonctionne avec des aiguille et numéroté
de 0 à 9 , en réalité j'ai 4 cadran j'en ai mis 2 sur le fichier que j'ai mis
pcq les 2 autres les formule va etre pareil.
Pour réponse 1 tu me donne
oui il faut mettre ces cellules au format personnalisé 00
le probleme est qu'il y a 2 possibilité on peut choisir le 09 et le 9
le 09 indique que l'éguille est situer en le 0 et le 9 et le 9 indique que
l'éguille du compteur est sur le 9 exactement , car la réponse est pas le
meme
09 = 9 meme si < ou > 5
et le 9 = 9 si < 5 et 8 si > que 5

et pour question 2
SAns macro est-ce possible

Merci encore de ton aide et ta patience.





bonjour aiwa,

Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1
oui il faut mettre ces cellules au format personnalisé 00

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir
tu pourrais ajouter cette macro sur la page code de la feuille :


Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set plg1 = Application.Intersect(Target(1), Range("F6"))
Set plg2 = Application.Intersect(Target(1), Range("H6"))
If Not plg1 Is Nothing Or Not plg2 Is Nothing Then
If IsError(Application.Match(Target(1), Range("A4:A33"), 0)) Then
Target.Value = 0
MsgBox "Cette valeur n'est pas authorisée"
End If
End If
Err.Clear
End Sub

isabelle









isabelle
Le #5287291
bonjour Aiwa,

voici un nouveau fichier avec liste de validation :

http://cjoint.com/?bCrL1roO3C

isabelle

Allo
Question 1 Si je met en format texte sauf F3 et H3 quand j'entre des
chiffre en F5 ou H6 ca donne #N/A

Question 2 dans validation ce que je peut voir faut entrer une formule car
cest pas une série de chiffre qui ce suit, le probleme je ne sais pas comment
formuler la formule pour mettre dedans

Merci de ta patience et ton aide qui est vraiement apprécié




bonjour Aiwa,

dans ce cas tu n'as pas le choix de remettre tout en format texte (sauf F3 et H3 pour les formules)
et pour la question 2, le seul autre choix que je voie serait une liste de validation.

isabelle

Rebonjour Encore moi , le programme que je fait cest pour interprété une
lecture de compteur électrique qui fonctionne avec des aiguille et numéroté
de 0 à 9 , en réalité j'ai 4 cadran j'en ai mis 2 sur le fichier que j'ai mis
pcq les 2 autres les formule va etre pareil.
Pour réponse 1 tu me donne
oui il faut mettre ces cellules au format personnalisé 00
le probleme est qu'il y a 2 possibilité on peut choisir le 09 et le 9
le 09 indique que l'éguille est situer en le 0 et le 9 et le 9 indique que
l'éguille du compteur est sur le 9 exactement , car la réponse est pas le
meme
09 = 9 meme si < ou > 5
et le 9 = 9 si < 5 et 8 si > que 5

et pour question 2
SAns macro est-ce possible

Merci encore de ton aide et ta patience.





bonjour aiwa,

Rebonjour et merci encore de ton aide, j'aurais 2 petit chose si je peut te
déranger encore. Le fichier que je fait avec ton grand aide bien sure cest
pour interprété des lecture de compteur chiffre compris entre 0 et 9 le 0

1- En H6 et F6 Je sais que tu a mis sa numérique mais cest tu possible quand
on inscrit 01 et 09 qu'on voit le 0, car en réalité sa dit que l'éguille est
entre le 0 et le 9 ou entre le 0 et 1
oui il faut mettre ces cellules au format personnalisé 00

2- Peut-on mettre un condition pour quand H6 et F6 on entre autre chose dans
la colonne liste qu'on est un pop up qui dit entré invalide, je suis capable
faire des condition mais j'en ai jamais fait qui fait référence a une liste.
En H6 et F6 je ne veut pas avoir une liste pour choisir
tu pourrais ajouter cette macro sur la page code de la feuille :


Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Set plg1 = Application.Intersect(Target(1), Range("F6"))
Set plg2 = Application.Intersect(Target(1), Range("H6"))
If Not plg1 Is Nothing Or Not plg2 Is Nothing Then
If IsError(Application.Match(Target(1), Range("A4:A33"), 0)) Then
Target.Value = 0
MsgBox "Cette valeur n'est pas authorisée"
End If
End If
Err.Clear
End Sub

isabelle










Publicité
Poster une réponse
Anonyme