problème avec GRUB

Le
Gilles Guiot
Bonjour à tous,

étant un grand débutant sous linux, j'ai un petit souci. je dispose d'un
serveur sous debian avec deux raid array sda et sdb (raid 1 pour les
deux). j'ai monté un lvm sur le second (sdb), et copié le file system de
sda vers sdb. je souhaite maintenant booter sur le second raid array et
lorsque je veux paramétrer grub pour cela :
grub> root (sdb,0) j'ai le message d'erreur syntax error near unexpected
token'('.
qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
suivre ?
Merci d'avance.

--
Gilles Guiot
Responsable exploitation informatique
Tél. : 01 53 23 02 20
gilles.guiot@saros.fr

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pascatgm
Le #9673701
Gilles Guiot a écrit :
Bonjour à tous,


salut

étant un grand débutant sous linux, j'ai un petit souci. je dispose
d'un serveur sous debian avec deux raid array sda et sdb (raid 1 pour
les deux). j'ai monté un lvm sur le second (sdb), et copié le file
system de sda vers sdb. je souhaite maintenant booter sur le second
raid array et lorsque je veux paramétrer grub pour cela :
grub> root (sdb,0) j'ai le message d'erreur syntax error near
unexpected token'('.
qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
suivre ?
Merci d'avance.




ton menu.lst (du moins les parties non commentées et pertinentes)
pourrait nous aider à te répondre.

P.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Klaus Becker
Le #9673691
Am Donnerstag, 15. Mai 2008 12:46 schrieb pascatgm:
Gilles Guiot a écrit :
> Bonjour à tous,

salut

> étant un grand débutant sous linux, j'ai un petit souci. je dispose
> d'un serveur sous debian avec deux raid array sda et sdb (raid 1 pour
> les deux). j'ai monté un lvm sur le second (sdb), et copié le file
> system de sda vers sdb. je souhaite maintenant booter sur le second
> raid array et lorsque je veux paramétrer grub pour cela :
> grub> root (sdb,0) j'ai le message d'erreur syntax error near
> unexpected token'('.



c'est pas grub> root (hd1,0) ?

voir
http://www.linux-france.org/article/sys/chargeurs/ix86/grub/grub-manual-fr. html#Convention%20de%20nommage

Klaus

> qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
> suivre ?
> Merci d'avance.

ton menu.lst (du moins les parties non commentées et pertinentes)
pourrait nous aider à te répondre.

P.



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
HGrac
Le #9673651
Gilles Guiot a écrit :
Bonjour à tous,

étant un grand débutant sous linux, j'ai un petit souci. je dispose
d'un serveur sous debian avec deux raid array sda et sdb (raid 1 pour
les deux). j'ai monté un lvm sur le second (sdb), et copié le file
system de sda vers sdb. je souhaite maintenant booter sur le second
raid array et lorsque je veux paramétrer grub pour cela :
grub> root (sdb,0) j'ai le message d'erreur syntax error near
unexpected token'('.
qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
suivre ?
Merci d'avance.



j'ai dans menu.list :

root (hd0, 1) pour mon système linux installé en /hda2 et
root (hd0,0) pour winXp installé en hda1.

il me semble que que
root (sd1,0) devrait convenir

j'ai pu vérifier (man grub est très discret la dessus)

hgrac

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
GiGGz
Le #9673641
HGrac a écrit :
Gilles Guiot a écrit :
Bonjour à tous,






slt
étant un grand débutant sous linux, j'ai un petit souci. je dispose
d'un serveur sous debian avec deux raid array sda et sdb (raid 1 pour
les deux). j'ai monté un lvm sur le second (sdb), et copié le file
system de sda vers sdb. je souhaite maintenant booter sur le second
raid array et lorsque je veux paramétrer grub pour cela :
grub> root (sdb,0) j'ai le message d'erreur syntax error near
unexpected token'('.
qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
suivre ?
Merci d'avance.



j'ai dans menu.list :

root (hd0, 1) pour mon système linux installé en /hda2 et
root (hd0,0) pour winXp installé en hda1.

il me semble que que
root (sd1,0) devrait convenir




je connais po grand chose à grub. mais il faut que le "device" mis entre
parenthese corresponde à ce qu'il y a dans le .map situé dans /boot/grub/

moi par exemple avant le passage au 2.6.19 mes disques IDE étaient en
hd*, donc lors de l'install de grub mon device map contenait des hd*.
Ensuite qd je suis passé à l'émulation SATA pour les disques IDE, mes
devices sont devenus sd* mais mon .map de grub contenait tjs des hd* et
donc dans le menu.lst j'avais aussi des hd*. maintenant j'ai tout
changé, je suis en sd* partout...

en bref regarde dans le .map

j'ai pu vérifier (man grub est très discret la dessus)

hgrac




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Michel OLTRA
Le #9673631
Bonjour,


Le jeudi 15 mai 2008, Gilles Guiot a écrit...


lorsque je veux paramétrer grub pour cela :
grub> root (sdb,0) j'ai le message d'erreur syntax error near unexpected
token'('.
qqun aurait-il la gentillesse de m'indiquer mon erreur et la marche à
suivre ?



Je pense que c'est hdX qu'il faut mettre, avec X étant une référence au
disque qui contient /boot, et l'entier ensuite (ce que tu as mis à 0),
étant l'index commençant à 0 pour le numéro de cette partition. Donc
root(hd0, 0) signifie « /boot est sur la partition 1 du premier
disque ». Peut importe si c'est un sd ou un hd. Et je me demande bien
également si il ne faut pas supprimer l'espace située entre le « root »
et le « (hdX, N) »

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9673621
Jean-Michel OLTRA a écrit :
Je pense que c'est hdX qu'il faut mettre, avec X étant une référence au
disque qui contient /boot, et l'entier ensuite (ce que tu as mis à 0),
étant l'index commençant à 0 pour le numéro de cette partition. Donc
root(hd0, 0) signifie « /boot est sur la partition 1 du premier
disque ». Peut importe si c'est un sd ou un hd. Et je me demande bien
également si il ne faut pas supprimer l'espace située entre le « root »
et le « (hdX, N) »




Oui. Je pense également qu'il faut mettre hd1 si on veut booter sur le
second disque et 0 si c'est la première partition. A condition d'avoir un
(hd1) /dev/sdb
dans le device.map.
Par contre je n'ai pas trop compris d'où vient le raid puisqu'il est
mentionné une copie du système de fichier de sda vers sdb. D ans ce cas
d'où vient le MBR du second disque ?

P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Gilles Guiot
Le #9673611
Merci pour toutes les réponses.
J'ai modifié le fichier menu.lst en remplaçant dans la partie non
commentée hd0 par hd1.
Au redémarrage, grub propose bien les disques hd0 et hd1 mais il indique
que le filesystem est inconnu sur hd1. Même si je n'ai pas réussi à
trouver de hard data là dessus, j'ai lu qu'il ya vait des problèmes pour
que GRUB gère les LVM.
Si qqun a plus d'infos là dessus ?
ps : dans device map, mon hd1 n'apparaît pas.... pourtant il est monté,
je travaille dessus et pour ce qui est du raid, il y a deux raids array,
sur une carte perc6.




Merci d'avance.



pascatgm a écrit :
Jean-Michel OLTRA a écrit :
Je pense que c'est hdX qu'il faut mettre, avec X étant une référence au
disque qui contient /boot, et l'entier ensuite (ce que tu as mis à 0),
étant l'index commençant à 0 pour le numéro de cette partition. Donc
root(hd0, 0) signifie « /boot est sur la partition 1 du premier
disque ». Peut importe si c'est un sd ou un hd. Et je me demande bien
également si il ne faut pas supprimer l'espace située entre le « root »
et le « (hdX, N) »




Oui. Je pense également qu'il faut mettre hd1 si on veut booter sur le
second disque et 0 si c'est la première partition. A condition d'avoir un
(hd1) /dev/sdb
dans le device.map.
Par contre je n'ai pas trop compris d'où vient le raid puisqu'il est
mentionné une copie du système de fichier de sda vers sdb. D ans ce
cas d'où vient le MBR du second disque ?

P.





--
Gilles Guiot
Responsable exploitation informatique
Tél. : 01 53 23 02 20


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
pascatgm
Le #9673591
Gilles Guiot a écrit :
Merci pour toutes les réponses.
J'ai modifié le fichier menu.lst en remplaçant dans la partie non
commentée hd0 par hd1.
Au redémarrage, grub propose bien les disques hd0 et hd1 mais il
indique que le filesystem est inconnu sur hd1. Même si je n'ai pas
réussi à trouver de hard data là dessus, j'ai lu qu'il ya vait des
problèmes pour que GRUB gère les LVM.
Si qqun a plus d'infos là dessus ?
ps : dans device map, mon hd1 n'apparaît pas.... pourtant il est
monté, je travaille dessus et pour ce qui est du raid, il y a deux
raids array, sur une carte perc6.




Merci d'avance.





grub n'a aucun mal à gerer le lvm ...
Par contre ta partition /boot est-elle comprise dans le raid ?

Par contre pour ton contrôleur je ne connais pas trop...Si quelqu'un
dans la salle connaît...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
gilles.guiot
Le #9673581
This message is in MIME format.

--=_538nky3dlk00
Content-Type: text/plain;
charset=UTF-8;
DelSp="Yes";
format="flowed"
Content-Description: Version texte brut du message
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable



pascatgm
Gilles Guiot a écrit :
Merci pour toutes les réponses.
J'ai modifié le fichier menu.lst en remplaçant dans la partie n on 
commentée hd0 par hd1.
Au redémarrage, grub propose bien les disques hd0 et hd1 mais il  
indique que le filesystem est inconnu sur hd1. Même si je n'ai pas  
réussi à trouver de hard data là dessus, j'ai lu qu'il ya vait des 
problèmes pour que GRUB gère les LVM.
Si qqun a plus d'infos là dessus ?
ps : dans device map, mon hd1 n'apparaît pas.... pourtant il est  
monté, je travaille dessus et pour ce qui est du raid, il y a deux  
raids array, sur une carte perc6.




Merci d'avance.





grub n'a aucun mal à gerer le lvm ...
Par contre ta partition /boot est-elle comprise dans le raid ?



la sortie de fdisk -l

Disk /dev/sda: 499.5 GB, 499558383616 bytes
255 heads, 63 sectors/track, 60734 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000080

   Device Boot      Start    Â Â Â Â Â  End      Blocks    Id  System
/dev/sda1   *          Â  1       60404   485195098+   83  Linux
/dev/sda2           60405        60734     2650725     5  Extended
/dev/sda5           60405        60734     2650693+   82  Linux swap / Solaris

Disk /dev/sdb: 749.6 GB, 749606010880 bytes
255 heads, 63 sectors/track, 91134 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00097fda

   Device Boot      Start    Â Â Â Â Â  End      Blocks    Id  System
/dev/sdb1                1       91134   7 32033823+  83  Linux

Disk /dev/dm-0: 749.6 GB, 749601816576 bytes
255 heads, 63 sectors/track, 91133 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

par contre je rappelle que le premier raid array n'a pas été
installé en LVM....et donc qu'il n'y a pas eu de partion boot sépa rée
créée...

>
Par contre pour ton contrôleur je ne connais pas trop...Si quelqu'un
dans la salle connaît...
P.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact org





--=_538nky3dlk00
Content-Type: text/html;
charset=UTF-8
Content-Description: Version HTML du message
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

<p>
pascatgm &lt;&gt; a écrit:<br />
<br />
&gt; Gilles Guiot a écrit :<br />
&gt;&gt; Merci pour toutes les réponses.<br />
&gt;&gt; J'ai modifié le fichier menu.lst en remplaçant dans la pa rtie non 
<br />
&gt;&gt; commentée hd0 par hd1.<br />
&gt;&gt; Au redémarrage, grub propose bien les disques hd0 et hd1 mais il  <br
/>
&gt;&gt; indique que le filesystem est inconnu sur hd1. Même si je n'ai pas 
<br />
&gt;&gt; réussi à trouver de hard data là dessus, j'ai lu qu' il ya vait des 
<br />
&gt;&gt; problèmes pour que GRUB gère les LVM.<br />
&gt;&gt; Si qqun a plus d'infos là dessus ?<br />
&gt;&gt; ps : dans device map, mon hd1 n'apparaît pas.... pourtant il e st  <br
/>
&gt;&gt; monté, je travaille dessus et pour ce qui est du raid, il y a deux 
<br />
&gt;&gt; raids array, sur une carte perc6.<br />
&gt;&gt;<br />
&gt;&gt;<br />
&gt;&gt;<br />
&gt;&gt;<br />
&gt;&gt; Merci d'avance.<br />
&gt;&gt;<br />
&gt;&gt;<br />
&gt;&gt;<br />
&gt; grub n'a aucun mal à gerer le lvm ...<br />
&gt; Par contre ta partition /boot est-elle comprise dans le raid ?<br
/></p><p>la sortie de fdisk -l<br /><br />Disk /dev/sda: 499.5 GB, 499558383 616
bytes<br />255 heads, 63 sectors/track, 60734 cylinders<br />Units = cylin ders
of 16065 * 512 = 8225280 bytes<br />Disk identifier: 0x00000080<br /><br / >  
Device Boot      Start      Â Â Â  End      Blocks   I d 
System<br />/dev/sda1   *        Â Â Â  1       60404   
485195098+  83  Linux<br />/dev/sda2            60405      
60734     2650725    5  Extended<br />/dev/sda5          
60405       60734     2650 693+  82  Linux swap / Solaris<br /><br
/>Disk /dev/sdb: 749.6 GB, 749606010880 bytes<br />255 heads, 63 sectors/tra ck,
91134 cylinders<br />Units = cylinders of 16065 * 512 = 8225280 bytes<br />Disk
identifier: 0x00097fda<br /><br />   Device Boot      
Start         End       Blocks   Id  System<br
/>/dev/sdb1            Â Â Â  1       91134    732033823+ 
83  Linux heads, 63 sectors/track, 91133 cylinders<br />Units = cylinders of 16065 * 512 =
8225280 bytes<br />Disk identifier: 0x00000000<br /></p><p>par contre je
rappelle que le premier raid array n'a pas été installé en LV M....et donc
qu'il n'y a pas eu de partion boot séparée
créée...</p><p></p><p></p><p></p><p></p><p></p><p></p><p></p><p></ p><p></p><p>
&gt;<br />
&gt; Par contre pour ton contrôleur je ne connais pas trop...Si quelqu' un<br />
&gt; dans la salle connaît...<br />
&gt; P.<br />
&gt;<br />
&gt; -- <br />
&gt; Lisez la FAQ de la liste avant de poser une question :<br />
&gt; <a target="_blank"
href="http://wiki.debian.org/DebFrFrenchLists">http://wiki.debian.org/DebF rFrenchLists</a><br
/>
&gt; Vous pouvez aussi ajouter le mot ``spam'' dans vos champs &quot;From&qu ot;
et<br />
&gt; &quot;Reply-To:&quot;<br />
&gt;<br />
&gt; To UNSUBSCRIBE, email to <br />
&gt; with a subject of &quot;unsubscribe&quot;. Trouble? Contact
<br />
<br />
</p>
--=_538nky3dlk00--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
daniel huhardeaux
Le #9673571
a écrit :
[...]
la sortie de fdisk -l

Disk /dev/sda: 499.5 GB, 499558383616 bytes
255 heads, 63 sectors/track, 60734 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000080

Device Boot Start End Blocks Id System
/dev/sda1 * 1 60404 485195098+ 83 Linux
/dev/sda2 60405 60734 2650725 5 Extended
/dev/sda5 60405 60734 2650693+ 82 Linux swap /
Solaris

Disk /dev/sdb: 749.6 GB, 749606010880 bytes
255 heads, 63 sectors/track, 91134 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00097fda

Device Boot Start End Blocks Id System
/dev/sdb1 1 91134 732033823+ 83 Linux

Disk /dev/dm-0: 749.6 GB, 749601816576 bytes
255 heads, 63 sectors/track, 91133 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

par contre je rappelle que le premier raid array n'a pas été
installé en LVM....et donc qu'il n'y a pas eu de partion boot séparée
créée...


Si c'est du raid logiciel -mdadm- il n'y a pas de raid le system ID
devant etre fd. Si c'est du raid hard, c'est à la carte de le gérer et
on ne devrait voir apparaitre qu'un seul disque. Je doute donc fort
qu'il y ait du raid ...

Aussi, faire du raid sur deux disques/partitions n'étant pas de taille
identique me parait hasardeux, du moins en terme de perte de stockage
sur le disque le plus grand. Enfin, mettre la swap en raid est utile.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme