problème avec un logiciel

Le
Pascal
Bonjour,
je rencontre un soucis avec un logiciel qui fonctionne correctement sur un poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)
Essayant de savoir ce qui se passait j'ai testé filemon et regmon,
malheureusement ces deux logiciels renvoient énormément d'informations et je
n'arrive pas vraiment à savoir ce qui bloque.
Existe t'il un soft qui permet de tracer tout ce qui se passe au lancement d'un
executable particulier ?


merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude BELLAMY
Le #21386691
"Pascal" : 4b9f64db$0$23012$
Bonjour,
je rencontre un soucis avec un logiciel qui fonctionne correctement sur un
poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)
Essayant de savoir ce qui se passait j'ai testé filemon et regmon,
malheureusement ces deux logiciels renvoient énormément d'informations et
je
n'arrive pas vraiment à savoir ce qui bloque.
Existe t'il un soft qui permet de tracer tout ce qui se passe au lancement
d'un
executable particulier ?



"Filemon" et "Regmon", ces 2 utilitaires géniaux dus à Mark Russinovich et
Bryce Goswell, sont à présent réunis dans un outil UNIQUE, à savoir
"Procmon" (Process Monitior). C'est le plus approprié pour "tracer" un
processus.

Mais as-tu bien défini le bon filtre ?
En particulier choisir :
Process Name
is
le nom de l'exécutable à tracer
include
puis "add"

http://www.microsoft.com/france/technet/sysinternals/ProcessesAndThreads/processmonitor.mspx

--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Pascal
Le #21386811
-------- Message original --------


"Pascal" : 4b9f64db$0$23012$
Bonjour,
je rencontre un soucis avec un logiciel qui fonctionne correctement sur un
poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)
Essayant de savoir ce qui se passait j'ai testé filemon et regmon,
malheureusement ces deux logiciels renvoient énormément d'informations et
je
n'arrive pas vraiment à savoir ce qui bloque.
Existe t'il un soft qui permet de tracer tout ce qui se passe au lancement
d'un
executable particulier ?



"Filemon" et "Regmon", ces 2 utilitaires géniaux dus à Mark Russinovich et
Bryce Goswell, sont à présent réunis dans un outil UNIQUE, à savoir
"Procmon" (Process Monitior). C'est le plus approprié pour "tracer" un
processus.

Mais as-tu bien défini le bon filtre ?
En particulier choisir :
Process Name
is
le nom de l'exécutable à tracer
include
puis "add"

http://www.microsoft.com/france/technet/sysinternals/ProcessesAndThreads/processmonitor.mspx



je m'en va de ce pas essayer merci
je te tiens au courant
Pascal
Le #21387051
-------- Message original --------


"Pascal" : 4b9f64db$0$23012$
Bonjour,
je rencontre un soucis avec un logiciel qui fonctionne correctement sur un
poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)
Essayant de savoir ce qui se passait j'ai testé filemon et regmon,
malheureusement ces deux logiciels renvoient énormément d'informations et
je
n'arrive pas vraiment à savoir ce qui bloque.
Existe t'il un soft qui permet de tracer tout ce qui se passe au lancement
d'un
executable particulier ?



"Filemon" et "Regmon", ces 2 utilitaires géniaux dus à Mark Russinovich et
Bryce Goswell, sont à présent réunis dans un outil UNIQUE, à savoir
"Procmon" (Process Monitior). C'est le plus approprié pour "tracer" un
processus.

Mais as-tu bien défini le bon filtre ?
En particulier choisir :
Process Name
is
le nom de l'exécutable à tracer
include
puis "add"

http://www.microsoft.com/france/technet/sysinternals/ProcessesAndThreads/processmonitor.mspx



Malgré tout énormmément d'entrées, je n'arrive pas à voir ce qui cloche
j'ai fait une capture sur une machine ou le logiciel marche une autre sur une
machine ou le logiciel ne marche pas je ne vois pas de différences :-(

merci malgré tout pour ton aide
Pascal
Le #21387321
-------- Message original --------


"Pascal" : 4b9f64db$0$23012$
Bonjour,
je rencontre un soucis avec un logiciel qui fonctionne correctement sur un
poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)
Essayant de savoir ce qui se passait j'ai testé filemon et regmon,
malheureusement ces deux logiciels renvoient énormément d'informations et
je
n'arrive pas vraiment à savoir ce qui bloque.
Existe t'il un soft qui permet de tracer tout ce qui se passe au lancement
d'un
executable particulier ?



"Filemon" et "Regmon", ces 2 utilitaires géniaux dus à Mark Russinovich et
Bryce Goswell, sont à présent réunis dans un outil UNIQUE, à savoir
"Procmon" (Process Monitior). C'est le plus approprié pour "tracer" un
processus.

Mais as-tu bien défini le bon filtre ?
En particulier choisir :
Process Name
is
le nom de l'exécutable à tracer
include
puis "add"

http://www.microsoft.com/france/technet/sysinternals/ProcessesAndThreads/processmonitor.mspx



Bon j'ai trouvé d'ou vient le soucis mais c'est un peu obscur, je m'explique
Grace à procmon je peux voir que l'accès à cette clé est interdit :
RegOpenKey;HKCRCLSID{1833CFF0-CD7C-11D3-A099-0000B4AAE07B}LocalServer32;ACCESS DENIED;Desired
Access: Maximum Allowed

Je vais voir dans la base de registre et effectivement l'administrateur de la
machine ne peut accéder à cette clé, après un peu de gymnastique dans la base de
registre j'arrive à autoriser l'accès à cette clé pour tout le monde en control
total et effectivement le logiciel depuis fonctionne.

Ma question :

Ce poste semble un peu capricieux de la base de registre, est ce que cela peut
venir d'une restriction quelconque?
J'ai une image ghost de cette machine, y a t'il moyen de remettre la base de
registre dans un état correct une fois l'image ghost déployée ou bien ...... une
réinstall s'impose ?

merci pour vos réponses
Jean-Claude BELLAMY
Le #21387311
"Pascal" : 4b9f9f94$0$16634$
[...]
je rencontre un soucis avec un logiciel qui fonctionne correctement sur
un
poste
mais pas sur un autre. (tous les deux a priori identiques en XP sp2)




[...]
Malgré tout énormmément d'entrées, je n'arrive pas à voir ce qui cloche
j'ai fait une capture sur une machine ou le logiciel marche une autre sur
une
machine ou le logiciel ne marche pas je ne vois pas de différences :-(



Et si tu nous disais un peu plus précisément ce qui ne fonctionne pas sur
l'une des machines ?
Ici, il n'y pas de devins extra-lucides ! ;-)


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP]
http://www.bellamyjc.org ou http://jc.bellamy.free.fr
Lou Ravi
Le #21388151
Pascal wrote:

Ce poste semble un peu capricieux de la base de registre, est ce que
cela peut
venir d'une restriction quelconque?
J'ai une image ghost de cette machine, y a t'il moyen de remettre la
base de
registre dans un état correct une fois l'image ghost déployée ou bien
...... une
réinstall s'impose ?

merci pour vos réponses



Si tu veux dire remettre la base de registres comme elle est actuellement,
il suffit de faire une sauvegarde de ladite base (à partir de Regedit par
exemple où un autre programme qui le fait) puis de la remettre après via un
double-clic sur le fichier *.reg ainsi créé ou via le menu 'Importer' de
Regedit
Pascal
Le #21388271
Le 16/03/2010 19:01, Lou Ravi a écrit :
Pascal wrote:

Ce poste semble un peu capricieux de la base de registre, est ce que
cela peut
venir d'une restriction quelconque?
J'ai une image ghost de cette machine, y a t'il moyen de remettre la
base de
registre dans un état correct une fois l'image ghost déployée ou bien
...... une
réinstall s'impose ?

merci pour vos réponses



Si tu veux dire remettre la base de registres comme elle est actuellement,
il suffit de faire une sauvegarde de ladite base (à partir de Regedit par
exemple où un autre programme qui le fait) puis de la remettre après via un
double-clic sur le fichier *.reg ainsi créé ou via le menu 'Importer' de
Regedit




l'idée était plutot de résoudre ces problèmes de permission
p-reine
Le #21388331
Pascal a écrit :

Si tu veux dire remettre la base de registres comme elle est actuellement,
il suffit de faire une sauvegarde de ladite base (à partir de Regedit par
exemple où un autre programme qui le fait) puis de la remettre après via un
double-clic sur le fichier *.reg ainsi créé ou via le menu 'Importer' de
Regedit




l'idée était plutot de résoudre ces problèmes de permission



Comme te l'a déjà signalé JCB, il est très difficile de t'aider dans
cette voie puisque tu te montres avare de renseignements. Si le
logiciel dont tu parles (lequel, que fait-il, quand, etc.) tourne sur
une machine et pas l'autre alors que l'environnement paraît semblable
c'est sûrement une histoire de paramétrage mais où ?
Il s'agit peut-être d'un problème de mise à jour.
Il s'agit peut-être d'un problème de service.
Il s'agit peut-être d'un problème de périphérique.
Il s'agit peut-être d'un problème de ceci.
Il s'agit peut-être d'un problème de cela.
Ou encore d'autre chose.

--
pr
Az Sam
Le #21388371
"Pascal" 4b9fa603$0$7198$

J'ai une image ghost de cette machine, y a t'il moyen de remettre la base
de
registre dans un état correct une fois l'image ghost déployée ou bien
...... une
réinstall s'impose ?



Salut,

tu peux utiliser ce fixit pour remettre les droits d'acces d'applombs dans
le registre.
Ca ne resoud pas tout mais ca aide dans pas mal de cas.
http://support.microsoft.com/kb/313222

--
Cordialement,
Az Sam.
Pascal
Le #21388581
Le 16/03/2010 19:29, p-reine a écrit :
Pascal a écrit :

Si tu veux dire remettre la base de registres comme elle est actuellement,
il suffit de faire une sauvegarde de ladite base (à partir de Regedit par
exemple où un autre programme qui le fait) puis de la remettre après via un
double-clic sur le fichier *.reg ainsi créé ou via le menu 'Importer' de
Regedit




l'idée était plutot de résoudre ces problèmes de permission



Comme te l'a déjà signalé JCB, il est très difficile de t'aider dans
cette voie puisque tu te montres avare de renseignements. Si le
logiciel dont tu parles (lequel, que fait-il, quand, etc.) tourne sur
une machine et pas l'autre alors que l'environnement paraît semblable
c'est sûrement une histoire de paramétrage mais où ?
Il s'agit peut-être d'un problème de mise à jour.
Il s'agit peut-être d'un problème de service.
Il s'agit peut-être d'un problème de périphérique.
Il s'agit peut-être d'un problème de ceci.
Il s'agit peut-être d'un problème de cela.
Ou encore d'autre chose.



Difficile de donner plus de renseignements dans la mesure ou il s'agit
d'un logiciel peu connu mais bon
il s'agit de reflex business english (apprentissage de l'anglais)
suite aux conseils de JCB j'ai "découvert" qu'il s'agissait d'une clé de
la base de registre qui n'avait pas les bonnes permissions
cf post plus haut
du coup ma question est comment remettre en état ces permissions qui se
sont "déréglées" je ne sais pourquoi

Du coup je vais tenter la manip de AZ Sam
merci pour vos réponses
Publicité
Poster une réponse
Anonyme