problème avec nb.si

Le
marc
Bonjour à vous tous.
Je sais si j'utilise la bonne formule, mais pour l'instant, cela ne fonctionne pas.
Disons A1 jusquà E1.
A1= est vide
B1= Stage 1
C1= bla bla
D1= Stage 2 avec restcition
E1=vide
Ce que j'aimerais, c'est de pouvoir dire à Excel, compte le nombre de fois que tu vois le mot Stage (peu importe ce qu'il est
inscrit dans la cellule) et chaque fois que tu vois le mot Stage, ça équivaut au chiffre 3. Donc dans mon exemple, le mot sate est
écrit 2 fois , 2 X3= 6.
En espérant avoir été assez claire. J'aimerais pouvoir le faire à l'aide d'une formule, et non d'une macro.
Merci de votre aide
Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #18816151
Bonsoir
Désolé de ne pas passer par NB.SI.....

=SOMMEPROD((GAUCHE(A1:E1;5)="stage")*3)


--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"marc"
Bonjour à vous tous.
Je sais si j'utilise la bonne formule, mais pour l'instant, cela ne
fonctionne pas.
Disons A1 jusquà E1.
A1= est vide
B1= Stage 1
C1= bla bla
D1= Stage 2 avec restcition
E1=vide
Ce que j'aimerais, c'est de pouvoir dire à Excel, compte le nombre de fois
que tu vois le mot Stage (peu importe ce qu'il est inscrit dans la
cellule) et chaque fois que tu vois le mot Stage, ça équivaut au chiffre
3. Donc dans mon exemple, le mot sate est écrit 2 fois , 2 X3= 6.
En espérant avoir été assez claire. J'aimerais pouvoir le faire à l'aide
d'une formule, et non d'une macro.
Merci de votre aide
Marc




marc
Le #18816431
Bonjour Jacquouille
Aucun problème de ne pas utiliser la fonction NB.Si
Cela fonctionne parfaitement
Merci et bonne journée
Marc

"Jacquouille"
Bonsoir
Désolé de ne pas passer par NB.SI.....

=SOMMEPROD((GAUCHE(A1:E1;5)="stage")*3)


--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"marc"
Bonjour à vous tous.
Je sais si j'utilise la bonne formule, mais pour l'instant, cela ne fonctionne pas.
Disons A1 jusquà E1.
A1= est vide
B1= Stage 1
C1= bla bla
D1= Stage 2 avec restcition
E1=vide
Ce que j'aimerais, c'est de pouvoir dire à Excel, compte le nombre de fois que tu vois le mot Stage (peu importe ce qu'il est
inscrit dans la cellule) et chaque fois que tu vois le mot Stage, ça équivaut au chiffre 3. Donc dans mon exemple, le mot sate
est écrit 2 fois , 2 X3= 6.
En espérant avoir été assez claire. J'aimerais pouvoir le faire à l'aide d'une formule, et non d'une macro.
Merci de votre aide
Marc








Christian M
Le #18816801
ou encore
=SOMMEPROD(ESTNUM(CHERCHE("stage";A1:E1;1))*3)
qui fonctionne sans tenir compte de la casse et où que se trouve la chaîne
de caractères "stage" dans la cellule
ChristianM

"marc"
Bonjour à vous tous.
Je sais si j'utilise la bonne formule, mais pour l'instant, cela ne
fonctionne pas.
Disons A1 jusquà E1.
A1= est vide
B1= Stage 1
C1= bla bla
D1= Stage 2 avec restcition
E1=vide
Ce que j'aimerais, c'est de pouvoir dire à Excel, compte le nombre de fois
que tu vois le mot Stage (peu importe ce qu'il est inscrit dans la
cellule) et chaque fois que tu vois le mot Stage, ça équivaut au chiffre
3. Donc dans mon exemple, le mot sate est écrit 2 fois , 2 X3= 6.
En espérant avoir été assez claire. J'aimerais pouvoir le faire à l'aide
d'une formule, et non d'une macro.
Merci de votre aide
Marc




marc
Le #18820311
Bonjour Christian
Merci pour ta réponse.
Bonne journée
Marc
"Christian M"
ou encore
=SOMMEPROD(ESTNUM(CHERCHE("stage";A1:E1;1))*3)
qui fonctionne sans tenir compte de la casse et où que se trouve la chaîne de caractères "stage" dans la cellule
ChristianM

"marc"
Bonjour à vous tous.
Je sais si j'utilise la bonne formule, mais pour l'instant, cela ne fonctionne pas.
Disons A1 jusquà E1.
A1= est vide
B1= Stage 1
C1= bla bla
D1= Stage 2 avec restcition
E1=vide
Ce que j'aimerais, c'est de pouvoir dire à Excel, compte le nombre de fois que tu vois le mot Stage (peu importe ce qu'il est
inscrit dans la cellule) et chaque fois que tu vois le mot Stage, ça équivaut au chiffre 3. Donc dans mon exemple, le mot sate
est écrit 2 fois , 2 X3= 6.
En espérant avoir été assez claire. J'aimerais pouvoir le faire à l'aide d'une formule, et non d'une macro.
Merci de votre aide
Marc








Publicité
Poster une réponse
Anonyme