problème avec un SI

Le
marc
Bonjour à vous tous
Dans une cellule, exemple a1, il peut y avoir 3 choix de texte
Vrai, ou Faux ou une lettre avec du texte (exemple: a) Il fait chaud dehors.
en b1, j'aimerais que si A1 est différent de Vrai ou faux, gauche(a1;1), sinon A1.

Alors j'essaie =si(a1<>"vrai;faux";gauche(a1);a1)
mais ça ne fonctionne pas.
merci de m'aider
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #20254061
Bonjour,

=SI(ET(A1<>"Vrai";A1<>"Faux");GAUCHE(A1;1);A1)

--
Salutations
JJ


"marc"
Bonjour à vous tous
Dans une cellule, exemple a1, il peut y avoir 3 choix de texte
Vrai, ou Faux ou une lettre avec du texte (exemple: a) Il fait chaud
dehors.
en b1, j'aimerais que si A1 est différent de Vrai ou faux, gauche(a1;1),
sinon A1.

Alors j'essaie =si(a1<>"vrai;faux";gauche(a1);a1)
mais ça ne fonctionne pas.
merci de m'aider




marc
Le #20254131
Bonjour Jacky
Ça fonctionne parfaitement.
J'en ai une autre,
que dois-je changer dans mon code pour que la macro insère 2 ligne et non, une seule
voici le code

Sub test()
Dim i&
For i = Range("a65536").End(xlUp).Row To 2 Step -1
If Not Cells(i, 1) = Cells(i - 1, 1).Value Then
Rows(i).Insert
End If
Next i
End Sub


"Jacky"
Bonjour,

=SI(ET(A1<>"Vrai";A1<>"Faux");GAUCHE(A1;1);A1)

--
Salutations
JJ


"marc"
Bonjour à vous tous
Dans une cellule, exemple a1, il peut y avoir 3 choix de texte
Vrai, ou Faux ou une lettre avec du texte (exemple: a) Il fait chaud dehors.
en b1, j'aimerais que si A1 est différent de Vrai ou faux, gauche(a1;1), sinon A1.

Alors j'essaie =si(a1<>"vrai;faux";gauche(a1);a1)
mais ça ne fonctionne pas.
merci de m'aider








michdenis
Le #20254351
Bonjour Marc,

Modifie cette ligne de cette façon dans ta procédure !
Rows(i).Resize(2).Insert


"marc" #
Bonjour Jacky
Ça fonctionne parfaitement.
J'en ai une autre,
que dois-je changer dans mon code pour que la macro insère 2 ligne et non, une seule
voici le code

Sub test()
Dim i&
For i = Range("a65536").End(xlUp).Row To 2 Step -1
If Not Cells(i, 1) = Cells(i - 1, 1).Value Then
Rows(i).Insert
End If
Next i
End Sub


"Jacky" %23wR$
Bonjour,

=SI(ET(A1<>"Vrai";A1<>"Faux");GAUCHE(A1;1);A1)

--
Salutations
JJ


"marc"
Bonjour à vous tous
Dans une cellule, exemple a1, il peut y avoir 3 choix de texte
Vrai, ou Faux ou une lettre avec du texte (exemple: a) Il fait chaud dehors.
en b1, j'aimerais que si A1 est différent de Vrai ou faux, gauche(a1;1), sinon A1.

Alors j'essaie =si(a1<>"vrai;faux";gauche(a1);a1)
mais ça ne fonctionne pas.
merci de m'aider








isabelle
Le #20254341
bonjour Marc,

remplace :

Rows(i).Insert

par

Rows(i & ":" & i + 1).Insert

isabelle

marc a écrit :
Bonjour Jacky
Ça fonctionne parfaitement.
J'en ai une autre,
que dois-je changer dans mon code pour que la macro insère 2 ligne et non, une seule
voici le code

Sub test()
Dim i&
For i = Range("a65536").End(xlUp).Row To 2 Step -1
If Not Cells(i, 1) = Cells(i - 1, 1).Value Then
Rows(i).Insert
End If
Next i
End Sub


"Jacky"
Bonjour,

=SI(ET(A1<>"Vrai";A1<>"Faux");GAUCHE(A1;1);A1)

--
Salutations
JJ


"marc"
Bonjour à vous tous
Dans une cellule, exemple a1, il peut y avoir 3 choix de texte
Vrai, ou Faux ou une lettre avec du texte (exemple: a) Il fait chaud dehors.
en b1, j'aimerais que si A1 est différent de Vrai ou faux, gauche(a1;1), sinon A1.

Alors j'essaie =si(a1<>"vrai;faux";gauche(a1);a1)
mais ça ne fonctionne pas.
merci de m'aider













Publicité
Poster une réponse
Anonyme