Problème avec SOMMEPROD

Le
Séb
Bonjour,

Je rencontre un problème avec SOMMEPROD : une des 2 lignes de données que je
multiplie peut conttenir, dans certaines cellules, du texte. Et j'aimerais
que ces cellules avec texte soient considérées comme valant 0 : en l'état
actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il moyen de
contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas trouvé
d'équivalent.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #16776841
Bonjour.
Essaie :
=SOMMEPROD(B11:B13;C11:C13)
au lieu de :
=SOMMEPROD(B11:B13*C11:C13)
(Merci Denis...)
Cordialement.
Daniel
"Séb"
Bonjour,

Je rencontre un problème avec SOMMEPROD : une des 2 lignes de données que
je
multiplie peut conttenir, dans certaines cellules, du texte. Et j'aimerais
que ces cellules avec texte soient considérées comme valant 0 : en l'état
actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il moyen de
contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas trouvé
d'équivalent.


Séb
Le #16777121
Bonjour, et merci pour cette réponse (mon premier post est parti un peu plus
rapidement que je ne l'imaginais...).

Il subsiste encore un souci : ma ligne problématique fait partie d'une
soustration avec une autre. Un exemple :

=SOMMEPROD(((A2:E2)<>0)*((A2:E2)-(A1:E1)))
C'est ma ligne A2:E2 qui peut contenir du teste, et du coup la 2e partie de
mon SOMMEPROD coince.
J'ai bien trouvé la fonction ESTNUM, mais j'ai pas encore réussi à intégrer
ça comme il fallait dans ma formule.

Merci pour votre aide.

Séb

"Daniel.C" a écrit :

Bonjour.
Essaie :
=SOMMEPROD(B11:B13;C11:C13)
au lieu de :
=SOMMEPROD(B11:B13*C11:C13)
(Merci Denis...)
Cordialement.
Daniel
"Séb"
> Bonjour,
>
> Je rencontre un problème avec SOMMEPROD : une des 2 lignes de données que
> je
> multiplie peut conttenir, dans certaines cellules, du texte. Et j'aimerais
> que ces cellules avec texte soient considérées comme valant 0 : en l'état
> actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il moyen de
> contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas trouvé
> d'équivalent.





Daniel.C
Le #16777571
Essaie :
=SOMMEPROD(((A2:E2)<>0)*(SI(ESTNUM(A2:E2);(A2:E2)-(A1:E1);0)))
Daniel
"Séb"
Bonjour, et merci pour cette réponse (mon premier post est parti un peu
plus
rapidement que je ne l'imaginais...).

Il subsiste encore un souci : ma ligne problématique fait partie d'une
soustration avec une autre. Un exemple :

=SOMMEPROD(((A2:E2)<>0)*((A2:E2)-(A1:E1)))
C'est ma ligne A2:E2 qui peut contenir du teste, et du coup la 2e partie
de
mon SOMMEPROD coince.
J'ai bien trouvé la fonction ESTNUM, mais j'ai pas encore réussi à
intégrer
ça comme il fallait dans ma formule.

Merci pour votre aide.

Séb

"Daniel.C" a écrit :

Bonjour.
Essaie :
=SOMMEPROD(B11:B13;C11:C13)
au lieu de :
=SOMMEPROD(B11:B13*C11:C13)
(Merci Denis...)
Cordialement.
Daniel
"Séb"
> Bonjour,
>
> Je rencontre un problème avec SOMMEPROD : une des 2 lignes de données
> que
> je
> multiplie peut conttenir, dans certaines cellules, du texte. Et
> j'aimerais
> que ces cellules avec texte soient considérées comme valant 0 : en
> l'état
> actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il moyen
> de
> contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas
> trouvé
> d'équivalent.







Séb
Le #17237391
Bonjour,

Malheureusement, ça coince toujours : le "ESTNUM" ne semble pas marcher sur
une matrice.

Merci quand même pour votre aide.

Séb



"Daniel.C" a écrit :

Essaie :
=SOMMEPROD(((A2:E2)<>0)*(SI(ESTNUM(A2:E2);(A2:E2)-(A1:E1);0)))
Daniel
"Séb"
> Bonjour, et merci pour cette réponse (mon premier post est parti un peu
> plus
> rapidement que je ne l'imaginais...).
>
> Il subsiste encore un souci : ma ligne problématique fait partie d'une
> soustration avec une autre. Un exemple :
>
> =SOMMEPROD(((A2:E2)<>0)*((A2:E2)-(A1:E1)))
> C'est ma ligne A2:E2 qui peut contenir du teste, et du coup la 2e partie
> de
> mon SOMMEPROD coince.
> J'ai bien trouvé la fonction ESTNUM, mais j'ai pas encore réussi à
> intégrer
> ça comme il fallait dans ma formule.
>
> Merci pour votre aide.
>
> Séb
>
> "Daniel.C" a écrit :
>
>> Bonjour.
>> Essaie :
>> =SOMMEPROD(B11:B13;C11:C13)
>> au lieu de :
>> =SOMMEPROD(B11:B13*C11:C13)
>> (Merci Denis...)
>> Cordialement.
>> Daniel
>> "Séb" >>
>> > Bonjour,
>> >
>> > Je rencontre un problème avec SOMMEPROD : une des 2 lignes de données
>> > que
>> > je
>> > multiplie peut conttenir, dans certaines cellules, du texte. Et
>> > j'aimerais
>> > que ces cellules avec texte soient considérées comme valant 0 : en
>> > l'état
>> > actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il moyen
>> > de
>> > contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas
>> > trouvé
>> > d'équivalent.
>>
>>
>>





Daniel.C
Le #17240511
Bonjour.
Peux-tu mettre un classeur exemple sur www.cjoint.com et poster ici
l'adresse générée ?
Daniel
"Séb"
Bonjour,

Malheureusement, ça coince toujours : le "ESTNUM" ne semble pas marcher
sur
une matrice.

Merci quand même pour votre aide.

Séb



"Daniel.C" a écrit :

Essaie :
=SOMMEPROD(((A2:E2)<>0)*(SI(ESTNUM(A2:E2);(A2:E2)-(A1:E1);0)))
Daniel
"Séb"
> Bonjour, et merci pour cette réponse (mon premier post est parti un peu
> plus
> rapidement que je ne l'imaginais...).
>
> Il subsiste encore un souci : ma ligne problématique fait partie d'une
> soustration avec une autre. Un exemple :
>
> =SOMMEPROD(((A2:E2)<>0)*((A2:E2)-(A1:E1)))
> C'est ma ligne A2:E2 qui peut contenir du teste, et du coup la 2e
> partie
> de
> mon SOMMEPROD coince.
> J'ai bien trouvé la fonction ESTNUM, mais j'ai pas encore réussi à
> intégrer
> ça comme il fallait dans ma formule.
>
> Merci pour votre aide.
>
> Séb
>
> "Daniel.C" a écrit :
>
>> Bonjour.
>> Essaie :
>> =SOMMEPROD(B11:B13;C11:C13)
>> au lieu de :
>> =SOMMEPROD(B11:B13*C11:C13)
>> (Merci Denis...)
>> Cordialement.
>> Daniel
>> "Séb" >>
>> > Bonjour,
>> >
>> > Je rencontre un problème avec SOMMEPROD : une des 2 lignes de
>> > données
>> > que
>> > je
>> > multiplie peut conttenir, dans certaines cellules, du texte. Et
>> > j'aimerais
>> > que ces cellules avec texte soient considérées comme valant 0 : en
>> > l'état
>> > actuel des choses, j'ai un joli #VALEUR qui me revient. Y a-t-il
>> > moyen
>> > de
>> > contourner ce problème ? Une sorte de ISNUMERIC, mais je n'ai pas
>> > trouvé
>> > d'équivalent.
>>
>>
>>







Publicité
Poster une réponse
Anonyme