problème avec wifi-radar

Le
docanski
Bonjour la foule !

Je n'arrive pas à démarrer cette application, malgré plusieurs
installations avec Gdebi, Synaptic et en console.
Lorsque je veux l'activer, j'obtiens la fenêtre d'alerte
"Impossible de lancer l'entrée du menu. L'exécution du processus fils
"su-to-root" a échoué (aucun fichier ou dossier de ce type)"
J'ai pourtant installé cette application sans éprouver aucun problème
sur plusieurs autres machines, toutes sous Ubuntu. Ici, je tente sur une
machine à base de Pentium III 450 Mhz et plus de 400 Mo de Ram. Bon, je
me doute que cela n'a aucun rapport mais c'est pour dire, quoi :-)

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
docanski
Le #17747981
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski ecrit ce qui suit en ce 04.11.2008 14:15 :

Je n'arrive pas à démarrer cette application, malgré plusieurs
installations avec Gdebi, Synaptic et en console.



J'ai essayé sur une autre machine : même résultat.
Ces deux essais ont été faits sous Ubuntu 8.10 et il n'y avait pas de
problèmes avec la 7.10 et la 8.04.
Pourtant, cette application est disponible à partir de Synaptic pour les
3 versions.
Des retours d'expérience à ce propos ?

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Michel Giacomazzi
Le #17750511
docanski a écrit :
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski ecrit ce qui suit en ce 04.11.2008 14:15 :

Je n'arrive pas à démarrer cette application, malgré plusieurs
installations avec Gdebi, Synaptic et en console.



J'ai essayé sur une autre machine : même résultat.
Ces deux essais ont été faits sous Ubuntu 8.10 et il n'y avait pas de
problèmes avec la 7.10 et la 8.04.
Pourtant, cette application est disponible à partir de Synaptic pour les
3 versions.
Des retours d'expérience à ce propos ?

Cordialement,


Bonjour,

Je ne sais pas si je vais vous aider car le pb que j'avais eu n'est pas
strictement identique : ça se lançait sur Ubuntu 7.10, mais pas
directement sur Debian 4.

Pour que ça fonctionne, j'ai remplacé la commande du menu :
gksu wifi-radar
(j'utilise Gnome)

Dans /usr/share/menu/wifi-radar, j'ai notamment :
command="su-to-root -X -c /usr/sbin/wifi-radar"

J'ai dû modifier à la main le fichier de config :
/etc/wifi-radar.conf
pour paramétrer correctement les accès que je souhaitait.

Cordialement
docanski
Le #17752531
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Michel Giacomazzi ecrit ce qui suit en ce 05.11.2008 05:49 :

Bonjour,



Bonjour,

J'ai dû modifier à la main le fichier de config :
/etc/wifi-radar.conf
pour paramétrer correctement les accès que je souhaitait.



J'ai le paramétrage suivant :

[DEFAULT]
interface = auto_detect
auto_profile_order speak_up = False
scan_timeout = 5
commit_required = False
ifup_required = False

Quelle différence par rapport au tien ?

Pour pouvoir ouvrir l'application, je suis obligé de le faire par une
commande en console. Or, je voudrais pouvoir le faire directement par le
menu des applications, en cliquant tout simplement sur son icône.

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Jonathan ROTH
Le #17752751
Le 05/11/2008 11:05, docanski s'exprima:
Pour pouvoir ouvrir l'application, je suis obligé de le faire par une
commande en console. Or, je voudrais pouvoir le faire directement par le
menu des applications, en cliquant tout simplement sur son icône.



Activer le bit "suid" ? (chmod u+s)
docanski
Le #17753351
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Jonathan ROTH ecrit ce qui suit en ce 05.11.2008 12:09 :

Activer le bit "suid" ? (chmod u+s)



Là, ça devient brumeux pour moi. Sais pas comment faire :-(
Autre chose : si l'interface détecte bien un signal, il est de toute
façon impossible d'avoir une connexion. C'est très curieux ... et très
emmerdant.
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Michel Giacomazzi
Le #17755351
docanski a écrit :
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Michel Giacomazzi ecrit ce qui suit en ce 05.11.2008 05:49 :

Bonjour,



Bonjour,

J'ai dû modifier à la main le fichier de config :
/etc/wifi-radar.conf
pour paramétrer correctement les accès que je souhaitait.



J'ai le paramétrage suivant :

[DEFAULT]
interface = auto_detect
auto_profile_order > speak_up = False
scan_timeout = 5
commit_required = False
ifup_required = False

Quelle différence par rapport au tien ?

Pour pouvoir ouvrir l'application, je suis obligé de le faire par une
commande en console. Or, je voudrais pouvoir le faire directement par le
menu des applications, en cliquant tout simplement sur son icône.

Cordialement,


A mon avis, il y a 2 choses :

1.Lancer l'application
La commande gksu (sous Gnome ; kdesu sous KDE) indiquée plus haut
lance wifi-radar en tant que superutilisateur et réclame donc le mot de
passe avant le lancement
Je pense que Jonathan ROTH propose de modifier les autorisations des
fichiers utilisés pour que n'importe quel utilisateur puisse lancer
l'application.

2.Se connecter une fois wifi-radar lancé
Pour cela, lorsque vous voyez le nom de votre borne dans la liste
SSID, cliquer sur Edit et renseignez les paramètres (généralement
seulement la clé) puis Enregistrer
Ensuite, vous pouvez cliquer sur Connect.
Dans mon cas, la connexion se faisait bien mais la clé n'était pas
enregistrée, d'où la modif de /etc/wifi-radar.conf (attention /etc),
qui donne ceci (selon ma config <SSID> et <clé WEP> étant à remplacer
par les vraies valeurs selon votre borne WiFi) :

[DEFAULT]
scan_timeout = 5
auto_profile_order = <SSID>
speak_up = False
ifup_required = False
interface = eth1
commit_required = True

[<SSID>]
prescript use_wpa = no
postscript mode key = <clé WEP>
use_dhcp = yes
security channel =
Jonathan ROTH
Le #17755531
Le 05/11/2008 17:35, Michel Giacomazzi s'exprima:
Je pense que Jonathan ROTH propose de modifier les autorisations des
fichiers utilisés pour que n'importe quel utilisateur puisse lancer
l'application.



Tu penses bien.

En fait, cela permet de lancer l'appli avec avec les privilèges de root.
docanski
Le #17756541
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Michel Giacomazzi ecrit ce qui suit en ce 05.11.2008 17:35 :

A mon avis, il y a 2 choses :

1.Lancer l'application
La commande gksu ...



C'est ce que je suis obligé de faire. Or, je voudrais lancer
l'application par le menu des applications, où d'ailleurs il apparaît.

lance wifi-radar en tant que superutilisateur et réclame donc le mot de
passe avant le lancement



Ce qui n'est pas normal : tous les utilisateurs sont censés pouvoir s'en
servir. J'avais fait la même installation sous Ubuntu 7.10 par Gdebi et
n'avait eu aucun problème. Sur cette 8.10, j'ai fait de même et faute de
résultat, je l'ai tentée en console.

Je pense que Jonathan ROTH propose de modifier les autorisations des
fichiers utilisés pour que n'importe quel utilisateur puisse lancer
l'application.



Ce qui serait bien.

2.Se connecter une fois wifi-radar lancé
Pour cela, lorsque vous voyez le nom de votre borne dans la liste
SSID, cliquer sur Edit et renseignez les paramètres (généralement
seulement la clé) puis Enregistrer



Tout cela a été fait, sachant que pour les tests, aucune clef n'a été
enregistrée, ni sur le routeur ni évidemment sur la cle USB.

Ensuite, vous pouvez cliquer sur Connect.
Dans mon cas, la connexion se faisait bien mais la clé n'était pas
enregistrée, d'où la modif de /etc/wifi-radar.conf (attention /etc),



En "utilisateur" j'obtiens :

"Impossible d'afficher « /etc/wifi-radar.conf »
Aucune application n'est installée pour ce type de fichier"
et je ne peux donc corriger le fichier qu'en su

Et je suis donc obligé de passer en su pour éditer le fichier, mais il
me paraît de toute façon correct :

[DEFAULT]
scan_timeout = 5
auto_profile_order = linksys
speak_up = False
ifup_required = False
interface = auto_detect
commit_required = False

[linksys]
prescript use_wpa = no
postscript mode = auto
key use_dhcp = yes
security = open
channel = auto

D'ailleurs, l'interface me permet de constater qu'il y a un signal (et
même le signal de routeurs voisins), la clef "clignote" et est donc
censée envoyer/recevoir des paquets ... mais je n'ai pourtant pas de
connexion.

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
docanski
Le #17756531
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
docanski ecrit ce qui suit en ce 05.11.2008 18:44 :

D'ailleurs, l'interface me permet de constater qu'il y a un signal (et
même le signal de routeurs voisins), la clef "clignote" et est donc
censée envoyer/recevoir des paquets ... mais je n'ai pourtant pas de
connexion.



J'ajoute que quand je tente de me connecter, j'obtiens :

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:1e:58:b3:85:fc
Sending on LPF/wlan0/00:1e:58:b3:85:fc
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16

Cordialement,


--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Jonathan ROTH
Le #17756971
Le 05/11/2008 19:14, docanski s'exprima:
wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/wlan0/00:1e:58:b3:85:fc
Sending on LPF/wlan0/00:1e:58:b3:85:fc
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16



Je suppose que ça continue sans recevoir d'IP...

...c'est peut être parce que tu n'as pas la clef ou qu'elle a été mal
recopiéé.
Publicité
Poster une réponse
Anonyme