Problème de bouton

Le
gds10
Bonjour voilà j'ai créé plusieurs boutons de commande dans un formulaire.
Chaque bouton doit actionner un module. Ce module me lance un publipostage.
voilà mon code de bouton :
Private Sub Commande46_Click()
Call Publipostage_Vers_Document

End Sub

Mon problème est que ce code marche tant que je ne sors pas du bouton !! Dès
que je vais dans la 2ème le 1er se modifie de façon anarchique et ainsi de
suite ..

Peut être faut il utiliser un autre code ?

D'avance merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gilbert
Le #17509641
Bonjour,

Je n'ai pas compris :
Qu'est-ce que "sortir du bouton"?
Quand tu vas dans la 2ème quoi?
Le premier quoi se modifie?

--
Cordialement,

Gilbert


"gds10"
Bonjour voilà j'ai créé plusieurs boutons de commande dans un formulaire.
Chaque bouton doit actionner un module. Ce module me lance un
publipostage.
voilà mon code de bouton :
Private Sub Commande46_Click()
Call Publipostage_Vers_Document

End Sub

Mon problème est que ce code marche tant que je ne sors pas du bouton !!
Dès
que je vais dans la 2ème le 1er se modifie de façon anarchique et ainsi de
suite ..

Peut être faut il utiliser un autre code ?

D'avance merci de votre aide.



gds10
Le #17510891
Donc en fait je crée mon 1er bouton mon publipostage marche (le module est
lancé)
Mais dès que je crée un 2ème bouton, le code du 1er (bouton) apparait donc
je le modifie pour qu'il corresponde au code de mon 2ème bouton. Et alors mon
2ème bouton fonctionne mais plus mon premier et ainsi de suite

voilà j'espère que je suis plus claire ?

"gds10" a écrit :

Bonjour voilà j'ai créé plusieurs boutons de commande dans un formulaire.
Chaque bouton doit actionner un module. Ce module me lance un publipostage.
voilà mon code de bouton :
Private Sub Commande46_Click()
Call Publipostage_Vers_Document

End Sub

Mon problème est que ce code marche tant que je ne sors pas du bouton !! Dès
que je vais dans la 2ème le 1er se modifie de façon anarchique et ainsi de
suite ..

Peut être faut il utiliser un autre code ?

D'avance merci de votre aide.


Gilbert
Le #17511041
Chacun de tes boutons doit avoir un évènement "Sur click" indépendant des
autres.
Tu dois avoir quelque chose comme
Private Sub Bouton1_Click()
Call aaaaaaaaaaaa
End Sub

Private Sub Bouton2_Click()
Call bbbbbbbbbb
End Sub

Private Sub Bouton3_Click()
Call ccccccccccccc
End Sub

--
Cordialement,

Gilbert


"gds10"
Donc en fait je crée mon 1er bouton mon publipostage marche (le module est
lancé)
Mais dès que je crée un 2ème bouton, le code du 1er (bouton) apparait donc
je le modifie pour qu'il corresponde au code de mon 2ème bouton. Et alors
mon
2ème bouton fonctionne mais plus mon premier et ainsi de suite

voilà j'espère que je suis plus claire ?

"gds10" a écrit :

Bonjour voilà j'ai créé plusieurs boutons de commande dans un formulaire.
Chaque bouton doit actionner un module. Ce module me lance un
publipostage.
voilà mon code de bouton :
Private Sub Commande46_Click()
Call Publipostage_Vers_Document

End Sub

Mon problème est que ce code marche tant que je ne sors pas du bouton !!
Dès
que je vais dans la 2ème le 1er se modifie de façon anarchique et ainsi
de
suite ..

Peut être faut il utiliser un autre code ?

D'avance merci de votre aide.





gds10
Le #17512331
Merci pour ta réponse.
Alors en fait oui je change ça devient Commande 47 puis 48 etc..



"Gilbert" a écrit :

Chacun de tes boutons doit avoir un évènement "Sur click" indépendant des
autres.
Tu dois avoir quelque chose comme
Private Sub Bouton1_Click()
Call aaaaaaaaaaaa
End Sub

Private Sub Bouton2_Click()
Call bbbbbbbbbb
End Sub

Private Sub Bouton3_Click()
Call ccccccccccccc
End Sub

--
Cordialement,

Gilbert


"gds10"
> Donc en fait je crée mon 1er bouton mon publipostage marche (le module est
> lancé)
> Mais dès que je crée un 2ème bouton, le code du 1er (bouton) apparait donc
> je le modifie pour qu'il corresponde au code de mon 2ème bouton. Et alors
> mon
> 2ème bouton fonctionne mais plus mon premier et ainsi de suite
>
> voilà j'espère que je suis plus claire ?
>
> "gds10" a écrit :
>
>> Bonjour voilà j'ai créé plusieurs boutons de commande dans un formulaire.
>> Chaque bouton doit actionner un module. Ce module me lance un
>> publipostage.
>> voilà mon code de bouton :
>> Private Sub Commande46_Click()
>> Call Publipostage_Vers_Document
>>
>> End Sub
>>
>> Mon problème est que ce code marche tant que je ne sors pas du bouton !!
>> Dès
>> que je vais dans la 2ème le 1er se modifie de façon anarchique et ainsi
>> de
>> suite ..
>>
>> Peut être faut il utiliser un autre code ?
>>
>> D'avance merci de votre aide.
>





Gilbert
Le #17513191
Il est préférable pour une question de maintenace du code de renommer tes
boutons (et tous les objets en général).
Au lieu de laisser Commande47, tu renommes (propriétés du bouton, onglet
Autres, propriété Nom) ton bouton en CmdPublipostage ou Btn_Toto ou ce que
tu veux pourvu que ce soit plus parlant pour toi.

--
Cordialement,

Gilbert


"gds10"
Merci pour ta réponse.
Alors en fait oui je change ça devient Commande 47 puis 48 etc..



"Gilbert" a écrit :

Chacun de tes boutons doit avoir un évènement "Sur click" indépendant des
autres.
Tu dois avoir quelque chose comme
Private Sub Bouton1_Click()
Call aaaaaaaaaaaa
End Sub

Private Sub Bouton2_Click()
Call bbbbbbbbbb
End Sub

Private Sub Bouton3_Click()
Call ccccccccccccc
End Sub

--
Cordialement,

Gilbert


"gds10" news:

> Donc en fait je crée mon 1er bouton mon publipostage marche (le module
> est
> lancé)
> Mais dès que je crée un 2ème bouton, le code du 1er (bouton) apparait
> donc
> je le modifie pour qu'il corresponde au code de mon 2ème bouton. Et
> alors
> mon
> 2ème bouton fonctionne mais plus mon premier et ainsi de suite
>
> voilà j'espère que je suis plus claire ?
>
> "gds10" a écrit :
>
>> Bonjour voilà j'ai créé plusieurs boutons de commande dans un
>> formulaire.
>> Chaque bouton doit actionner un module. Ce module me lance un
>> publipostage.
>> voilà mon code de bouton :
>> Private Sub Commande46_Click()
>> Call Publipostage_Vers_Document
>>
>> End Sub
>>
>> Mon problème est que ce code marche tant que je ne sors pas du bouton
>> !!
>> Dès
>> que je vais dans la 2ème le 1er se modifie de façon anarchique et
>> ainsi
>> de
>> suite ..
>>
>> Peut être faut il utiliser un autre code ?
>>
>> D'avance merci de votre aide.
>








chpa
Le #17888411
Bonsoir,
Oui, Gilbert a raison mais attention, si tu renomme ton bouton après y avoir
placé ton code,
tu te retrouve avec un bouton sans code et un code sans bouton.

"Gilbert" news:
Il est préférable pour une question de maintenace du code de renommer tes
boutons (et tous les objets en général).
Au lieu de laisser Commande47, tu renommes (propriétés du bouton, onglet
Autres, propriété Nom) ton bouton en CmdPublipostage ou Btn_Toto ou ce que
tu veux pourvu que ce soit plus parlant pour toi.

--
Cordialement,

Gilbert


"gds10"
Merci pour ta réponse.
Alors en fait oui je change ça devient Commande 47 puis 48 etc..



"Gilbert" a écrit :

Chacun de tes boutons doit avoir un évènement "Sur click" indépendant
des
autres.
Tu dois avoir quelque chose comme
Private Sub Bouton1_Click()
Call aaaaaaaaaaaa
End Sub

Private Sub Bouton2_Click()
Call bbbbbbbbbb
End Sub

Private Sub Bouton3_Click()
Call ccccccccccccc
End Sub

--
Cordialement,

Gilbert


"gds10" news:

> Donc en fait je crée mon 1er bouton mon publipostage marche (le module
> est
> lancé)
> Mais dès que je crée un 2ème bouton, le code du 1er (bouton) apparait
> donc
> je le modifie pour qu'il corresponde au code de mon 2ème bouton. Et
> alors
> mon
> 2ème bouton fonctionne mais plus mon premier et ainsi de suite
>
> voilà j'espère que je suis plus claire ?
>
> "gds10" a écrit :
>
>> Bonjour voilà j'ai créé plusieurs boutons de commande dans un
>> formulaire.
>> Chaque bouton doit actionner un module. Ce module me lance un
>> publipostage.
>> voilà mon code de bouton :
>> Private Sub Commande46_Click()
>> Call Publipostage_Vers_Document
>>
>> End Sub
>>
>> Mon problème est que ce code marche tant que je ne sors pas du bouton
>> !!
>> Dès
>> que je vais dans la 2ème le 1er se modifie de façon anarchique et
>> ainsi
>> de
>> suite ..
>>
>> Peut être faut il utiliser un autre code ?
>>
>> D'avance merci de votre aide.
>












Publicité
Poster une réponse
Anonyme