probleme sur certains de mes users en restaurant une VM

Le
Thierry B
Bonjour,

Sur une nouvelle Dedibox, j'ai restauré une VM Xen qui va me servir
comme nouveau serveur.

J'avais fait plusieurs LVs pour découper cette VM (par exemple, pour
/var/mail, /var/www)

J'ai tout restauré proprement en créeant les différents LVs sur le dom0,
en faisant le mapping entre ces LVs et les différents partitions xvda de
ma VM

La VM se lance, tout a l'air de bien fonctionné

Donc je me dis que je vais faire pointer le MX d'un de mes domaines sur
ma VM pour faire des tests, et je m'apercois que j'ai un pb de "user
unknown" quand j'envoie un mail sur un alias.

En voulant faire un su vmail, j'obtiens ceci :

h:w$

De plus, l'auto-complétion ne fonctionne pluset ca fait aussi pareil
avec www-data.

Je me demande si cela ne vient pas de la restauration de ces LVs.

Un chown -R vmail:vmail /var/mail ne change rien :(

Je n'ai pas de pb avec le user root avec lequel je me logue sur cette VM.

# grep -i "vmail" /etc/passwd
vmail:x:1001:1001::/var/mail/:/bin/sh

# grep -i "root" /etc/passwd
root:x:0:0:root:/root:/bin/bash

# ls -l /bin/sh
lrwxrwxrwx 1 root root 4 14 juil. 04:03 /bin/sh -> dash

# grep -i "bash" /etc/passwd
root:x:0:0:root:/root:/bin/bash

Apparemment, il n'y a que root qui utilise bash et le reste des users dash.

Pour info, c'est une VM sous lenny initalement qui a été migré sous
squeeze. Faudrait que je passe le tout en sh?


Je ne sais pas si tout cela a un rapport avec mon pb de user, mais
j'aimerais régler ce soucis déjà.


Merci :-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4E2006DC.3010200@tbzone.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry B
Le #23566881
Le 15/07/2011 11:22, Thierry B a écrit :
Bonjour,

Sur une nouvelle Dedibox, j'ai restauré une VM Xen qui va me servir
comme nouveau serveur.

J'avais fait plusieurs LVs pour découper cette VM (par exemple, pour
/var/mail, /var/www...)

J'ai tout restauré proprement en créeant les différents LVs sur le dom0,
en faisant le mapping entre ces LVs et les différents partitions xvda de
ma VM...

La VM se lance, tout a l'air de bien fonctionné...

Donc je me dis que je vais faire pointer le MX d'un de mes domaines sur
ma VM pour faire des tests, et je m'apercois que j'ai un pb de "user
unknown" quand j'envoie un mail sur un alias.

En voulant faire un su vmail, j'obtiens ceci :

h:w$

De plus, l'auto-complétion ne fonctionne plus...et ca fait aussi pareil
avec www-data.

Je me demande si cela ne vient pas de la restauration de ces LVs.

Un chown -R vmail:vmail /var/mail ne change rien :(

Je n'ai pas de pb avec le user root avec lequel je me logue sur cette VM.

# grep -i "vmail" /etc/passwd
vmail:x:1001:1001::/var/mail/:/bin/sh

# grep -i "root" /etc/passwd
root:x:0:0:root:/root:/bin/bash

# ls -l /bin/sh
lrwxrwxrwx 1 root root 4 14 juil. 04:03 /bin/sh -> dash

# grep -i "bash" /etc/passwd
root:x:0:0:root:/root:/bin/bash

Apparemment, il n'y a que root qui utilise bash et le reste des users dash.

Pour info, c'est une VM sous lenny initalement qui a été migré sous
squeeze. Faudrait que je passe le tout en sh?


Je ne sais pas si tout cela a un rapport avec mon pb de user, mais
j'aimerais régler ce soucis déjà.


Merci :-)




Bon, ca venait bien de dash pour mon pb de prompt et d'auto complétion,
mais mon pb de user unknown ne venait pas de là.

Merci :-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme