Probleme de classe. methode non reconnu

Le
Daniel
Bonjour,
J' ai récuperé la classe "Cimagememoire" et 'CPlanning" du projet
Planning en W10.
Tout c est bien passé sauf que la methode "Restaure" n'est pas
reconnu.
Je suis l'exemple au pas a pas et je n'ai que cette erreur.

"Erreur :L'élément 'Restaure' n'existe pas dans la classe
'CPlanning'."
en effet la methode et dans la classe "Cimagememoire". mais elle
existe bien.
le code incriminé est :
clPlanning:Restaure(clPlanning:NomChampImage,clPlanning:HDC)

je ne vois pas le probleme.
Merci pour vos aides
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Firetox
Le #17829651
Bonjour,

vous avez bien cette ligne dans la classe cplanning : un objet cImageMemoire
si oui alors supprimer le repertoire ?cpl de votre projet et recompiler le

Bon dev
@+


"Daniel"
Bonjour,
J' ai récuperé la classe "Cimagememoire" et 'CPlanning" du projet
Planning en W10.
Tout c est bien passé sauf que la methode "Restaure" n'est pas
reconnu.
Je suis l'exemple au pas a pas et je n'ai que cette erreur.

"Erreur :L'élément 'Restaure' n'existe pas dans la classe
'CPlanning'."
en effet la methode et dans la classe "Cimagememoire". mais elle
existe bien.
le code incriminé est :
clPlanning:Restaure(clPlanning:NomChampImage,clPlanning:HDC)

je ne vois pas le probleme.
Merci pour vos aides
Daniel
Le #17829781
merci,
On m'a deja proposé cette methode mais cela ne fonctionne PAS.
J ai meme enlevé le fichier .env de l appli.
Ce code est affecté au clic sur image.
Faut-il declarer l image?


On 13 nov, 11:05, "Firetox"
Bonjour,

vous avez bien cette ligne dans la classe cplanning : un objet cImageMemo ire
si oui alors supprimer le repertoire ?cpl de votre projet et recompiler l e

Bon dev
@+

"Daniel"
Bonjour,
J' ai récuperé la classe "Cimagememoire" et 'CPlanning" du projet
Planning en W10.
Tout c est bien passé sauf que la methode "Restaure" n'est pas
reconnu.
Je suis l'exemple au pas a pas et je n'ai que cette erreur.

"Erreur :L'élément 'Restaure' n'existe pas dans la classe
'CPlanning'."
en effet la methode et dans la classe "Cimagememoire". mais elle
existe bien.
le code incriminé est :
clPlanning:Restaure(clPlanning:NomChampImage,clPlanning:HDC)

je ne vois pas le probleme.
Merci pour vos aides


Daniel
Le #17832531
J avais mis en commentaire la déclaration de la classe Cimagememoire
en Héritage.
Désolé, et merci a ceux qui ont cherché


On 13 nov, 11:31, Daniel
merci,
On m'a deja proposé cette methode mais cela ne fonctionne PAS.
J ai meme enlevé le fichier .env de l appli.
Ce code est affecté au clic sur image.
Faut-il declarer l image?

On 13 nov, 11:05, "Firetox"


> Bonjour,

> vous avez bien cette ligne dans la classe cplanning : un objet cImageMe moire
> si oui alors supprimer le repertoire ?cpl de votre projet et recompiler le

> Bon dev
> @+

> "Daniel" >
> Bonjour,
> J' ai récuperé la classe "Cimagememoire" et 'CPlanning" du projet
> Planning en W10.
> Tout c est bien passé sauf que la methode "Restaure" n'est pas
> reconnu.
> Je suis l'exemple au pas a pas et je n'ai que cette erreur.

> "Erreur :L'élément 'Restaure' n'existe pas dans la classe
> 'CPlanning'."
> en effet la methode et dans la classe "Cimagememoire". mais elle
> existe bien.
> le code incriminé est :
> clPlanning:Restaure(clPlanning:NomChampImage,clPlanning:HDC)

> je ne vois pas le probleme.
> Merci pour vos aides- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Publicité
Poster une réponse
Anonyme