Probleme compilation KontrollerLab (Qt)

Le
Robert LEFEVRE
Bonjour,
Avec kubuntu, jaunty et karmic, 64 bits, j'essaie donc de compiler
kontrollerlab (IDE pour µC Atmel) et j'ai toujours la même erreur, à la
fin du ./configure:

checking for Qt configure: error: Qt (>= Qt 3.2) (headers and
libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Et la fin du fichier config.log est celle-ci:

configure: exit 1

J'ai cherché à savoir quelle était ma version de Qt, en faaisant, qmake
-v :
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib

Je ne compile que très rarement un programme avec Qt et j'ai besoin de
conseils pour m'en sortir, merci beaucoup.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
batyann811
Le #21446871
Robert LEFEVRE a écrit :
Avec kubuntu, jaunty et karmic, 64 bits, j'essaie donc de compiler
kontrollerlab (IDE pour µC Atmel) et j'ai toujours la même erreur, à la
fin du ./configure:

checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and
libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Et la fin du fichier config.log est celle-ci:

configure: exit 1

J'ai cherché à savoir quelle était ma version de Qt, en faaisant, qmake
-v :
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib




Comme ça à froid et au réveil je dirais que ton programme ne compile
qu'avec la bibliothèque qt3. Essaye d'installer le paquet libqt3-mt-dev.
Robert LEFEVRE
Le #21450301
batyann811 a écrit :
Robert LEFEVRE a écrit :
Avec kubuntu, jaunty et karmic, 64 bits, j'essaie donc de compiler
kontrollerlab (IDE pour µC Atmel) et j'ai toujours la même erreur, à
la fin du ./configure:

checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and
libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Et la fin du fichier config.log est celle-ci:

configure: exit 1

J'ai cherché à savoir quelle était ma version de Qt, en faaisant,
qmake -v :
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib




Comme ça à froid et au réveil je dirais que ton programme ne compile
qu'avec la bibliothèque qt3. Essaye d'installer le paquet libqt3-mt-dev.


Merci pour cette reponse, effectivement, le message d'erreur n'est plus
le même, et concerne maintenant KDE:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will
fail.
So, check this please and use another prefix!

Et je ne sais pas trop quoi faire. Merci encore.
bruno666
Le #21450821
Robert LEFEVRE a écrit :

batyann811 a écrit :
Robert LEFEVRE a écrit :
Avec kubuntu, jaunty et karmic, 64 bits, j'essaie donc de compiler
kontrollerlab (IDE pour µC Atmel) et j'ai toujours la même erreur, à
la fin du ./configure:

checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and
libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Et la fin du fichier config.log est celle-ci:

configure: exit 1

J'ai cherché à savoir quelle était ma version de Qt, en faaisant,
qmake -v :
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib




Comme ça à froid et au réveil je dirais que ton programme ne compile
qu'avec la bibliothèque qt3. Essaye d'installer le paquet libqt3-mt-dev.


Merci pour cette reponse, effectivement, le message d'erreur n'est plus
le même, et concerne maintenant KDE:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will
fail.
So, check this please and use another prefix!

Et je ne sais pas trop quoi faire. Merci encore.



Je pense que c'est le même problème tu utilises une distribution qui founnit
un environnement KDE4 / Qt4 et tu essaies de compiler une application KDE3
(dont le développement semble en panne depuis 2ans)

Essaie donc d'installer les bibliothèques KDE3 : paquet kdelibs4-dev


--
Bruno
Robert LEFEVRE
Le #21452901
bruno666 a écrit :
Robert LEFEVRE a écrit :

batyann811 a écrit :
Robert LEFEVRE a écrit :
Avec kubuntu, jaunty et karmic, 64 bits, j'essaie donc de compiler
kontrollerlab (IDE pour µC Atmel) et j'ai toujours la même erreur, à
la fin du ./configure:

checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and
libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Et la fin du fichier config.log est celle-ci:

configure: exit 1

J'ai cherché à savoir quelle était ma version de Qt, en faaisant,
qmake -v :
QMake version 2.01a
Using Qt version 4.5.2 in /usr/lib



Comme ça à froid et au réveil je dirais que ton programme ne compile
qu'avec la bibliothèque qt3. Essaye d'installer le paquet libqt3-mt-dev.


Merci pour cette reponse, effectivement, le message d'erreur n'est plus
le même, et concerne maintenant KDE:

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will
fail.
So, check this please and use another prefix!

Et je ne sais pas trop quoi faire. Merci encore.



Je pense que c'est le même problème tu utilises une distribution qui founnit
un environnement KDE4 / Qt4 et tu essaies de compiler une application KDE3
(dont le développement semble en panne depuis 2ans)

Essaie donc d'installer les bibliothèques KDE3 : paquet kdelibs4-dev




Oui, bien sûr, c'est ce que j'ai compris et j'ai installé kdelibs4-dev.
Comme tu vas le voir, c'est déjà mieux en ce qui concerne KDE, mais
kontrollerlab continue à demander des choses, voici:

checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... yes
checking for KDE paths... defaults
checking for dcopidl... /usr/bin/dcopidl
checking for dcopidl2cpp... /usr/bin/dcopidl2cpp
checking for mcopidl... not found
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove
functionality).

Je comprends que je peux compiler, c'est déjà ça, avec une option, mais
je veux comprendre... Bon, je vais essayer de m'en sortir mais si vous
avez une idée, elle est la bienvenue. Merci à vous deux !
olafkewl
Le #21455081
Le 28/03/2010 10:22, Robert LEFEVRE a écrit :

Oui, bien sûr, c'est ce que j'ai compris et j'ai installé kdelibs4-dev.
Comme tu vas le voir, c'est déjà mieux en ce qui concerne KDE, mais
kontrollerlab continue à demander des choses, voici:

checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... yes
checking for KDE paths... defaults
checking for dcopidl... /usr/bin/dcopidl
checking for dcopidl2cpp... /usr/bin/dcopidl2cpp
checking for mcopidl... not found
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove
functionality).

Je comprends que je peux compiler, c'est déjà ça, avec une option, mais
je veux comprendre... Bon, je vais essayer de m'en sortir mais si vous
avez une idée, elle est la bienvenue. Merci à vous deux !




Il vous manque le paquet "libarts1-dev".
Robert LEFEVRE
Le #21470111
olafkewl a écrit :
Le 28/03/2010 10:22, Robert LEFEVRE a écrit :

Oui, bien sûr, c'est ce que j'ai compris et j'ai installé kdelibs4-dev.
Comme tu vas le voir, c'est déjà mieux en ce qui concerne KDE, mais
kontrollerlab continue à demander des choses, voici:

checking for KDE... libraries /usr/lib, headers /usr/include/kde
checking if UIC has KDE plugins available... yes
checking for KDE paths... defaults
checking for dcopidl... /usr/bin/dcopidl
checking for dcopidl2cpp... /usr/bin/dcopidl2cpp
checking for mcopidl... not found
configure: error: The important program mcopidl was not found!
Please check whether you installed aRts correctly or use
--without-arts to compile without aRts support (this will remove
functionality).

Je comprends que je peux compiler, c'est déjà ça, avec une option, mais
je veux comprendre... Bon, je vais essayer de m'en sortir mais si vous
avez une idée, elle est la bienvenue. Merci à vous deux !




Il vous manque le paquet "libarts1-dev".


Bonjour,
Je n'ai pas trové ce paquet sous jaunty. Bon, je renonce pour l'instant,
d'autant que le portage de kontrollerlab sous KDE 4 est en cours.
Merci à tous quand même !
Publicité
Poster une réponse
Anonyme