Problème de connexion

Le
p_geni...
Bonjour,
j'ai un pc avec Vista et Mandriva avec une connexion freebox en ethernet.
Sous Vista tout fonctionne correctement mais avec Mandriva
Il y a un problème bizarre:
Ma carte réseau est reconnue correctement:
L'accès aux serveurs ftp fonctionne sans problème
L'acces aux serveurs web (http) ne fonctionne pas
correctement: Je m'explique j'arrive à accéder uniquement à google (.fr ou
.com)
et une poignée de site en .com, je n'arrive pas à faire du smtplorsque
je fais un ping www.free.fr cela fonctionne j'ai utilisé firefox;
Konqueror
lorsque j'observe la "barre d'état" en bas du navigateur il affiche
recherche de l'hôte, hôte trouvé
requête envoyée
cela bloque à réception de données depuis xxx

C'est bizarre non ?

J'ai utilisé d'autres distributions (Ubuntu/Hardy et Knoppix)
j'ai booté sur un "Live DVD" sans installer
le système d'exploitation mais toujours les mêmes problèmes

Avec mandriva j'ai désactivé le parefeu et toujours rien !!!
Ma carte réseau semble être reconnue par mandriva comme
Silicon Integrated Systems [SiS] 191 Gigabit Ethernet

Voici un résumé de la configuration du PC:

Acer Aspire M1610 avec
Intel Pentium Dual Core, 2.2 GHz, 3072 MB, 320 GB
Nvidia GeForce 8600 GS


Merci de votre aide,
Pierre.


--
échangez opinions et commentaires dans les forums de discussion.
http://www.usenetgratuit.com/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
YBM
Le #6802751
Bonjour,
j'ai un pc avec Vista et Mandriva avec une connexion freebox en ethernet.
Sous Vista tout fonctionne correctement mais avec Mandriva
Il y a un problème bizarre:
Ma carte réseau est reconnue correctement:
L'accès aux serveurs ftp fonctionne sans problème
L'acces aux serveurs web (http) ne fonctionne pas
correctement: Je m'explique j'arrive à accéder uniquement à google (.fr ou
.com)
et une poignée de site en .com, je n'arrive pas à faire du smtp...lorsque
je fais un ping www.free.fr cela fonctionne j'ai utilisé firefox;


Les sites qui passent ne seraient-ils pas ceux dont la page Web est très
simple ?
Essaye de faire un :
ifconfig eth0 mtu 1400
en root dans un terminal et regarde ce que ça donne.

p_geni...
Le #6805571
YBM wrote:

Essaye de faire un :
ifconfig eth0 mtu 1400
en root dans un terminal et regarde ce que ça donne.


je viens d'exécuter cette commande et cela fonctionne
j'arrive à me connecter à des sites inaccessibles avant.
Merci...

peux-tu m'expliquer le problème que j'avais ?

Pierre.

-----
échangez opinions et commentaires dans les forums de discussion.
http://www.usenetgratuit.com/

YBM
Le #6805941
peux-tu m'expliquer le problème que j'avais ?


Ton routeur ne laisse pas passer les datagrammes d'une
taille supérieure à une certaine limite (MTU=Maximal
Transfert Limit) qui est inférieure à 1500 octets
(la valeur pour ethernet), sans doute à cause d'un
protocole de transport encapsulé genre ppp. Normalement
ta machine devrait recevoir des paquets ICMP lui indiquant
de diminuer la taille des datagrammes qu'elle émet, mais
ceux-ci sont sans doute bloqué par quelque firewall.

Pour la plupart des modem adsl le mtu est de 1492. Tu
peux faire des essais pour optimiser la valeur à positionner,
pour trouver le plafond (sous windows il y a des outils
pour le déterminer genre tcpoptimizer, sous linux je n'en
connais pas).

En toute logique le problème devrait se poser aussi sous
windows d'ailleurs.

Pour rendre la configuration de la mtu automatique, ajoute
dans :

/etc/sysconfig/network-scripts/ifup-eth0

un :
ifconfig eth0 mtu 1400

(ou autre valeur qui marche).

YBM
Le #6805931
...
taille supérieure à une certaine limite (MTU=Maximal
Transfert Limit) qui est inférieure à 1500 octets


Maximal Transfert Unit, bien sûr.

p_geni...
Le #6805921
YBM wrote:



/etc/sysconfig/network-scripts/ifup-eth0
ifconfig eth0 mtu 1400



Je n'ai pas un tel fichier j'ai un
/etc/sysconfig/network-scripts/ifup-eth
(sans le 0 à la fin)
j'ai donc ajouté cette ligne

exec ifconfig eth0 mtu 1400

provisoirement le temps chercher une valeur optimale
pour le MTU.

Merci encore,

Pierre.
-----
échangez opinions et commentaires dans les forums de discussion.
http://www.usenetgratuit.com/

YBM
Le #6805911
YBM wrote:



/etc/sysconfig/network-scripts/ifup-eth0
ifconfig eth0 mtu 1400



Je n'ai pas un tel fichier j'ai un
/etc/sysconfig/network-scripts/ifup-eth
(sans le 0 à la fin)
j'ai donc ajouté cette ligne

exec ifconfig eth0 mtu 1400


avec un exec ? j'espère que cette ligne est
la dernière du script !

Ça survit bien à un reboot ? (ifconfig eth0
permet de voir la valeur courante de la mtu).


p_geni...
Le #6805901
YBM wrote:



/etc/sysconfig/network-scripts/ifup-eth0
ifconfig eth0 mtu 1400



Je n'ai pas un tel fichier j'ai un
/etc/sysconfig/network-scripts/ifup-eth
(sans le 0 à la fin)
j'ai donc ajouté cette ligne

exec ifconfig eth0 mtu 1400

provisoirement le temps chercher une valeur optimale
pour le MTU.

Merci encore,

Pierre.
-----
échangez opinions et commentaires dans les forums de discussion.
http://www.usenetgratuit.com/

p_geni...
Le #6806371
YBM wrote:

avec un exec ? j'espère que cette ligne est
la dernière du script !


Oui c'est la dernière ligne.

Ça survit bien à un reboot ? (ifconfig eth0
permet de voir la valeur courante de la mtu).


j'ai bien MTU:1400

Pierre.
-----
échangez opinions et commentaires dans les forums de discussion.
http://www.usenetgratuit.com/

Thierry B.
Le #6806971
--{ (Pierre Génieys) a plopé ceci: }--

avec un exec ? j'espère que cette ligne est
la dernière du script !


Oui c'est la dernière ligne.

Fait quand même attention, si un truc vient installer automatiquement

quelque chose à la fin du script, ben *paf* le chien !


--
{ SIGAREDECUBA, "HAVANE" },
/* Instructs the process to share resources and to hate USA. Kill
* remains the dictator, though */
--{ f.m.b.l revisite la command kill }--


Publicité
Poster une réponse
Anonyme