Problème de couleurs sous session graphique

Le
Bifidus
Bonjour

Quand j'ouvre une session non graphique, puis retourne sous ma session
graphique, les couleurs sont psychédéliques, inutilisables (les
polices sont trop déformées pour être lues).
Pour contourner le problème, je quitte ma session et la relance, mais
ça m'oblige à perdre tous les travaux en cours.
Comment régler ce souci ?

Merci d'avance pour votre aide.

(j'imagine qu'il vous faudra d'autres éléments pour répondre, mais je
ne sais lesquels encore : je viens juste d'installer Ubuntu 9.10 sur
un pc neuf, équipé d'une radeon 5770).
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bruno666
Le #21269991
Bifidus a écrit :

Bonjour

Quand j'ouvre une session non graphique, puis retourne sous ma session
graphique, les couleurs sont psychédéliques, inutilisables (les
polices sont trop déformées pour être lues).
Pour contourner le problème, je quitte ma session et la relance, mais
ça m'oblige à perdre tous les travaux en cours.
Comment régler ce souci ?

Merci d'avance pour votre aide.

(j'imagine qu'il vous faudra d'autres éléments pour répondre, mais je
ne sais lesquels encore : je viens juste d'installer Ubuntu 9.10 sur
un pc neuf, équipé d'une radeon 5770).



Probablement un problème avec le pilote de la carte graphique. Il faudrait
savoir lequel tu utilises.


--
Bruno
Bifidus
Le #21272311
On 26 fév, 09:41, bruno666
Probablement un probl me avec le pilote de la carte graphique. Il faudrai t
savoir lequel tu utilises.



Celui par défaut (le libre).
Une option dans le menu système prévoit d'utiliser le pilote
constructeur, mais j'écope ce faisant d'une icône "amd unsupported
hardware" en bas à droite de l'écran. Donc je suis repassé au pilote
par défaut.
Lucas Levrel
Le #21272431
Le 25 février 2010, Bifidus a écrit :

Quand j'ouvre une session non graphique, puis retourne sous ma session
graphique, les couleurs sont psychédéliques, inutilisables (les
polices sont trop déformées pour être lues).
Pour contourner le problème, je quitte ma session et la relance, mais
ça m'oblige à perdre tous les travaux en cours.



/var/log/Xorg.0.log dit-il quelque chose d'intéressant ?

--
LL
bruno666
Le #21272771
Bifidus a écrit :

On 26 fév, 09:41, bruno666
Probablement un probl me avec le pilote de la carte graphique. Il
faudrait savoir lequel tu utilises.



Celui par défaut (le libre).
Une option dans le menu système prévoit d'utiliser le pilote
constructeur, mais j'écope ce faisant d'une icône "amd unsupported
hardware" en bas à droite de l'écran. Donc je suis repassé au pilote
par défaut.



Il me semble que le pilote libre fonctionne mieux de toute façon. Tu aurais
peu-être inter à te bricoler un fichier xorg.conf avec les caractéristiques
de ton écran la résolution voulue.


--
Bruno
Bifidus
Le #21274051
On 26 fév, 15:37, Lucas Levrel
> Quand j'ouvre une session non graphique, puis retourne sous ma session
> graphique, les couleurs sont psychédéliques, inutilisables (les
> polices sont trop déformées pour être lues).
> Pour contourner le problème, je quitte ma session et la relance, mais
> ça m'oblige à perdre tous les travaux en cours.

/var/log/Xorg.0.log dit-il quelque chose d'intéressant ?



Je serais bien incapable de le savoir.
Le fichier existe, je l'ai ouvert avec Gedit.
Je le copiecolle ici ?
jp willm
Le #21274141
Hello,

bruno666 a écrit :
Il me semble que le pilote libre fonctionne mieux de toute façon. Tu aurais
peu-être inter à te bricoler un fichier xorg.conf avec les caractéristiques
de ton écran la résolution voulue.



J'ai vainement essayé de faire fonctionner une radeon7000 sous ubuntu
9.10. La 3D ne fonctionnait pas avec vesa.

J'ai essayé fgrlx, puis deux pilotes ati.

D'après les recherches que j'avais faites, certaines cartes ati ne
fonctionnent pas (du moins la 3D) sous ubuntu 9.10 (voir ubuntu ati sur
google)


J'ai finalement installé une ubuntu 9.04 et la 3D fonctionnait d'office.

Evidemment c'est loin d'être parfait, ou comparable à du Intel gma ou du
nvidia, mais on peut au moins aller sur googleearth, lancer stellarium
ou encore jouer à certains jeux 3D.



--
http://perso.orange.fr/willms/index.html
Hugolino
Le #21276711
Le 26-02-2010, Bifidus
On 26 fév, 15:37, Lucas Levrel
> > Quand j'ouvre une session non graphique, puis retourne sous ma session
> > graphique, les couleurs sont psychédéliques, inutilisables (les
> > polices sont trop déformées pour être lues).
> > Pour contourner le problème, je quitte ma session et la relance, mais
> > ça m'oblige à perdre tous les travaux en cours.
>
> /var/log/Xorg.0.log dit-il quelque chose d'intéressant ?

Je serais bien incapable de le savoir.
Le fichier existe, je l'ai ouvert avec Gedit.
Je le copiecolle ici ?



Le monsieur te demande s'il dit quelquechose d'intéressant, et tu peux
l'ouvrir, donc : non tu ne le copie-colles pas ici.
Tu finger-ass-plop un peu parce que tu n'es pas sur la hotline ubuntu:
c'est à dire qu'on veut bien lever un doute qui subsisterait après
l'étude de ce fichier, mais on ne va pas faire l'étude à ta place...


--
Software is like sex. It's better when it's free... (Linus Torvalds)
Hugo (né il y a 1 446 603 355 secondes)
moi-meme
Le #21277081
Le Fri, 26 Feb 2010 09:54:54 -0800, Bifidus a écrit :

Le fichier existe, je l'ai ouvert avec Gedit.



c'est bien de l'ouvrir. C'est mieux de le lire

Au moins pour faire le tri des informations et d'essayer de comprendre.

et nous livrer le résultat de tes réflexions.
Rémi Moyen
Le #21280791
Bifidus a écrit :

/var/log/Xorg.0.log dit-il quelque chose d'intéressant ?



Je serais bien incapable de le savoir.
Le fichier existe, je l'ai ouvert avec Gedit.
Je le copiecolle ici ?



Histoire d'être un peu plus constructif que les autres réponses, tu peux
regarder si il y a des lignes qui commencent par (EE), ou aussi comparer
le fichier juste après ouverture de ta première session (quand tout est
OK) et après que le problème soit apparu : les lignes en plus à la fin
(si il y en a) seront sans doute liées à ton problème.

Sur des problèmes liés au matériel, tu peux aussi trouver des messages
dans la sortie de 'dmesg' (ou /var/log/dmesg, c'est la même chose), ou
quelque fois dans /var/log/syslog (ou autre fichier de /var/log, les
noms varient suivant les distrib...). Idem, compare avant et après le
problème.
--
Rémi Moyen
Lucas Levrel
Le #21291811
Le 27 février 2010, Rémi Moyen a écrit :

/var/log/Xorg.0.log dit-il quelque chose d'intéressant ?





Histoire d'être un peu plus constructif que les autres réponses, tu peux
regarder si il y a des lignes qui commencent par (EE), ou aussi comparer
le fichier juste après ouverture de ta première session (quand tout est
OK) et après que le problème soit apparu : les lignes en plus à la fin
(si il y en a) seront sans doute liées à ton problème.



Tu peux aussi regarder les lignes (WW), normalement il n'y en a pas trop
(la signification de ces codes est donnée au début du fichier).

Tu peux poster /etc/X11/xorg.conf s'il existe.
--
LL
Publicité
Poster une réponse
Anonyme