probleme crypt

Le
mickey
Bonjour,

Est-ce que quelqu'un saurait pourquoi lorsque je fais
crypt(passWord)
le résultat donné n'est pas accepté par htaccess ?
J'ai un peu tout tenté mais je ne parviens qu'à obtenir une chaine de 8
caractères alors que j'en attends 13.

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Olivier Miakinen
Le #6476231

Est-ce que quelqu'un saurait pourquoi lorsque je fais
crypt(passWord)
le résultat donné n'est pas accepté par htaccess ?
J'ai un peu tout tenté mais je ne parviens qu'à obtenir une chaine de 8
caractères alors que j'en attends 13.


D'après la doc, il peut y avoir plusieurs types de résultats, et donc
plusieurs longueurs, selon le « salt ».

Essaye de lui passer un salt de deux lettres, pour voir. Aussi, vérifie
que CRYPT_STD_DES vaut bien 1.

mickey
Le #6479621
Olivier Miakinen wrote:


Est-ce que quelqu'un saurait pourquoi lorsque je fais
crypt(passWord)
le résultat donné n'est pas accepté par htaccess ?
J'ai un peu tout tenté mais je ne parviens qu'à obtenir une chaine de 8
caractères alors que j'en attends 13.


D'après la doc, il peut y avoir plusieurs types de résultats, et donc
plusieurs longueurs, selon le « salt ».

Essaye de lui passer un salt de deux lettres, pour voir. Aussi, vérifie
que CRYPT_STD_DES vaut bien 1.


Oui merci tout fonctionne. L'erreur venait de la table SQL qui stocke les
mots de passe. La taille du champ était à 8 caractères...


Publicité
Poster une réponse
Anonyme