Probleme dans mon fhchier php.ini

Le
JuliouZ
Bonjour,
Voilà je cherche a faire tourner Apache + PHP + Oracle 10g Database sur
un meme serveur.
Mon php doit pouvoir lire dans la base Oracle.

Et la MON PROBLEME : Quand je redémarre Apache avec un fichier php.ini
dans le répertoire /usr/local/apache/php/ Bah je n'ai plus de php qui
fonctionne. Si je vire le PHP.ini ca remarche.

Le hic c'est que ca fait des semaines que j'essai de lui faire
interpretter les fonctions OCI8 ou ORA_ mais en vain.

Versions :

- Apache : 2.2.4
- PHP : 5.2.1
- Oracle 10.2.0.1 Database

Installation d'apache :
--
J'ai installer Apache avec la commande ci dessous :

./configure --prefix=/usr/local/apache --enable-so --enable-rewrite
Make
Make install

J'ai rajouté la ligne /usr/local/apache2/lib dans le fichier
/etc/ld.so.conf puis j'ai fait un ldconfig

Installation de PHP :

./configure --with-apxs2=/usr/local/apache/bin/apxs
--prefix=/usr/local/apache/php
--with-config-file-path=/usr/local/apache/php --with-zlib --with-gettext
--with-gdbm --with-oracle=/oracle/ora102 (j'ai testé avec aussi le
with-oci8=/oracle/ora102)

Pour info mon Oracle_HOME=/oracle/ora102 et mon tnsnames dans
/oracle/ora102/network/admin/tnsnames.ora

Make
Make install

copy de php.in-recommanded dans /usr/local/apache/php/php.ini

Et la MON PROBLEME : Quand je redémarre Apache avec un fichier php.ini
dans le répertoire /usr/local/apache/php/ Bah je n'ai plus de php qui
fonctionne. Si je vire le PHP.ini ca remarche.

Avec le with-oci8=/oracle/ora102 j'arrive pas a me connecter a ma base,
alors que j'exporte bien les variables, j'ai meme testé des PutEnv, des
SetEnv pour mon TNSADMIN, mon ORACLE_HOME et mon ORACLE_SID.

Ensuite j'ai testé une nouvelle install, et toujours le meme probleme
avec le fichier php.ini, j'ai installé OCI8 via PECL et idem j'arrive
pas a me connecter. j'ai des erreurs du type 'OCIEnvNlsCreate() failed'

Si quelqu'un peut m'aider ce serait bien sympa parce que je suis
completement bloqué.
Merci et désolé pour le long discours mais c'est pour bien décrir mon
problème

Julien
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
P'tit Marcel
Le #59388
Et la MON PROBLEME : Quand je redémarre Apache avec un fichier php.ini
dans le répertoire /usr/local/apache/php/ Bah je n'ai plus de php qui
fonctionne. Si je vire le PHP.ini ca remarche.


Conclusion : soit Apache n'a pas le droit de lire le fichier php.ini,
soit son contenu n'est pas bon.

Le hic c'est que ca fait des semaines que j'essai de lui faire
interpretter les fonctions OCI8 ou ORA_ mais en vain.


as-tu vérifié les paramètres OCI dans le php.ini ? Il faut peut être
décommenter ou corriger les lignes kivontbien par exemple dans les
chapitres Windows Extensions/php_oci8 ou Module Settings/OCI8...

regarde aussi l'introduction au chapitre Oracle du manuel php :
http://fr.php.net/manual/fr/ref.oci8.php


eça
--
P'tit Marcel
stats sur les forums modérés http://www.centrale-lyon.org/ng/

Publicité
Poster une réponse
Anonyme